extra/thunderbird fixes

This commit is contained in:
Kevin Mihelich 2015-06-12 01:09:39 +00:00
parent b6ecca628f
commit 63bd9eb49b
3 changed files with 116 additions and 127 deletions

View file

@ -35,9 +35,9 @@ options=('!emptydirs' '!makeflags')
sha256sums=('7655039a9a2d5d169f5b43d2c737007dbaa42fa767f7bfbfde8ae46b05e4ab71'
'25085e4f147174f88541896673f741a968a6acf13c3f10432e81083416ef5611'
'3fba13d88aeb003ab0811ef739463858172ce0662a1c7d62835df3d83ddbb8fb'
'9049ab3f9600a1592a54c41a166c76e046c393e1cfe7c4e769155b7317d197ee'
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
'8010bc3abff71cdaa3624ebbddbc7baaae4cda7ad093ad60d3c3e841c1141872')
'1ecdb17848df46c1820bcf071b24e588f29f99ba860821d2b960c75f4ff1c6a4')
prepare() {
cd comm-esr${pkgver%%.*}

View file

@ -1,23 +1,23 @@
--- mozilla/js/src/configure.orig 2014-07-22 18:38:00.736218651 -0600
+++ mozilla/js/src/configure 2014-07-22 18:41:43.420479891 -0600
@@ -6153,99 +6153,9 @@
--- ./mozilla/configure.orig 2015-06-11 19:05:34.195096563 -0600
+++ ./mozilla/configure 2015-06-11 19:06:44.405101697 -0600
@@ -7096,98 +7096,9 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:6159: checking for ARM SIMD support in compiler" >&5
-echo "configure:7102: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6163 "configure"
-#line 7106 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:6170: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-if { (eval echo configure:7113: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
@ -40,23 +40,127 @@
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:6193: checking ARM version support in compiler" >&5
-echo "configure:7136: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:6198: checking for ARM NEON support in compiler" >&5
-echo "configure:7141: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6202 "configure"
-#line 7145 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:6209: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-if { (eval echo configure:7152: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_NEON 1
-EOF
-
- HAVE_ARM_NEON=1
-
- if test -n "$ARM_ARCH"; then
- if test "$ARM_ARCH" -lt 7; then
- BUILD_ARM_NEON=
- else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
- fi
- fi
- fi
-
-fi # CPU_ARCH = arm
-
-
+HAVE_ARM_NEON=0
+BUILD_ARM_NEON=0
+HAVE_ARM_SIMD=0
--- ./mozilla/js/src/configure.orig 2015-06-11 19:05:34.155096560 -0600
+++ ./mozilla/js/src/configure 2015-06-11 19:07:17.065104453 -0600
@@ -6235,99 +6235,9 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:6241: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6245 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:6252: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_SIMD 1
-EOF
-
- HAVE_ARM_SIMD=1
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:6275: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:6280: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6284 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:6291: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
@ -103,107 +207,3 @@
--- mozilla/configure.orig 2014-12-17 17:29:25.130301121 -0700
+++ mozilla/configure 2014-12-17 17:30:11.155242482 -0700
@@ -6975,98 +6975,9 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:6981: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6985 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:6992: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_SIMD 1
-EOF
-
- HAVE_ARM_SIMD=1
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:7015: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:7020: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 7024 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:7031: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define HAVE_ARM_NEON 1
-EOF
-
- HAVE_ARM_NEON=1
-
- if test -n "$ARM_ARCH"; then
- if test "$ARM_ARCH" -lt 7; then
- BUILD_ARM_NEON=
- else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
- fi
- fi
- fi
-
-fi # CPU_ARCH = arm
-
-
+HAVE_ARM_NEON=0
+BUILD_ARM_NEON=0
+HAVE_ARM_SIMD=0

View file

@ -1,14 +1,3 @@
diff -upr comm-esr31.orig/config/baseconfig.mk comm-esr31/config/baseconfig.mk
--- comm-esr31.orig/config/baseconfig.mk 2014-07-22 09:44:23.000000000 +0300
+++ comm-esr31/config/baseconfig.mk 2014-07-22 09:46:30.000000000 +0300
@@ -1,6 +1,6 @@
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
MOZILLA_SRCDIR = $(topsrcdir)/mozilla
MOZDEPTH = $(DEPTH)/mozilla
diff -upr comm-esr31.orig/mozilla/config/baseconfig.mk comm-esr31/mozilla/config/baseconfig.mk
--- comm-esr31.orig/mozilla/config/baseconfig.mk 2014-07-22 09:44:22.000000000 +0300
+++ comm-esr31/mozilla/config/baseconfig.mk 2014-07-22 09:46:45.000000000 +0300