mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5-webengine to 5.8.0-1
This commit is contained in:
parent
913562bb97
commit
63de5246b2
2 changed files with 60 additions and 7 deletions
|
@ -9,9 +9,9 @@
|
|||
buildarch=12
|
||||
|
||||
pkgname=qt5-webengine
|
||||
_qtver=5.7.1
|
||||
_qtver=5.8.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
|
@ -26,10 +26,10 @@ source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submo
|
|||
qtwebengine-5.7.0-icu58.patch
|
||||
system-ffmpeg.patch)
|
||||
|
||||
md5sums=('c90fba515fb33c091904fe2cadbb345a'
|
||||
md5sums=('6e7fb2be161c6db4d988a4f5b329672f'
|
||||
'2a1610b34204102938a24154a52e5571'
|
||||
'123d4d0d7db7473649ff2b5650330cc4'
|
||||
'c2ffb0073e6f67a0a77a8fe39f9e9859'
|
||||
'9d225d1bf83ea45dbf6556d30d35fcb8'
|
||||
'9f79b14f7c5ff603c1fcd87f37a8904f')
|
||||
|
||||
prepare() {
|
||||
|
@ -54,8 +54,7 @@ build() {
|
|||
cd build
|
||||
|
||||
export PATH="$srcdir/bin:$PATH"
|
||||
export CXXFLAGS+=" -fno-delete-null-pointer-checks"
|
||||
qmake WEBENGINE_CONFIG+="use_proprietary_codecs system_ffmpeg use_system_icu" ../${_pkgfqn}
|
||||
qmake CONFIG+="proprietary-codecs" WEBENGINE_CONFIG+="use_proprietary_codecs use_system_ffmpeg use_system_icu" ../${_pkgfqn}
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -1,4 +1,58 @@
|
|||
diff -Naur qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
From 424584b4984bde7c831f42e9fb47f1ad583a1c46 Mon Sep 17 00:00:00 2001
|
||||
From: jshin <jshin@chromium.org>
|
||||
Date: Fri, 21 Oct 2016 01:15:50 -0700
|
||||
Subject: [PATCH] Update aspirational_scripts per Unicode 9
|
||||
|
||||
This is a preparation to update ICU to 58.1.
|
||||
Without this change, ICU update CL cannot be tested on
|
||||
trybots because a compile will fail due to '#error' checking
|
||||
if ICU version is less than 58.
|
||||
|
||||
BUG=637001
|
||||
TEST=None
|
||||
TBR=pkasting@chromium.org
|
||||
|
||||
Review-Url: https://chromiumcodereview.appspot.com/2436113003
|
||||
Cr-Commit-Position: refs/heads/master@{#426749}
|
||||
---
|
||||
components/url_formatter/url_formatter.cc | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/components/url_formatter/url_formatter.cc b/components/url_formatter/url_formatter.cc
|
||||
index 4455db3..2b82c0c 100644
|
||||
--- qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/components/url_formatter/url_formatter.cc
|
||||
+++ qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/components/url_formatter/url_formatter.cc
|
||||
@@ -428,9 +428,9 @@ void IDNSpoofChecker::SetAllowedUnicodeSet(UErrorCode* status) {
|
||||
// section at
|
||||
// http://www.unicode.org/Public/security/latest/xidmodifications.txt) are
|
||||
// are added to the allowed set. The list has to be updated when a new
|
||||
- // version of Unicode is released. The current version is 8.0.0 and ICU 58
|
||||
- // will have Unicode 9.0 data.
|
||||
-#if U_ICU_VERSION_MAJOR_NUM < 58
|
||||
+ // version of Unicode is released. The current version is 9.0.0 and ICU 60
|
||||
+ // will have Unicode 10.0 data.
|
||||
+#if U_ICU_VERSION_MAJOR_NUM < 60
|
||||
const icu::UnicodeSet aspirational_scripts(
|
||||
icu::UnicodeString(
|
||||
// Unified Canadian Syllabics
|
||||
@@ -444,13 +444,13 @@ void IDNSpoofChecker::SetAllowedUnicodeSet(UErrorCode* status) {
|
||||
// Yi
|
||||
"\\uA000-\\uA48C"
|
||||
// Miao
|
||||
- "\\U00016F00-\\U00016F44\\U00016F50-\\U00016F7F"
|
||||
+ "\\U00016F00-\\U00016F44\\U00016F50-\\U00016F7E"
|
||||
"\\U00016F8F-\\U00016F9F]",
|
||||
-1, US_INV),
|
||||
*status);
|
||||
allowed_set.addAll(aspirational_scripts);
|
||||
#else
|
||||
-#error "Update aspirational_scripts per Unicode 9.0"
|
||||
+#error "Update aspirational_scripts per Unicode 10.0"
|
||||
#endif
|
||||
|
||||
// U+0338 is included in the recommended set, while U+05F4 and U+2027 are in
|
||||
diff -Naur qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
--- qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp 2016-11-15 17:07:38.680665385 -0800
|
||||
+++ qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp 2016-11-15 17:12:17.564001354 -0800
|
||||
@@ -26,6 +26,9 @@
|
||||
|
|
Loading…
Reference in a new issue