mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/irqbalance to 1.3.0-1
This commit is contained in:
parent
4dbff7ea14
commit
63f0e69b74
4 changed files with 43 additions and 54 deletions
|
@ -1,32 +0,0 @@
|
|||
From b0f77c10fc4561463b59b12cba0bfd69d7c73934 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
|
||||
Date: Tue, 10 Jan 2017 09:51:32 +0200
|
||||
Subject: [PATCH] fix aarch64 compile error due to undefined variable
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
fixes #36
|
||||
|
||||
Signed-off-by: Timo Teräs <timo.teras@iki.fi>
|
||||
---
|
||||
procinterrupts.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/procinterrupts.c b/procinterrupts.c
|
||||
index 6b37a88..c5c034c 100644
|
||||
--- a/procinterrupts.c
|
||||
+++ b/procinterrupts.c
|
||||
@@ -148,6 +148,9 @@ GList* collect_full_irq_list()
|
||||
char *line = NULL;
|
||||
size_t size = 0;
|
||||
char *irq_name, *irq_mod, *savedptr, *last_token, *p;
|
||||
+#ifdef AARCH64
|
||||
+ char *tmp;
|
||||
+#endif
|
||||
|
||||
file = fopen("/proc/interrupts", "r");
|
||||
if (!file)
|
||||
--
|
||||
2.11.0
|
||||
|
|
@ -3,38 +3,39 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed dependency on numactl
|
||||
# - upstream patch for AArch64
|
||||
|
||||
pkgname=irqbalance
|
||||
pkgver=1.2.0
|
||||
pkgver=1.3.0
|
||||
pkgrel=1
|
||||
pkgdesc="IRQ balancing daemon for SMP systems"
|
||||
arch=('i686' 'x86_64')
|
||||
arch=('x86_64')
|
||||
url="https://github.com/Irqbalance/irqbalance"
|
||||
license=('GPL')
|
||||
depends=('glib2' 'libcap-ng')
|
||||
backup=('etc/irqbalance.env')
|
||||
depends=('glib2' 'libcap-ng' 'libsystemd')
|
||||
makedepends=('systemd')
|
||||
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
|
||||
irqbalance.service
|
||||
0001-fix-aarch64-compile-error-due-to-undefined-variable.patch)
|
||||
md5sums=('d1b3f2c31389f2ab955dfa3d02f9f296'
|
||||
'767061c257b26cc3e3c4a5e462166579'
|
||||
'c926a091bc1a50102fd9d4c91eac4fe5')
|
||||
config.patch)
|
||||
sha1sums=('2797747812d65fcfa83d7e3610857e6326df933a'
|
||||
'f5750dd9b53ef77c3dcb46ea70622c6c4d462888')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 -i ../0001-fix-aarch64-compile-error-due-to-undefined-variable.patch
|
||||
patch -p1 < ../config.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
./autogen.sh
|
||||
./configure --prefix=/usr --sbindir=/usr/bin
|
||||
./configure --prefix=/usr --sbindir=/usr/bin --with-systemd
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
make install DESTDIR="$pkgdir"
|
||||
install -D -m644 ../irqbalance.service \
|
||||
"$pkgdir"/usr/lib/systemd/system/irqbalance.service
|
||||
|
||||
install -D -m644 misc/irqbalance.service "$pkgdir"/usr/lib/systemd/system/irqbalance.service
|
||||
install -D -m644 misc/irqbalance.env "$pkgdir"/etc/irqbalance.env
|
||||
install -D -m644 misc/90-irqbalance.rules "$pkgdir"/usr/lib/udev/rules.d/90-irqbalance.rules
|
||||
}
|
||||
|
|
29
extra/irqbalance/config.patch
Normal file
29
extra/irqbalance/config.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index 38a1bee..5e9cc03 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -53,9 +53,6 @@ AC_ARG_WITH([systemd],
|
||||
AS_IF(
|
||||
[test "x$with_systemd" = xyes], [
|
||||
PKG_CHECK_MODULES([SYSTEMD], [libsystemd], [journal_lib=yes], [journal_lib=no])
|
||||
- AS_IF([test "x$journal_lib" != "xyes"], [
|
||||
- PKG_CHECK_MODULES([SYSTEMD], [libsystemd-journal], [journal_lib=yes])
|
||||
- ])
|
||||
AC_DEFINE(HAVE_LIBSYSTEMD, 1, [systemd support])
|
||||
AC_CHECK_LIB([systemd], [sd_journal_print_with_location])
|
||||
AC_CHECK_LIB([systemd], [sd_journal_print])
|
||||
diff --git a/misc/irqbalance.service b/misc/irqbalance.service
|
||||
index e9a5527..a8451d9 100644
|
||||
--- a/misc/irqbalance.service
|
||||
+++ b/misc/irqbalance.service
|
||||
@@ -3,8 +3,8 @@ Description=irqbalance daemon
|
||||
ConditionVirtualization=!container
|
||||
|
||||
[Service]
|
||||
-EnvironmentFile=/path/to/irqbalance.env
|
||||
-ExecStart=/usr/sbin/irqbalance --foreground $IRQBALANCE_ARGS
|
||||
+EnvironmentFile=/etc/irqbalance.env
|
||||
+ExecStart=/usr/bin/irqbalance --foreground $IRQBALANCE_ARGS
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
|
@ -1,9 +0,0 @@
|
|||
[Unit]
|
||||
Description=CPU Interrupt Request Balancer
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/irqbalance --foreground
|
||||
ExecReload=/bin/kill -HUP $MAINPID
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
Loading…
Reference in a new issue