mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/chromium to 53.0.2785.89-1
This commit is contained in:
parent
75f245f8db
commit
63f75729c2
4 changed files with 9 additions and 74 deletions
|
@ -1,7 +1,7 @@
|
|||
From 8d174a47fce05738c247d1e7f5247b6e26461492 Mon Sep 17 00:00:00 2001
|
||||
From 61fa940ff939b5e5c725469c5e546dc840ccf1a2 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 6 Mar 2016 20:26:53 -0700
|
||||
Subject: [PATCH 1/2] system ffmpeg fixes
|
||||
Subject: [PATCH] system ffmpeg fixes
|
||||
|
||||
---
|
||||
media/ffmpeg/ffmpeg_common.h | 5 -----
|
||||
|
@ -32,10 +32,10 @@ index fa5dfee..db045f3 100644
|
|||
#include <libavutil/avutil.h>
|
||||
#include <libavutil/imgutils.h>
|
||||
diff --git a/media/filters/ffmpeg_demuxer.cc b/media/filters/ffmpeg_demuxer.cc
|
||||
index 2785c0a..40de4b1 100644
|
||||
index 83b1879..6d5e6f0 100644
|
||||
--- a/media/filters/ffmpeg_demuxer.cc
|
||||
+++ b/media/filters/ffmpeg_demuxer.cc
|
||||
@@ -1101,24 +1101,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
||||
@@ -1106,24 +1106,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
||||
// If no estimate is found, the stream entry will be kInfiniteDuration().
|
||||
std::vector<base::TimeDelta> start_time_estimates(format_context->nb_streams,
|
||||
kInfiniteDuration());
|
||||
|
@ -61,5 +61,5 @@ index 2785c0a..40de4b1 100644
|
|||
std::unique_ptr<MediaTracks> media_tracks(new MediaTracks());
|
||||
AVStream* audio_stream = NULL;
|
||||
--
|
||||
2.9.0
|
||||
2.9.3
|
||||
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
From fd390d689c538c2d315430fecde8e65863984b2d Mon Sep 17 00:00:00 2001
|
||||
From: "riku.voipio" <riku.voipio@linaro.org>
|
||||
Date: Tue, 1 Mar 2016 08:02:43 -0800
|
||||
Subject: [PATCH 2/2] Linux Sandbox: whitelist arm64 syscalls
|
||||
|
||||
On debian/arm64, two syscalls needed whitelisting for chromium to work with seccomp:
|
||||
|
||||
epoll_pwait, replacing epoll_wait which is a legacy syscall not available on arm64. epoll_wait implmentation in glibc calls epoll_pwait behind scenes, so this needs to be enabled.
|
||||
|
||||
getrlimit, missing #ifdef for arm64 in several policy definitions. test for arm64 added for each case.
|
||||
|
||||
BUG=581018
|
||||
R=keescook@chromium.org,jln@chromium.org,rsesek@chromium.org
|
||||
TEST=Start chrome on arm64 with seccomp enabled kernel
|
||||
|
||||
Review URL: https://codereview.chromium.org/1613883002
|
||||
|
||||
Cr-Commit-Position: refs/heads/master@{#378440}
|
||||
---
|
||||
services/shell/runner/host/linux_sandbox.cc | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/services/shell/runner/host/linux_sandbox.cc b/services/shell/runner/host/linux_sandbox.cc
|
||||
index 24461a5..33822bd 100644
|
||||
--- a/services/shell/runner/host/linux_sandbox.cc
|
||||
+++ b/services/shell/runner/host/linux_sandbox.cc
|
||||
@@ -38,12 +38,14 @@ intptr_t SandboxSIGSYSHandler(const struct sandbox::arch_seccomp_data& args,
|
||||
const sandbox::syscall_broker::BrokerProcess* broker_process =
|
||||
static_cast<const sandbox::syscall_broker::BrokerProcess*>(aux);
|
||||
switch (args.nr) {
|
||||
+#if !defined(__aarch64__)
|
||||
case __NR_access:
|
||||
return broker_process->Access(reinterpret_cast<const char*>(args.args[0]),
|
||||
static_cast<int>(args.args[1]));
|
||||
case __NR_open:
|
||||
return broker_process->Open(reinterpret_cast<const char*>(args.args[0]),
|
||||
static_cast<int>(args.args[1]));
|
||||
+#endif
|
||||
case __NR_faccessat:
|
||||
if (static_cast<int>(args.args[0]) == AT_FDCWD) {
|
||||
return broker_process->Access(
|
||||
--
|
||||
2.9.0
|
||||
|
|
@ -19,7 +19,7 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=52.0.2743.116
|
||||
pkgver=53.0.2785.89
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
|
@ -42,18 +42,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium.desktop
|
||||
chromium-widevine.patch
|
||||
PNGImageDecoder.patch
|
||||
chromium-52.0.2743.116-unset-madv_free.patch
|
||||
0001-system-ffmpeg-fixes.patch
|
||||
0002-Linux-Sandbox-whitelist-arm64-syscalls.patch)
|
||||
sha256sums=('a194ae1edb041024b3d4b6ba438f32fefdb6f1ecb24a96c50248a486b237a101'
|
||||
0001-system-ffmpeg-fixes.patch)
|
||||
sha256sums=('2e3c5f7b12b5b4f150b93004a718fb85778aeddc4df05bbf92b99a19a1c63dee'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
|
||||
'd9fd982ba6d50edb7743db6122b975ad1d3da5a9ad907c8ab7cf574395b186cd'
|
||||
'3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
|
||||
'2c9f39c04397898711ba9d5e008cf11e909d479e9af0627d4534206051cc77ef'
|
||||
'b2d301f48f603bd7b9ae5802aa9211a6a7991ea94e0e725b4c4272bdfd6c35db')
|
||||
'4a8907651ea25dd7753566799bea28b74b8cd512d3cbc40c34b6d9a43cb36e22')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
@ -76,15 +72,9 @@ prepare() {
|
|||
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
|
||||
patch -Np1
|
||||
|
||||
# Chromium 51 won't build without this patch. Not reported upstream yet AFAIK.
|
||||
patch -p1 -i "$srcdir"/PNGImageDecoder.patch
|
||||
|
||||
# Fix building with system ffmpeg
|
||||
patch -Np1 -i ../0001-system-ffmpeg-fixes.patch
|
||||
|
||||
# AArch64 fix
|
||||
patch -Np1 -i ../0002-Linux-Sandbox-whitelist-arm64-syscalls.patch
|
||||
|
||||
# Commentception – use bundled ICU due to build failures (50.0.2661.75)
|
||||
# See https://crbug.com/584920 and https://crbug.com/592268
|
||||
# ---
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/third_party/WebKit/Source/platform/image-decoders/png/PNGImageDecoder.cppg 2016-05-01 15:22:46.103607522 +0800
|
||||
+++ b/third_party/WebKit/Source/platform/image-decoders/png/PNGImageDecoder.cpp 2016-05-01 15:25:14.459753876 +0800
|
||||
@@ -234,7 +234,7 @@
|
||||
#endif
|
||||
png_uint_32 profileLength = 0;
|
||||
if (png_get_iCCP(png, info, &profileName, &compressionType, &profile, &profileLength)) {
|
||||
- setColorProfileAndTransform(profile, profileLength, imageHasAlpha, false /* useSRGB */);
|
||||
+ setColorProfileAndTransform((const char*)profile, profileLength, imageHasAlpha, false /* useSRGB */);
|
||||
}
|
||||
}
|
||||
#endif // PNG_iCCP_SUPPORTED
|
Loading…
Reference in a new issue