alarm/devtools-alarm to 20131107-1

This commit is contained in:
Kevin Mihelich 2014-01-22 01:39:39 +00:00
parent 8725cc1da5
commit 644a26462a
6 changed files with 44 additions and 61 deletions

View file

@ -1,31 +1,33 @@
diff -urN a/makechrootpkg.in b/makechrootpkg.in
--- a/makechrootpkg.in 2013-05-25 15:39:46.000000000 -0500
+++ b/makechrootpkg.in 2013-06-04 16:19:08.453803346 -0500
--- a/makechrootpkg.in 2013-11-07 06:57:03.000000000 -0700
+++ b/makechrootpkg.in 2014-01-21 18:25:01.778675214 -0700
@@ -48,6 +48,7 @@
echo ''
echo "Default makepkg args: $makepkg_args"
echo ''
+ echo '-C <dir> Set pacman cache to pass to arch-nspawn'
echo 'Flags:'
echo '-h This help'
echo '-c Clean the chroot before building'
+ echo '-C <dir> Set pacman cache to pass to arch-nspawn'
echo '-u Update the working copy of the chroot before building'
echo ' This is useful for rebuilds without dirtying the pristine'
echo ' chroot'
@@ -61,11 +62,12 @@
@@ -66,13 +67,14 @@
exit 1
}
-while getopts 'hcur:I:l:nT' arg; do
+while getopts 'hcuC:r:I:l:nT' arg; do
-while getopts 'hcur:I:l:nTD:d:' arg; do
+while getopts 'hcuC:r:I:l:nTD:d:' arg; do
case "$arg" in
h) usage ;;
c) clean_first=true ;;
D) bindmounts_ro+=(--bind-ro="$OPTARG") ;;
d) bindmounts_rw+=(--bind="$OPTARG") ;;
u) update_first=true ;;
+ C) cache_dir="$OPTARG" ;;
r) passeddir="$OPTARG" ;;
I) install_pkgs+=("$OPTARG") ;;
l) copy="$OPTARG" ;;
@@ -84,6 +86,10 @@
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '$passeddir'"
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot $chrootdir/root base-devel"
@@ -91,6 +93,10 @@
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
+if [ -n "$cache_dir" ]; then
+ cache_dir="-c $cache_dir"
@ -34,7 +36,7 @@ diff -urN a/makechrootpkg.in b/makechrootpkg.in
# Detect chrootdir filesystem type
chroottype=$(stat -f -c %T "$chrootdir")
@@ -346,7 +352,7 @@
@@ -373,7 +379,7 @@
download_sources
@ -42,4 +44,4 @@ diff -urN a/makechrootpkg.in b/makechrootpkg.in
+if arch-nspawn $cache_dir "$copydir" \
--bind-ro="$PWD:/startdir_host" \
--bind-ro="$SRCDEST:/srcdest_host" \
/chrootbuild
"${bindmounts_ro[@]}" "${bindmounts_rw[@]}" \

View file

@ -1,14 +1,14 @@
diff -urN a/arch-nspawn.in b/arch-nspawn.in
--- a/arch-nspawn.in 2013-05-25 15:39:46.000000000 -0500
+++ b/arch-nspawn.in 2013-06-04 16:22:20.718826563 -0500
@@ -74,8 +74,8 @@
--- a/arch-nspawn.in 2013-11-07 06:57:03.000000000 -0700
+++ b/arch-nspawn.in 2014-01-21 18:33:11.817113085 -0700
@@ -70,8 +70,8 @@
}
copy_hostconf () {
- cp -a /etc/pacman.d/gnupg "$working_dir/etc/pacman.d"
- echo "Server = $host_mirror" > $working_dir/etc/pacman.d/mirrorlist
- echo "Server = $host_mirror" >"$working_dir/etc/pacman.d/mirrorlist"
+ #cp -a /etc/pacman.d/gnupg "$working_dir/etc/pacman.d"
+ #echo "Server = $host_mirror" > $working_dir/etc/pacman.d/mirrorlist
+ #echo "Server = $host_mirror" >"$working_dir/etc/pacman.d/mirrorlist"
[[ -n $pac_conf ]] && cp $pac_conf $working_dir/etc/pacman.conf
[[ -n $makepkg_conf ]] && cp $makepkg_conf $working_dir/etc/makepkg.conf
[[ -n $pac_conf ]] && cp $pac_conf "$working_dir/etc/pacman.conf"
[[ -n $makepkg_conf ]] && cp $makepkg_conf "$working_dir/etc/makepkg.conf"

View file

@ -1,7 +1,7 @@
diff -urN a/makechrootpkg.in b/makechrootpkg.in
--- a/makechrootpkg.in 2013-06-04 16:19:08.453803346 -0500
+++ b/makechrootpkg.in 2013-06-04 16:29:16.961006377 -0500
@@ -306,7 +306,9 @@
--- a/makechrootpkg.in 2014-01-21 18:14:12.156219500 -0700
+++ b/makechrootpkg.in 2014-01-21 18:16:41.715633742 -0700
@@ -324,7 +324,9 @@
exit 1
fi

View file

@ -1,19 +1,19 @@
diff -urN a/arch-nspawn.in b/arch-nspawn.in
--- a/arch-nspawn.in 2013-06-04 16:22:20.718826563 -0500
+++ b/arch-nspawn.in 2013-06-04 17:42:52.282698873 -0500
@@ -98,7 +98,7 @@
eval $(grep '^CARCH=' "$working_dir/etc/makepkg.conf")
--- a/arch-nspawn.in 2014-01-21 18:16:31.735672829 -0700
+++ b/arch-nspawn.in 2014-01-21 18:17:31.245439755 -0700
@@ -97,7 +97,7 @@
machine_name="${working_dir//[![:alnum:]_-]/-}"
machine_name="${machine_name#-}"
-exec ${CARCH:+setarch "$CARCH"} systemd-nspawn 2>/dev/null \
+exec systemd-nspawn 2>/dev/null \
-D "$working_dir" \
--machine "${working_dir//\//-}" \
--machine "$machine_name" \
"${mount_args[@]}" \
diff -urN a/makechrootpkg.in b/makechrootpkg.in
--- a/makechrootpkg.in 2013-06-04 17:37:51.646420764 -0500
+++ b/makechrootpkg.in 2013-06-04 17:50:34.673206856 -0500
@@ -256,10 +256,10 @@
--- a/makechrootpkg.in 2014-01-21 18:17:21.820476669 -0700
+++ b/makechrootpkg.in 2014-01-21 18:17:31.245439755 -0700
@@ -272,10 +272,10 @@
# Ensure sources are downloaded
if [[ -n $SUDO_USER ]]; then
sudo -u $SUDO_USER env SRCDEST="$SRCDEST" BUILDDIR="$builddir" \

View file

@ -1,16 +0,0 @@
diff -urN a/arch-nspawn.in b/arch-nspawn.in
--- a/arch-nspawn.in 2013-08-20 13:23:41.830745058 -0600
+++ b/arch-nspawn.in 2013-08-20 13:24:29.500531210 -0600
@@ -98,8 +98,11 @@
eval $(grep '^CARCH=' "$working_dir/etc/makepkg.conf")
+machine_name="${working_dir//\//-}"
+machine_name="${machine_name#-}"
+
exec systemd-nspawn 2>/dev/null \
-D "$working_dir" \
- --machine "${working_dir//\//-}" \
+ --machine "$machine_name" \
"${mount_args[@]}" \
"$@"

View file

@ -6,8 +6,8 @@
pkgname=devtools-alarm
_pkgname=devtools
pkgver=20130525
pkgrel=2
pkgver=20131107
pkgrel=1
pkgdesc='Tools for Arch Linux ARM package maintainers'
arch=('any')
license=('GPL')
@ -19,16 +19,14 @@ source=("ftp://ftp.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
'0002-arch-nspawn-keep-mirrorlist.patch'
'0003-makechrootpkg-distcc.patch'
'0004-arch-nspawn-arm-fix.patch'
'0005-makechrootpkg-no-default-logging.patch'
'0006-machine-name.patch')
md5sums=('afec33a914471db8b8fb8ef65ee6b9ee'
'0005-makechrootpkg-no-default-logging.patch')
md5sums=('8b78e5f8e68d09864cf231c999ab222a'
'SKIP'
'2164cda16c7caf9789f2441d49fcdf77'
'8d229b27e16c74a5308b1f452a17d97e'
'1d0c06106bf633e555e2ce3cf26d30d5'
'a53f7dea2392ffede8f2a1012707f201'
'473f7128e088188121f5565e7ca34759'
'2e7d45805bb6f989052fbf3a75ad4bea')
'7b96700206f0832d8f9c72adeccb8f9f'
'ac6a4477565030c8e2bea08068e7597f'
'97a011ae19be82b932ef8abab83f9b6a'
'd7c5800ed19500e33e2c9cf89c41a86c'
'473f7128e088188121f5565e7ca34759')
prepare() {
cd ${srcdir}/${_pkgname}-${pkgver}
@ -37,7 +35,6 @@ prepare() {
patch -p1 -i "${srcdir}"/0003-makechrootpkg-distcc.patch
patch -p1 -i "${srcdir}"/0004-arch-nspawn-arm-fix.patch
patch -p1 -i "${srcdir}"/0005-makechrootpkg-no-default-logging.patch
patch -p1 -i "${srcdir}"/0006-machine-name.patch
}
build() {