mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-armv7 to 4.8.7-1
This commit is contained in:
parent
31fa09a470
commit
647c977bcb
16 changed files with 64 additions and 152 deletions
|
@ -1,7 +1,7 @@
|
|||
From 3df18d4dd1d141b3f3c7bff820019e15eafa20a9 Mon Sep 17 00:00:00 2001
|
||||
From 8537ea66c09bebc2be88c7e319b27e763842d89f Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 01/14] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 01/13] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From d048aa94a7e9a77bd30ca477b1134a40b5e5cbac Mon Sep 17 00:00:00 2001
|
||||
From 139fe01610d1c78c6ea9e402b9548f90e95a99bb Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 02/14] ARM: atags/fdt: retrieve MAC addresses from Marvell
|
||||
Subject: [PATCH 02/13] ARM: atags/fdt: retrieve MAC addresses from Marvell
|
||||
boot loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From a4b60b3619816e275328bdef6bd511cc0a579f34 Mon Sep 17 00:00:00 2001
|
||||
From 9d676096d4aa4d2cdd03c242dcb59862e6476562 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 03/14] SMILE Plug device tree file
|
||||
Subject: [PATCH 03/13] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -205,5 +205,5 @@ index 0000000..d01308a
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 7863afeb305484f5ce7f9c16c36f2e809b832a6f Mon Sep 17 00:00:00 2001
|
||||
From d6bde52e9ae175a59da46054f13e392481b9ca20 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 04/14] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 04/13] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -34,5 +34,5 @@ index 42296e5..e5ce6d2 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 7cdb4b24dc687480eee4cc0908acb5ee582394fd Mon Sep 17 00:00:00 2001
|
||||
From 82c2da591ba6285523566a5323962f5fb95b3869 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
|
||||
Subject: [PATCH 05/13] net/smsc95xx: Allow mac address to be set as a
|
||||
parameter
|
||||
|
||||
---
|
||||
|
@ -92,5 +92,5 @@ index dc989a8..912be75 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 755e5fb29244c9d343ab791588e1c8e7c543aae4 Mon Sep 17 00:00:00 2001
|
||||
From e888e5f96c57ea0d8e75084d4bc9e7c6c8812786 Mon Sep 17 00:00:00 2001
|
||||
From: dobatog <dobatog@gmail.com>
|
||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 06/14] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
Subject: [PATCH 06/13] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
related to input routing signals.
|
||||
|
||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||
|
@ -45,5 +45,5 @@ index cd8c02b..95e6b11 100644
|
|||
/* input mux */
|
||||
{"Capture Source", "Line", "Line Input"},
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From ef88d745d8d3e2672f5ba252010da8a1f5b3b136 Mon Sep 17 00:00:00 2001
|
||||
From 9332f8007064d41fe06611671ba7cecffe18cb0b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 07/14] set default cubietruck led triggers
|
||||
Subject: [PATCH 07/13] set default cubietruck led triggers
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -29,5 +29,5 @@ index 83f39b0..15e9626 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 7f2f9131be193f8d49271ccb7e11841c4d182da9 Mon Sep 17 00:00:00 2001
|
||||
From 8289d8d3cdc80e9093d65d36b73eacfc75c67569 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 7 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 08/14] USB armory support
|
||||
Subject: [PATCH 08/13] USB armory support
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 5 +
|
||||
|
@ -677,5 +677,5 @@ index 0000000..33719f7
|
|||
+ status = "okay";
|
||||
+};
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From c0531d926d5c9951e4405d87ad22ed8469e5abf9 Mon Sep 17 00:00:00 2001
|
||||
From 8b1c799d72b295a039618b61f5934008b62a15bb Mon Sep 17 00:00:00 2001
|
||||
From: Vanessa Maegima <vanessa.maegima@nxp.com>
|
||||
Date: Mon, 1 Aug 2016 09:54:14 -0300
|
||||
Subject: [PATCH 09/14] ARM: dts: imx6ul-pico-hobbit: Add Wifi support
|
||||
Subject: [PATCH 09/13] ARM: dts: imx6ul-pico-hobbit: Add Wifi support
|
||||
|
||||
imx6ul-pico-hobbit has a bcm4339 wifi chip connected to usdhc2 port.
|
||||
|
||||
|
@ -59,5 +59,5 @@ index 86f68fa..d3dfa5f 100644
|
|||
fsl,pins = <
|
||||
MX6UL_PAD_ENET1_TX_DATA1__ENET2_MDIO 0x1b0b0
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 6d06f98be65397f6b80d8af6924a250830c7b587 Mon Sep 17 00:00:00 2001
|
||||
From cf306f4ec83a1f645d01e01d1d18c555e6b766e5 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 11 Aug 2016 00:42:37 -0600
|
||||
Subject: [PATCH 10/14] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
Subject: [PATCH 10/13] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
voltage
|
||||
|
||||
Set a higher minimum voltage to help reboot issue.
|
||||
|
@ -26,5 +26,5 @@ index 58ad48e7..f7c5571 100644
|
|||
regulator-always-on;
|
||||
regulator-boot-on;
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 25245e060b4626a625e1849b027b3bebc9696ff4 Mon Sep 17 00:00:00 2001
|
||||
From 17998b802d18651bd4bfd6ee32e10c166f484e76 Mon Sep 17 00:00:00 2001
|
||||
From: Tony Lindgren <tony@atomide.com>
|
||||
Date: Fri, 30 Sep 2016 11:10:10 -0700
|
||||
Subject: [PATCH 12/14] usb: musb: Call pm_runtime from musb_gadget_queue
|
||||
Subject: [PATCH 11/13] usb: musb: Call pm_runtime from musb_gadget_queue
|
||||
|
||||
If we're booting pandaboard using NFSroot over built-in g_ether, we
|
||||
can get the following after booting once and doing a warm reset:
|
||||
|
@ -52,5 +52,5 @@ index 6d1e975..8ccc1b1 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
|
@ -1,86 +0,0 @@
|
|||
From b947f36e0453d0bc466fd88a883f3c4a50e6f6a1 Mon Sep 17 00:00:00 2001
|
||||
From: Tony Lindgren <tony@atomide.com>
|
||||
Date: Fri, 30 Sep 2016 11:10:09 -0700
|
||||
Subject: [PATCH 11/14] usb: musb: Fix hardirq-safe hardirq-unsafe lock order
|
||||
error
|
||||
|
||||
If we configure musb with 2430 glue as a peripheral, and then rmmod
|
||||
omap2430 module, we'll get the following error:
|
||||
|
||||
[ INFO: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected ]
|
||||
...
|
||||
rmmod/413 [HC0[0]:SC0[0]:HE0:SE1] is trying to acquire:
|
||||
(&phy->mutex){+.+.+.}, at: [<c04b9fd0>] phy_power_off+0x1c/0xb8
|
||||
[ 204.678710]
|
||||
and this task is already holding:
|
||||
(&(&musb->lock)->rlock){-.-...}, at: [<bf3a482c>]
|
||||
musb_gadget_stop+0x24/0xec [musb_hdrc]
|
||||
which would create a new lock dependency:
|
||||
(&(&musb->lock)->rlock){-.-...} -> (&phy->mutex){+.+.+.}
|
||||
...
|
||||
|
||||
This is because some glue layers expect musb_platform_enable/disable
|
||||
to be called with spinlock held, and 2430 glue layer has USB PHY on
|
||||
the I2C bus using a mutex.
|
||||
|
||||
We could fix the glue layers to take the spinlock, but we still have
|
||||
a problem of musb_plaform_enable/disable being called in an unbalanced
|
||||
manner. So that would still lead into USB PHY enable/disable related
|
||||
problems for omap2430 glue layer.
|
||||
|
||||
While it makes sense to only enable USB PHY when needed from PM point
|
||||
of view, in this case we just can't do it yet without breaking things.
|
||||
So let's just revert phy_enable/disable related changes instead and
|
||||
reconsider this after we have fixed musb_platform_enable/disable to
|
||||
be balanced.
|
||||
|
||||
Fixes: a83e17d0f73b ("usb: musb: Improve PM runtime and phy handling
|
||||
for 2430 glue layer")
|
||||
Signed-off-by: Tony Lindgren <tony@atomide.com>
|
||||
Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
|
||||
---
|
||||
drivers/usb/musb/omap2430.c | 7 ++-----
|
||||
1 file changed, 2 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/drivers/usb/musb/omap2430.c b/drivers/usb/musb/omap2430.c
|
||||
index 0b4cec9..dae92de 100644
|
||||
--- a/drivers/usb/musb/omap2430.c
|
||||
+++ b/drivers/usb/musb/omap2430.c
|
||||
@@ -337,6 +337,7 @@ static int omap2430_musb_init(struct musb *musb)
|
||||
}
|
||||
musb->isr = omap2430_musb_interrupt;
|
||||
phy_init(musb->phy);
|
||||
+ phy_power_on(musb->phy);
|
||||
|
||||
l = musb_readl(musb->mregs, OTG_INTERFSEL);
|
||||
|
||||
@@ -373,8 +374,6 @@ static void omap2430_musb_enable(struct musb *musb)
|
||||
struct musb_hdrc_platform_data *pdata = dev_get_platdata(dev);
|
||||
struct omap_musb_board_data *data = pdata->board_data;
|
||||
|
||||
- if (!WARN_ON(!musb->phy))
|
||||
- phy_power_on(musb->phy);
|
||||
|
||||
omap2430_set_power(musb, true, glue->cable_connected);
|
||||
|
||||
@@ -413,9 +412,6 @@ static void omap2430_musb_disable(struct musb *musb)
|
||||
struct device *dev = musb->controller;
|
||||
struct omap2430_glue *glue = dev_get_drvdata(dev->parent);
|
||||
|
||||
- if (!WARN_ON(!musb->phy))
|
||||
- phy_power_off(musb->phy);
|
||||
-
|
||||
if (glue->status != MUSB_UNKNOWN)
|
||||
omap_control_usb_set_mode(glue->control_otghs,
|
||||
USB_MODE_DISCONNECT);
|
||||
@@ -429,6 +425,7 @@ static int omap2430_musb_exit(struct musb *musb)
|
||||
struct omap2430_glue *glue = dev_get_drvdata(dev->parent);
|
||||
|
||||
omap2430_low_level_exit(musb);
|
||||
+ phy_power_off(musb->phy);
|
||||
phy_exit(musb->phy);
|
||||
musb->phy = NULL;
|
||||
cancel_work_sync(&glue->omap_musb_mailbox_work);
|
||||
--
|
||||
2.10.0
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 04facfb4b4b49337f83bcb87eb40ce54cebfab5c Mon Sep 17 00:00:00 2001
|
||||
From d2c0d2c702b3847a0b1bf06996998c142254952e Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Kemnade <andreas@kemnade.info>
|
||||
Date: Mon, 22 Aug 2016 21:24:22 +0200
|
||||
Subject: [PATCH 13/14] phy-twl4030-usb: better handle musb_mailbox() failure
|
||||
Subject: [PATCH 12/13] phy-twl4030-usb: better handle musb_mailbox() failure
|
||||
|
||||
setting twl->linkstat = MUSB_UNKNOWN upon error in musb_mailbox as
|
||||
introduced in
|
||||
|
@ -58,5 +58,5 @@ index d9b10a3..81067b4 100644
|
|||
twl->phy.dev = twl->dev;
|
||||
twl->phy.label = "twl4030";
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From c92dd30d2a3a73ebbc01e351d8c3b23b18b52350 Mon Sep 17 00:00:00 2001
|
||||
From cff4d7ad9abccf3693bc4e7bf01009a5254e3175 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Oct 2016 22:15:41 -0600
|
||||
Subject: [PATCH 14/14] Revert "gpu: drm: omapdrm: dss-of: add missing
|
||||
Subject: [PATCH 13/13] Revert "gpu: drm: omapdrm: dss-of: add missing
|
||||
of_node_put after calling of_parse_phandle"
|
||||
|
||||
This reverts commit 2ab9f5879162499e1c4e48613287e3f59e593c4f.
|
||||
|
@ -34,5 +34,5 @@ index e256d87..dfd4e96 100644
|
|||
|
||||
struct device_node *
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
|
@ -7,7 +7,7 @@ pkgbase=linux-armv7
|
|||
_srcname=linux-4.8
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=4.8.6
|
||||
pkgver=4.8.7
|
||||
pkgrel=1
|
||||
rcnrel=armv7-x4
|
||||
arch=('armv7h')
|
||||
|
@ -28,33 +28,31 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0008-USB-armory-support.patch'
|
||||
'0009-ARM-dts-imx6ul-pico-hobbit-Add-Wifi-support.patch'
|
||||
'0010-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
|
||||
'0011-usb-musb-Fix-hardirq-safe-hardirq-unsafe-lock-order-.patch'
|
||||
'0012-usb-musb-Call-pm_runtime-from-musb_gadget_queue.patch'
|
||||
'0013-phy-twl4030-usb-better-handle-musb_mailbox-failure.patch'
|
||||
'0014-Revert-gpu-drm-omapdrm-dss-of-add-missing-of_node_pu.patch'
|
||||
'0011-usb-musb-Call-pm_runtime-from-musb_gadget_queue.patch'
|
||||
'0012-phy-twl4030-usb-better-handle-musb_mailbox-failure.patch'
|
||||
'0013-Revert-gpu-drm-omapdrm-dss-of-add-missing-of_node_pu.patch'
|
||||
'config'
|
||||
'cmdline'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk')
|
||||
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
|
||||
'666753363fd69ac2c1a94f4349a7197e'
|
||||
'7a447fb422c61b242b20d11c31597457'
|
||||
'35022f86112a9bd877d5cf04fb5d26c3'
|
||||
'46f8df5129747619801f7b2347c17857'
|
||||
'62930c53525f265fbc5d0ed9f58f19b9'
|
||||
'3389b8a5919f9ee8df49cd1a56b6726c'
|
||||
'dbfb9c7528e841fcf8904b78e22887e4'
|
||||
'354499d62629c9d38a39aeb044b586f0'
|
||||
'0bd799f038a4a2550116e1a05e9bc553'
|
||||
'f58741b1fc78133aac6c7e4b289d3780'
|
||||
'857e91c8ace7e60e10bcfeddc97a30f8'
|
||||
'5b7f1502bd4b5ca32ade0b796acdb092'
|
||||
'bce4eff1317ab09cbff2ebbaab7ade90'
|
||||
'72ba4bb39771f3ce3f5fa01ae327a9bd'
|
||||
'ce698dca6cdc3a158037cd6199d57741'
|
||||
'fe4ee64c38b0d144b5bb99239a3123f7'
|
||||
'd824a94c362d717832d5fd29587a0004'
|
||||
'ad7cdae5329497d07582b31858516686'
|
||||
'bea35eb4de137661be31f16c24487eea'
|
||||
'0153cba3c01756d17d03bef3cdc308ef'
|
||||
'74911f2cc4df510c11bcfe3c4a2b2121'
|
||||
'30257f5d8da3945cfbe9a9ee51ce32d1'
|
||||
'8723371954030e97e91406063c1329dc'
|
||||
'700e0ceca908156375634f5702050220'
|
||||
'f387621358a03cd7040b844d9beee649'
|
||||
'd4476829ee651e20a6629cc7760ff957'
|
||||
'b54a2e2a00f20c8671431292ee63452f'
|
||||
'8775562272a11411569817ad17e08655'
|
||||
'138a050b55fe4bdd3a5b744b114d4993'
|
||||
'f70e197338324a17f787b58884c647ff'
|
||||
'4293d874c9bd306dfbd9f37e4927a585'
|
||||
'75cbfa910f0f12248bb24356cfe631cb'
|
||||
'1eef139f059304d14c0898dd08ab1674'
|
||||
'1813b39074d01af6548951764a0f6444'
|
||||
'4f2379ed84258050edb858ee8d281678'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
|
@ -80,10 +78,9 @@ prepare() {
|
|||
git apply ../0008-USB-armory-support.patch
|
||||
git apply ../0009-ARM-dts-imx6ul-pico-hobbit-Add-Wifi-support.patch
|
||||
git apply ../0010-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
|
||||
git apply ../0011-usb-musb-Fix-hardirq-safe-hardirq-unsafe-lock-order-.patch
|
||||
git apply ../0012-usb-musb-Call-pm_runtime-from-musb_gadget_queue.patch
|
||||
git apply ../0013-phy-twl4030-usb-better-handle-musb_mailbox-failure.patch
|
||||
git apply ../0014-Revert-gpu-drm-omapdrm-dss-of-add-missing-of_node_pu.patch
|
||||
git apply ../0011-usb-musb-Call-pm_runtime-from-musb_gadget_queue.patch
|
||||
git apply ../0012-phy-twl4030-usb-better-handle-musb_mailbox-failure.patch
|
||||
git apply ../0013-Revert-gpu-drm-omapdrm-dss-of-add-missing-of_node_pu.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.8.3-1 Kernel Configuration
|
||||
# Linux/arm 4.8.7-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -2114,6 +2114,7 @@ CONFIG_SRAM=y
|
|||
CONFIG_VEXPRESS_SYSCFG=y
|
||||
CONFIG_BONE_CAPEMGR=y
|
||||
# CONFIG_DEV_OVERLAYMGR is not set
|
||||
CONFIG_TIEQEP=m
|
||||
CONFIG_C2PORT=m
|
||||
|
||||
#
|
||||
|
|
Loading…
Reference in a new issue