mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added extra/cairo
This commit is contained in:
parent
97b4b02774
commit
649df85480
2 changed files with 102 additions and 0 deletions
73
extra/cairo/PKGBUILD
Normal file
73
extra/cairo/PKGBUILD
Normal file
|
@ -0,0 +1,73 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Brice Carpentier <brice@daknet.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - drop valgrind makedepend
|
||||
|
||||
pkgname=cairo
|
||||
pkgver=1.12.16
|
||||
pkgrel=3.1
|
||||
pkgdesc="Cairo vector graphics library"
|
||||
arch=(i686 x86_64)
|
||||
license=('LGPL' 'MPL')
|
||||
url="http://cairographics.org/"
|
||||
depends=('libpng' 'libxrender' 'libxext' 'fontconfig' 'pixman>=0.28.0' 'glib2' 'mesa' 'libgl' 'sh' 'lzo')
|
||||
makedepends=('mesa-libgl' 'librsvg' 'gtk2' 'poppler-glib' 'libspectre' 'gtk-doc'
|
||||
# for the test suite:
|
||||
'ttf-dejavu' 'gsfonts' 'xorg-server-xvfb' ) # 'libdrm')
|
||||
#optdepends=('xcb-util: for XCB backend') # really needed?
|
||||
provides=('cairo-xcb')
|
||||
replaces=('cairo-xcb')
|
||||
source=(http://cairographics.org/releases/$pkgname-$pkgver.tar.xz
|
||||
cairo-1.12.16-lto-optional.patch)
|
||||
sha1sums=('4f6e337d5d3edd7ea79d1426f575331552b003ec'
|
||||
'80883e44a57942762995aea2f136701b1fa54568')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
# https://bugs.archlinux.org/task/40313 + https://bugs.gentoo.org/510782
|
||||
# patch to make it optional is taken from Gentoo
|
||||
patch -Np1 -i $srcdir/cairo-1.12.16-lto-optional.patch
|
||||
autoreconf -vfi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--disable-static \
|
||||
--disable-lto \
|
||||
--enable-tee \
|
||||
--enable-gl \
|
||||
--enable-egl \
|
||||
--enable-svg \
|
||||
--enable-ps \
|
||||
--enable-pdf \
|
||||
--enable-gobject #\
|
||||
# --enable-test-surfaces
|
||||
|
||||
#--disable-xlib-xcb \
|
||||
# --enable-test-surfaces \ takes ages
|
||||
#--enable-drm # breaks build
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
make -k test || /bin/true
|
||||
|
||||
# results:
|
||||
# 1.12.8-1 # 162 Passed, 328 Failed [8 crashed, 10 expected], 26 Skipped
|
||||
# 1.12.12-2: # 29 Passed, 464 Failed [460 crashed, 2 expected], 26 Skipped
|
||||
# 1.12.16-1: 144 Passed, 364 Failed [6 crashed, 12 expected], 27 Skipped
|
||||
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
29
extra/cairo/cairo-1.12.16-lto-optional.patch
Normal file
29
extra/cairo/cairo-1.12.16-lto-optional.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
diff --git a/build/configure.ac.warnings b/build/configure.ac.warnings
|
||||
index f984eb2..15b3da2 100644
|
||||
--- a/build/configure.ac.warnings
|
||||
+++ b/build/configure.ac.warnings
|
||||
@@ -38,13 +38,18 @@ dnl options. Namely, the following:
|
||||
|
||||
dnl -flto working really needs a test link, not just a compile
|
||||
|
||||
-safe_MAYBE_WARN="$MAYBE_WARN"
|
||||
-MAYBE_WARN="$MAYBE_WARN -flto"
|
||||
-AC_TRY_LINK([],[
|
||||
+AC_ARG_ENABLE(lto,
|
||||
+ AS_HELP_STRING([--disable-lto],
|
||||
+ [Do not try to use Link-Time Optimization]))
|
||||
+if test "x$enable_lto" != "xno"; then
|
||||
+ safe_MAYBE_WARN="$MAYBE_WARN"
|
||||
+ MAYBE_WARN="$MAYBE_WARN -flto"
|
||||
+ AC_TRY_LINK([],[
|
||||
int main(int argc, char **argv) { return 0; }
|
||||
-],[],[
|
||||
+ ],[],[
|
||||
MAYBE_WARN="$safe_MAYBE_WARN"
|
||||
-])
|
||||
+ ])
|
||||
+fi
|
||||
|
||||
MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common"
|
||||
|
||||
|
Loading…
Reference in a new issue