mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/redis
This commit is contained in:
parent
10169cf10f
commit
64bf8fa4ba
7 changed files with 0 additions and 119 deletions
|
@ -1,63 +0,0 @@
|
|||
# Maintainer: Andrew Crerar <crerar@archlinux.org>
|
||||
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
|
||||
# Contributor: nofxx <x@<nick>.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=redis
|
||||
pkgver=5.0.9
|
||||
pkgrel=1
|
||||
pkgdesc='Advanced key-value store'
|
||||
arch=('x86_64')
|
||||
url='https://redis.io/'
|
||||
license=('BSD')
|
||||
depends=('jemalloc' 'grep' 'shadow')
|
||||
backup=('etc/redis.conf'
|
||||
'etc/logrotate.d/redis')
|
||||
source=(http://download.redis.io/releases/redis-$pkgver.tar.gz
|
||||
redis.service
|
||||
redis.sysusers
|
||||
redis.tmpfiles
|
||||
redis.logrotate
|
||||
redis.conf-sane-defaults.patch
|
||||
redis-5.0-use-system-jemalloc.patch)
|
||||
sha512sums=('d2c7bc1f769bc5d179bfe6e71954962813b50597eafc752a9b1edf2fd87e84707b7daf0910db56dd0e89cb3bdb3e551da7f111ae4899f505bac5f77f99744c13'
|
||||
'86018ddd6625f918295e10f9478da361f73a6dbd6c6b8e4b974201669bcccbd4dba443bb0844be68f6ab8d5a1762b32af04c5e12df53b1f0ea812b790d9f4e37'
|
||||
'2227dfb41bf5112f91716f011862ba5fade220aea3b6a8134a5a05ee3af6d1cca05b08d793a486be97df98780bf43ac5dc4e5e9989ae0c5cd4e1eedb6cee5d71'
|
||||
'68f7bc12e3b95cb199b71255c6aa5bfaa431fbabbc7d2308e54347c0d35e6d8091c4a79a5a6b56494ab3a294f9389e3ec63902931920862f60b1ffe77222eeeb'
|
||||
'df11492df0458b224f75fff31475d39b85116cba6deb06d80d0fd8c467d221db51a2a8f5fc5d2e3e8239c0718e1cf5dc12e99cac9019cb99d3f11835ad00aa5d'
|
||||
'fe9748e0ab326e429f4183016b5aeb772199cd4688371c320811c25f8de2fcb7bc34955b359612c1a287e83b4afaba3b7fd6a6567fad66c04e8482cc802f3b50'
|
||||
'55b4085900c54fa7e7bf1c2bad7fba8cdbaf496a3f83b6d32fccb8aed5048cdde1690fea0485162dbb637e7fafb00a6b995908fa6db55e77854eb9f575b54d40')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../redis.conf-sane-defaults.patch
|
||||
patch -p1 -i ../redis-5.0-use-system-jemalloc.patch
|
||||
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
|
||||
sed -ri 's/^(FINAL_LIBS=.*)/\1 -latomic/' src/Makefile
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
make -C $pkgname-$pkgver
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make PREFIX="$pkgdir"/usr install
|
||||
|
||||
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/redis/LICENSE
|
||||
install -Dm644 redis.conf "$pkgdir"/etc/redis.conf
|
||||
install -Dm644 ../redis.service "$pkgdir"/usr/lib/systemd/system/redis.service
|
||||
|
||||
# files kept for compatibility with installations made before 2.8.13-2
|
||||
install -Dm644 ../redis.logrotate "$pkgdir"/etc/logrotate.d/redis
|
||||
|
||||
ln -sf redis-server "$pkgdir"/usr/bin/redis-sentinel
|
||||
|
||||
install -Dm644 "$srcdir"/redis.sysusers "$pkgdir"/usr/lib/sysusers.d/redis.conf
|
||||
install -Dm644 "$srcdir"/redis.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/redis.conf
|
||||
}
|
|
@ -1,15 +0,0 @@
|
|||
diff --git a/src/Makefile b/src/Makefile
|
||||
index 912cbc19..6840ce08 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -125,8 +125,8 @@ endif
|
||||
|
||||
ifeq ($(MALLOC),jemalloc)
|
||||
DEPENDENCY_TARGETS+= jemalloc
|
||||
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
|
||||
- FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
|
||||
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
|
||||
+ FINAL_LIBS := -ljemalloc $(FINAL_LIBS)
|
||||
endif
|
||||
|
||||
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
|
|
@ -1,12 +0,0 @@
|
|||
diff -wbBur redis-3.2.1/redis.conf redis-3.2.1.my/redis.conf
|
||||
--- redis-3.2.1/redis.conf 2016-06-17 16:15:21.000000000 +0300
|
||||
+++ redis-3.2.1.my/redis.conf 2016-06-22 18:06:23.687046141 +0300
|
||||
@@ -244,7 +244,7 @@
|
||||
# The Append Only File will also be created inside this directory.
|
||||
#
|
||||
# Note that you must specify a directory here, not a file name.
|
||||
-dir ./
|
||||
+dir /var/lib/redis/
|
||||
|
||||
################################# REPLICATION #################################
|
||||
|
|
@ -1,5 +0,0 @@
|
|||
/var/log/redis.log {
|
||||
notifempty
|
||||
copytruncate
|
||||
missingok
|
||||
}
|
|
@ -1,22 +0,0 @@
|
|||
[Unit]
|
||||
Description=Advanced key-value store
|
||||
After=network.target
|
||||
|
||||
[Service]
|
||||
Type=simple
|
||||
User=redis
|
||||
Group=redis
|
||||
ExecStart=/usr/bin/redis-server /etc/redis.conf
|
||||
ExecStop=/usr/bin/redis-cli shutdown
|
||||
CapabilityBoundingSet=
|
||||
PrivateTmp=true
|
||||
PrivateDevices=true
|
||||
ProtectSystem=full
|
||||
ProtectHome=true
|
||||
NoNewPrivileges=true
|
||||
RuntimeDirectory=redis
|
||||
RuntimeDirectoryMode=755
|
||||
LimitNOFILE=10032
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
|
@ -1 +0,0 @@
|
|||
u redis - "Redis in-memory data structure store" /var/lib/redis
|
|
@ -1 +0,0 @@
|
|||
d /var/lib/redis 0700 redis redis
|
Loading…
Reference in a new issue