mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/davfs2 compiles from ABS, deleted
This commit is contained in:
parent
ce095d7c28
commit
6505907c4b
2 changed files with 0 additions and 94 deletions
|
@ -1,37 +0,0 @@
|
||||||
# $Id: PKGBUILD 66598 2010-02-01 00:08:45Z giovanni $
|
|
||||||
# Maintainer: Thomas Baechler <thomas@archlinux.org>
|
|
||||||
|
|
||||||
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
|
|
||||||
# - we require a fix for glibc212, courtesy of gentoo (yuck), but only because people can't program right
|
|
||||||
|
|
||||||
plugrel=1
|
|
||||||
|
|
||||||
pkgname=davfs2
|
|
||||||
pkgver=1.4.5
|
|
||||||
pkgrel=1
|
|
||||||
pkgdesc="File system driver that allows you to mount a WebDAV server as a local disk drive."
|
|
||||||
arch=(i686 x86_64)
|
|
||||||
url="http://savannah.nongnu.org/projects/davfs2"
|
|
||||||
license=('GPL')
|
|
||||||
depends=('neon')
|
|
||||||
backup=(etc/davfs2/davfs2.conf etc/davfs2/secrets)
|
|
||||||
source=(http://mirrors.zerg.biz/nongnu/davfs2/${pkgname}-${pkgver}.tar.gz
|
|
||||||
davfs2-1.4.5-glibc212.patch)
|
|
||||||
sha256sums=('28f0ce00ddaf1ab93aa9f39db8d9f932d194c676bc21c3c8c3e2bea7f21274de'
|
|
||||||
'f8e8bcc99d36a661b5363fcd9ceae5eaf18010f165afcebd443eb36c75801a01')
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
||||||
patch -p0 -i ${srcdir}/davfs2-1.4.5-glibc212.patch
|
|
||||||
dav_user=nobody dav_group=network ./configure --prefix=/usr --sysconfdir=/etc --disable-debug || return 1
|
|
||||||
make || return 1
|
|
||||||
# Create some dirs
|
|
||||||
install -d -m755 "${pkgdir}/sbin"
|
|
||||||
make DESTDIR="${pkgdir}" install || return 1
|
|
||||||
|
|
||||||
rm -f ${pkgdir}/sbin/{u,}mount.davfs
|
|
||||||
ln -sf /usr/sbin/mount.davfs "${pkgdir}/sbin/mount.davfs"
|
|
||||||
ln -sf /usr/sbin/umount.davfs "${pkgdir}/sbin/umount.davfs"
|
|
||||||
|
|
||||||
rm -f ${pkgdir}/usr/share/davfs2/{BUGS,COPYING,FAQ,NEWS,TODO,ChangeLog,GPL,README,THANKS}
|
|
||||||
}
|
|
|
@ -1,57 +0,0 @@
|
||||||
--- src/dav_coda.c
|
|
||||||
+++ src/dav_coda.c
|
|
||||||
@@ -52,6 +52,9 @@
|
|
||||||
#ifdef HAVE_SYS_TYPES_H
|
|
||||||
#include <sys/types.h>
|
|
||||||
#endif
|
|
||||||
+#ifdef HAVE_SYS_STAT_H
|
|
||||||
+#include <sys/stat.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include "defaults.h"
|
|
||||||
#include "mount_davfs.h"
|
|
||||||
--- src/dav_fuse.c
|
|
||||||
+++ src/dav_fuse.c
|
|
||||||
@@ -41,6 +41,12 @@
|
|
||||||
#ifdef HAVE_UNISTD_H
|
|
||||||
#include <unistd.h>
|
|
||||||
#endif
|
|
||||||
+#ifdef HAVE_SYS_TYPES_H
|
|
||||||
+#include <sys/types.h>
|
|
||||||
+#endif
|
|
||||||
+#ifdef HAVE_SYS_STAT_H
|
|
||||||
+#include <sys/stat.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include "defaults.h"
|
|
||||||
#include "mount_davfs.h"
|
|
||||||
--- src/kernel_interface.c
|
|
||||||
+++ src/kernel_interface.c
|
|
||||||
@@ -44,6 +44,12 @@
|
|
||||||
#ifdef HAVE_UNISTD_H
|
|
||||||
#include <unistd.h>
|
|
||||||
#endif
|
|
||||||
+#ifdef HAVE_SYS_TYPES_H
|
|
||||||
+#include <sys/types.h>
|
|
||||||
+#endif
|
|
||||||
+#ifdef HAVE_SYS_STAT_H
|
|
||||||
+#include <sys/stat.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#ifdef HAVE_SYS_MOUNT_H
|
|
||||||
#include <sys/mount.h>
|
|
||||||
--- src/webdav.c
|
|
||||||
+++ src/webdav.c
|
|
||||||
@@ -47,6 +47,12 @@
|
|
||||||
#ifdef HAVE_UNISTD_H
|
|
||||||
#include <unistd.h>
|
|
||||||
#endif
|
|
||||||
+#ifdef HAVE_SYS_TYPES_H
|
|
||||||
+#include <sys/types.h>
|
|
||||||
+#endif
|
|
||||||
+#ifdef HAVE_SYS_STAT_H
|
|
||||||
+#include <sys/stat.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include <ne_alloc.h>
|
|
||||||
#include <ne_auth.h>
|
|
Loading…
Reference in a new issue