mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
Added extra/qt3
This commit is contained in:
parent
fd8b5b4b3f
commit
651236eaae
12 changed files with 487 additions and 0 deletions
130
extra/qt3/PKGBUILD
Normal file
130
extra/qt3/PKGBUILD
Normal file
|
@ -0,0 +1,130 @@
|
||||||
|
# $Id: PKGBUILD 70485 2010-02-27 00:07:44Z ibiru $
|
||||||
|
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||||
|
# Contributor: John Proctor <jproctor@prium.net>
|
||||||
|
|
||||||
|
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
|
||||||
|
# - added arm.patch to fix compiling on ARM with GCC >= 4
|
||||||
|
# Source: http://lists.trolltech.com/qt-embedded-interest/2007-03/msg00003.html
|
||||||
|
|
||||||
|
plugrel=1
|
||||||
|
|
||||||
|
pkgname=qt3
|
||||||
|
pkgver=3.3.8
|
||||||
|
pkgrel=17
|
||||||
|
pkgdesc="The QT gui toolkit."
|
||||||
|
arch=(i686 x86_64)
|
||||||
|
license=('GPL')
|
||||||
|
url="http://www.trolltech.com/products/qt/index.html"
|
||||||
|
pkgfqn=qt-x11-free-${pkgver}
|
||||||
|
install=qt.install
|
||||||
|
depends=('libpng>=1.4.0' 'libxmu' 'libxcursor' 'libxinerama' 'mesa' \
|
||||||
|
'libxft' 'libxrandr' 'libmng>=1.0.10-3')
|
||||||
|
makedepends=('mysql' 'postgresql>=8.2.3' 'unixodbc' 'sqlite3')
|
||||||
|
optdepends=('libmysqlclient' 'postgresql-libs' 'unixodbc')
|
||||||
|
source=(ftp://ftp.trolltech.com/qt/source/${pkgfqn}.tar.bz2 qt3-png14.patch qt.profile \
|
||||||
|
qt-copy-kde-patches.tar.bz2 qt-patches.tar.bz2 utf8-bug-qt3.diff \
|
||||||
|
qt-font-default-subst.diff mysql.patch eastern_asian_languagues.diff qt-odbc.patch
|
||||||
|
arm.patch)
|
||||||
|
options=(!libtool)
|
||||||
|
md5sums=('cf3c43a7dfde5bfb76f8001102fe6e85'
|
||||||
|
'1dc671df42b9030dbdf68bb61cd3375e'
|
||||||
|
'f72d1eb4eb49b9a9467c1f6035194266'
|
||||||
|
'f2a2dbdbfee9422c90efc3ef3f86197c'
|
||||||
|
'2f00e5c0c1e2c2a23dddc982cd79f3e0'
|
||||||
|
'f6b3b39040f2b8f19ba1cf1445468c28'
|
||||||
|
'9370d82e85f2c799335ed0dcc1d53189'
|
||||||
|
'7d40ed1bd40d33d8b9b27a2076a5d22a'
|
||||||
|
'616f1f3029cf8375256ad6a406de3549'
|
||||||
|
'2178ca88dfd75a230918593b30eb0dbe'
|
||||||
|
'88933d4af283bd5e8ff1b99f0dc35225')
|
||||||
|
|
||||||
|
# qt-copy-kde-patches come from http://websvn.kde.org/trunk/qt-copy/patches/
|
||||||
|
# other qt-patches come from fedora and gentoo
|
||||||
|
|
||||||
|
build() {
|
||||||
|
unset QMAKESPEC
|
||||||
|
export QTDIR=${srcdir}/$pkgfqn
|
||||||
|
export PATH=${QTDIR}/bin:${PATH}
|
||||||
|
export LD_LIBRARY_PATH=${QTDIR}/lib:${LD_LIBRARY_PATH}
|
||||||
|
export QMAKESPEC=$QTDIR/mkspecs/linux-g++
|
||||||
|
cd ${srcdir}/$pkgfqn
|
||||||
|
# apply qt patches from kde.org
|
||||||
|
for i in ../qt-copy-kde-patches/*; do
|
||||||
|
patch -Np0 -i $i || return 1
|
||||||
|
done
|
||||||
|
# apply other qt patches and one security fix from debian/gentoo
|
||||||
|
for i in ../qt-patches/*; do
|
||||||
|
patch -Np1 -i $i || return 1
|
||||||
|
done
|
||||||
|
# fix utf8 bug
|
||||||
|
patch -Np0 -i ../utf8-bug-qt3.diff || return 1
|
||||||
|
# fix asia fonts
|
||||||
|
patch -Np0 -i ../qt-font-default-subst.diff || return 1
|
||||||
|
# fix segfaults on exit when using mysql DB driver
|
||||||
|
patch -Np0 -i ../mysql.patch || return 1
|
||||||
|
# fix CJK font/chars select error (FS#11245)
|
||||||
|
patch -p1 -i ${srcdir}/eastern_asian_languagues.diff || return 1
|
||||||
|
# fix build problem against new unixODBC
|
||||||
|
patch -p1 -i ${srcdir}/qt-odbc.patch || return 1
|
||||||
|
|
||||||
|
patch -p0 -i ${srcdir}/qt3-png14.patch || return 1
|
||||||
|
|
||||||
|
# PlugApps arm.patch
|
||||||
|
patch -p1 -i ${srcdir}/arm.patch || return 1
|
||||||
|
|
||||||
|
# start compiling qt
|
||||||
|
sed -i 's|-cp -P -f|-cp -L -f|' qmake/Makefile.unix
|
||||||
|
rm -rf doc/html examples tutorial
|
||||||
|
sed -i "s|sub-tutorial sub-examples||" Makefile
|
||||||
|
sed -i "s|-O2|$CXXFLAGS|" mkspecs/linux-g++/qmake.conf
|
||||||
|
sed -i "s|-O2|$CXXFLAGS|" mkspecs/linux-g++-32/qmake.conf
|
||||||
|
sed -i "s|-O2|$CXXFLAGS|" mkspecs/linux-g++-64/qmake.conf
|
||||||
|
sed -i "s|-I. |$CXXFLAGS -I. |" qmake/Makefile.unix
|
||||||
|
sed -i "s|read acceptance|acceptance=yes|" configure
|
||||||
|
|
||||||
|
# remove unwanted mkspecs
|
||||||
|
rm -rf mkspecs/{*aix*,*bsd*,cygwin*,dgux*,darwin*,hpux*,hurd*,irix*,lynxos*,macx*,qnx*,reliant*,sco*,solaris*,tru64*,unixware*,win32*}
|
||||||
|
|
||||||
|
if [ "$CARCH" = "x86_64" ]; then
|
||||||
|
export ARCH="-64"
|
||||||
|
else unset ARCH
|
||||||
|
fi
|
||||||
|
|
||||||
|
./configure -prefix /opt/qt -platform linux-g++$ARCH \
|
||||||
|
-system-zlib -qt-gif -release -shared -sm -nis -thread -stl \
|
||||||
|
-system-lib{png,jpeg,mng} \
|
||||||
|
-no-g++-exceptions -plugin-sql-{mysql,psql,sqlite,odbc}
|
||||||
|
|
||||||
|
# fix /opt/qt/lib path
|
||||||
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/src/Makefile
|
||||||
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/designer/designer/Makefile
|
||||||
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/designer/editor/Makefile
|
||||||
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/assistant/lib/Makefile
|
||||||
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/designer/uilib/Makefile
|
||||||
|
|
||||||
|
cd ${srcdir}/$pkgfqn
|
||||||
|
make -C qmake || return 1
|
||||||
|
cd ${srcdir}/$pkgfqn/plugins/src/sqldrivers/mysql
|
||||||
|
${srcdir}/$pkgfqn/bin/qmake -o Makefile "INCPATH+=/usr/include/mysql" "LIBS+=-L/usr/lib/mysql -lmysqlclient" mysql.pro
|
||||||
|
cd ${srcdir}/$pkgfqn/plugins/src/sqldrivers/psql
|
||||||
|
${srcdir}/$pkgfqn/bin/qmake -o Makefile "INCPATH+=/usr/src/include /usr/include/postgresql/server" "LIBS+=-L/usr/lib -lpq" psql.pro
|
||||||
|
|
||||||
|
cd ${srcdir}/$pkgfqn
|
||||||
|
# fix the broken makefiles
|
||||||
|
#sed -i 's|[[:space:]]*strip.*doc/html.*$|#|g' src/Makefile
|
||||||
|
make || return 1
|
||||||
|
make INSTALL_ROOT=${pkgdir} install
|
||||||
|
rm -rf ${pkgdir}/opt/qt/{phrasebooks,templates,translations}
|
||||||
|
sed -i "s|-L${srcdir}/$pkgfqn/lib ||g" ${pkgdir}/opt/qt/lib/*.prl
|
||||||
|
install -D -m755 qmake/qmake ${pkgdir}/opt/qt/bin/qmake
|
||||||
|
install -D -m755 ${srcdir}/qt.profile ${pkgdir}/etc/profile.d/qt3.sh
|
||||||
|
ln -sf /opt/qt/bin/qtconfig ${pkgdir}/opt/qt/bin/qt3config
|
||||||
|
rm -f ${pkgdir}/opt/qt/mkspecs/linux-g++$ARCH/linux-g++$ARCH
|
||||||
|
|
||||||
|
# install man pages
|
||||||
|
mkdir -p ${pkgdir}/opt/qt/man
|
||||||
|
cp -r ${srcdir}/$pkgfqn/doc/man/{man1,man3} ${pkgdir}/opt/qt/man/
|
||||||
|
|
||||||
|
install -d -m755 ${pkgdir}/etc/ld.so.conf.d/
|
||||||
|
echo '/opt/qt/lib' > ${pkgdir}/etc/ld.so.conf.d/qt3.conf
|
||||||
|
}
|
25
extra/qt3/arm.patch
Normal file
25
extra/qt3/arm.patch
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
diff -urN qt-x11-free-3.3.8.orig/src/tools/qglobal.h qt-x11-free-3.3.8/src/tools/qglobal.h
|
||||||
|
--- qt-x11-free-3.3.8.orig/src/tools/qglobal.h 2011-01-20 21:18:42.000000000 -0700
|
||||||
|
+++ qt-x11-free-3.3.8/src/tools/qglobal.h 2011-01-20 21:20:34.000000000 -0700
|
||||||
|
@@ -320,6 +320,9 @@
|
||||||
|
# if __GNUC__ == 3 && __GNUC_MINOR__ >= 4
|
||||||
|
# define Q_NO_PACKED_REFERENCE
|
||||||
|
# endif
|
||||||
|
+# if __GNUC__ == 4 && __GNUC_MINOR__ >= 0
|
||||||
|
+# define Q_NO_PACKED_POINTERS
|
||||||
|
+# endif
|
||||||
|
# endif
|
||||||
|
# if !defined(__EXCEPTIONS)
|
||||||
|
# define Q_NO_EXCEPTIONS
|
||||||
|
diff -urN qt-x11-free-3.3.8.orig/src/tools/qstring.h qt-x11-free-3.3.8/src/tools/qstring.h
|
||||||
|
--- qt-x11-free-3.3.8.orig/src/tools/qstring.h 2011-01-20 21:18:43.000000000 -0700
|
||||||
|
+++ qt-x11-free-3.3.8/src/tools/qstring.h 2011-01-20 21:21:48.000000000 -0700
|
||||||
|
@@ -195,6 +195,8 @@
|
||||||
|
ushort unicode() const { return ucs; }
|
||||||
|
#ifdef Q_NO_PACKED_REFERENCE
|
||||||
|
ushort &unicode() { return *(&ucs); }
|
||||||
|
+#elif defined Q_NO_PACKED_POINTERS
|
||||||
|
+ ushort &unicode() { ushort& tmp = ucs; return tmp; }
|
||||||
|
#else
|
||||||
|
ushort &unicode() { return ucs; }
|
||||||
|
#endif
|
39
extra/qt3/eastern_asian_languagues.diff
Normal file
39
extra/qt3/eastern_asian_languagues.diff
Normal file
|
@ -0,0 +1,39 @@
|
||||||
|
--- qt-x11-free-3.3.8b/src/kernel/qfontdatabase.cpp 2008-01-15 21:09:13.000000000 +0200
|
||||||
|
+++ qt-x11-free-3.3.8b/src/kernel/qfontdatabase.cpp 2008-03-10 11:34:22.000000000 +0200
|
||||||
|
@@ -966,20 +966,22 @@
|
||||||
|
|
||||||
|
#ifdef Q_WS_X11
|
||||||
|
if (script == QFont::Han) {
|
||||||
|
- // modify script according to locale
|
||||||
|
- static QFont::Script defaultHan = QFont::UnknownScript;
|
||||||
|
- if (defaultHan == QFont::UnknownScript) {
|
||||||
|
- QCString locale = setlocale(LC_ALL, NULL);
|
||||||
|
- if (locale.contains("ko"))
|
||||||
|
- defaultHan = QFont::Han_Korean;
|
||||||
|
- else if (locale.contains("zh_TW") || locale.contains("zh_HK"))
|
||||||
|
- defaultHan = QFont::Han_TraditionalChinese;
|
||||||
|
- else if (locale.contains("zh"))
|
||||||
|
- defaultHan = QFont::Han_SimplifiedChinese;
|
||||||
|
- else
|
||||||
|
- defaultHan = QFont::Han_Japanese;
|
||||||
|
- }
|
||||||
|
- script = defaultHan;
|
||||||
|
+ // modify script according to locale
|
||||||
|
+ static QFont::Script defaultHan;
|
||||||
|
+ QCString locale = setlocale(LC_ALL, NULL);
|
||||||
|
+
|
||||||
|
+ if (locale.contains("ko"))
|
||||||
|
+ defaultHan = QFont::Han_Korean;
|
||||||
|
+ else if (locale.contains("zh_TW") || locale.contains("zh_HK"))
|
||||||
|
+ defaultHan = QFont::Han_TraditionalChinese;
|
||||||
|
+ else if (locale.contains("zh"))
|
||||||
|
+ defaultHan = QFont::Han_SimplifiedChinese;
|
||||||
|
+ else if (locale.contains("ja"))
|
||||||
|
+ defaultHan = QFont::Han_Japanese;
|
||||||
|
+ else
|
||||||
|
+ defaultHan = QFont::Han; // don't change
|
||||||
|
+
|
||||||
|
+ script = defaultHan;
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
47
extra/qt3/mysql.patch
Normal file
47
extra/qt3/mysql.patch
Normal file
|
@ -0,0 +1,47 @@
|
||||||
|
--- src/sql/drivers/mysql/qsql_mysql.cpp
|
||||||
|
+++ src/sql/drivers/mysql/qsql_mysql.cpp
|
||||||
|
@@ -37,7 +37,6 @@
|
||||||
|
#include "qsql_mysql.h"
|
||||||
|
#include <private/qsqlextension_p.h>
|
||||||
|
|
||||||
|
-#include <qapplication.h>
|
||||||
|
#include <qdatetime.h>
|
||||||
|
#include <qvaluevector.h>
|
||||||
|
#include <qsqlrecord.h>
|
||||||
|
@@ -341,14 +340,6 @@ int QMYSQLResult::numRowsAffected()
|
||||||
|
}
|
||||||
|
|
||||||
|
/////////////////////////////////////////////////////////
|
||||||
|
-static void qServerEnd()
|
||||||
|
-{
|
||||||
|
-#ifndef Q_NO_MYSQL_EMBEDDED
|
||||||
|
-# if MYSQL_VERSION_ID >= 40000
|
||||||
|
- mysql_server_end();
|
||||||
|
-# endif // MYSQL_VERSION_ID
|
||||||
|
-#endif // Q_NO_MYSQL_EMBEDDED
|
||||||
|
-}
|
||||||
|
|
||||||
|
static void qServerInit()
|
||||||
|
{
|
||||||
|
@@ -366,9 +357,7 @@ static void qServerInit()
|
||||||
|
qWarning( "QMYSQLDriver::qServerInit: unable to start server." );
|
||||||
|
# endif
|
||||||
|
}
|
||||||
|
- qAddPostRoutine(qServerEnd);
|
||||||
|
init = TRUE;
|
||||||
|
-
|
||||||
|
# endif // MYSQL_VERSION_ID
|
||||||
|
#endif // Q_NO_MYSQL_EMBEDDED
|
||||||
|
}
|
||||||
|
@@ -411,6 +400,11 @@ QMYSQLDriver::~QMYSQLDriver()
|
||||||
|
QSqlOpenExtension *ext = qSqlOpenExtDict()->take( this );
|
||||||
|
delete ext;
|
||||||
|
}
|
||||||
|
+#ifndef Q_NO_MYSQL_EMBEDDED
|
||||||
|
+# if MYSQL_VERSION_ID > 40000
|
||||||
|
+ mysql_server_end();
|
||||||
|
+# endif
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
bool QMYSQLDriver::hasFeature( DriverFeature f ) const
|
BIN
extra/qt3/qt-copy-kde-patches.tar.bz2
Normal file
BIN
extra/qt3/qt-copy-kde-patches.tar.bz2
Normal file
Binary file not shown.
77
extra/qt3/qt-font-default-subst.diff
Normal file
77
extra/qt3/qt-font-default-subst.diff
Normal file
|
@ -0,0 +1,77 @@
|
||||||
|
--- src/kernel/qfontdatabase_x11.cpp
|
||||||
|
+++ src/kernel/qfontdatabase_x11.cpp
|
||||||
|
@@ -1589,15 +1589,6 @@ QFontEngine *loadEngine( QFont::Script s
|
||||||
|
if (script == QFont::Latin)
|
||||||
|
// add Euro character
|
||||||
|
FcCharSetAddChar(cs, 0x20ac);
|
||||||
|
- if (script == QFont::Han_SimplifiedChinese)
|
||||||
|
- FcCharSetAddChar(cs, 0x3400);
|
||||||
|
- if (script == QFont::Han_TraditionalChinese){
|
||||||
|
- FcCharSetAddChar(cs, 0x3435);
|
||||||
|
- FcCharSetAddChar(cs, 0xE000);
|
||||||
|
- FcCharSetAddChar(cs, 0xF6B1);
|
||||||
|
- }
|
||||||
|
- if (script == QFont::MiscellaneousSymbols)
|
||||||
|
- FcCharSetAddChar(cs, 0x2714);
|
||||||
|
FcPatternAddCharSet(pattern, FC_CHARSET, cs);
|
||||||
|
FcCharSetDestroy(cs);
|
||||||
|
}
|
||||||
|
@@ -1813,7 +1804,11 @@ static QFontEngine *loadFontConfigFont(c
|
||||||
|
FcPatternPrint(pattern);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+ // XftFontMatch calls the right ConfigSubstitute variants, but as we use
|
||||||
|
+ // FcFontMatch/Sort here we have to do it manually.
|
||||||
|
FcConfigSubstitute(0, pattern, FcMatchPattern);
|
||||||
|
+ XftDefaultSubstitute(QPaintDevice::x11AppDisplay(), QPaintDevice::x11AppScreen(), pattern);
|
||||||
|
+
|
||||||
|
// qDebug("1: pattern contains:");
|
||||||
|
// FcPatternPrint(pattern);
|
||||||
|
|
||||||
|
@@ -1847,10 +1842,6 @@ static QFontEngine *loadFontConfigFont(c
|
||||||
|
value.u.s = (const FcChar8 *)cs.data();
|
||||||
|
FcPatternAddWeak(pattern, FC_FAMILY, value, FcTrue);
|
||||||
|
}
|
||||||
|
-#ifdef FONT_MATCH_DEBUG
|
||||||
|
- printf("final pattern contains:\n");
|
||||||
|
- FcPatternPrint(pattern);
|
||||||
|
-#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
if (script != QFont::Unicode) {
|
||||||
|
@@ -1860,19 +1851,15 @@ static QFontEngine *loadFontConfigFont(c
|
||||||
|
if (script == QFont::Latin)
|
||||||
|
// add Euro character
|
||||||
|
FcCharSetAddChar(cs, 0x20ac);
|
||||||
|
- if (script == QFont::Han_SimplifiedChinese)
|
||||||
|
- FcCharSetAddChar(cs, 0x3400);
|
||||||
|
- if (script == QFont::Han_TraditionalChinese) {
|
||||||
|
- FcCharSetAddChar(cs, 0x3435);
|
||||||
|
- FcCharSetAddChar(cs, 0xE000);
|
||||||
|
- FcCharSetAddChar(cs, 0xF6B1);
|
||||||
|
- }
|
||||||
|
- if (script == QFont::MiscellaneousSymbols)
|
||||||
|
- FcCharSetAddChar(cs, 0x2714);
|
||||||
|
FcPatternAddCharSet(pattern, FC_CHARSET, cs);
|
||||||
|
FcCharSetDestroy(cs);
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifdef FONT_MATCH_DEBUG
|
||||||
|
+ printf("final pattern contains:\n");
|
||||||
|
+ FcPatternPrint(pattern);
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
QFontEngine *fe = 0;
|
||||||
|
|
||||||
|
for( int jj = (FcGetVersion() >= 20392 ? 0 : 1); jj < 2; ++jj ) {
|
||||||
|
--- src/kernel/qfontdatabase.cpp
|
||||||
|
+++ src/kernel/qfontdatabase.cpp
|
||||||
|
@@ -554,7 +554,7 @@ static const unsigned short sample_chars
|
||||||
|
// GeometricSymbols,
|
||||||
|
{ 0x2500, 0x0 },
|
||||||
|
// MiscellaneousSymbols,
|
||||||
|
- { 0x2640, 0x0 },
|
||||||
|
+ { 0x2640, 0x2714, 0x0 },
|
||||||
|
// EnclosedAndSquare,
|
||||||
|
{ 0x2460, 0x0 },
|
||||||
|
// Braille,
|
19
extra/qt3/qt-odbc.patch
Normal file
19
extra/qt3/qt-odbc.patch
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
diff -up qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp.orig qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp
|
||||||
|
--- qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp.orig 2009-02-24 11:32:27.000000000 +0100
|
||||||
|
+++ qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp 2009-02-24 11:33:43.000000000 +0100
|
||||||
|
@@ -57,13 +57,13 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
// newer platform SDKs use SQLLEN instead of SQLINTEGER
|
||||||
|
-#ifdef SQLLEN
|
||||||
|
+#if defined(SQLLEN) || defined(Q_OS_WIN64) || defined(Q_OS_UNIX)
|
||||||
|
# define QSQLLEN SQLLEN
|
||||||
|
#else
|
||||||
|
# define QSQLLEN SQLINTEGER
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#ifdef SQLULEN
|
||||||
|
+#if defined(SQLULEN) || defined(Q_OS_WIN64) || defined(Q_OS_UNIX)
|
||||||
|
# define QSQLULEN SQLULEN
|
||||||
|
#else
|
||||||
|
# define QSQLULEN SQLUINTEGER
|
BIN
extra/qt3/qt-patches.tar.bz2
Normal file
BIN
extra/qt3/qt-patches.tar.bz2
Normal file
Binary file not shown.
12
extra/qt3/qt.install
Normal file
12
extra/qt3/qt.install
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
post_install() {
|
||||||
|
post_remove
|
||||||
|
}
|
||||||
|
|
||||||
|
post_upgrade() {
|
||||||
|
post_remove
|
||||||
|
}
|
||||||
|
|
||||||
|
post_remove() {
|
||||||
|
# this can be removed in future versions
|
||||||
|
sed -e '/\/opt\/qt\/lib/d' -i etc/ld.so.conf
|
||||||
|
}
|
4
extra/qt3/qt.profile
Normal file
4
extra/qt3/qt.profile
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
export QTDIR=/opt/qt
|
||||||
|
export QT_XFT=true
|
||||||
|
export PATH=$PATH:$QTDIR/bin
|
||||||
|
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/qt/lib/pkgconfig
|
33
extra/qt3/qt3-png14.patch
Normal file
33
extra/qt3/qt3-png14.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
--- src/kernel/qpngio.cpp.orig 2010-01-16 22:02:41.000000000 +0100
|
||||||
|
+++ src/kernel/qpngio.cpp 2010-01-16 22:03:56.000000000 +0100
|
||||||
|
@@ -159,7 +159,7 @@
|
||||||
|
image.setColor( i, qRgba(c,c,c,0xff) );
|
||||||
|
}
|
||||||
|
if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
|
||||||
|
- const int g = info_ptr->trans_values.gray;
|
||||||
|
+ const int g = info_ptr->trans_color.gray;
|
||||||
|
if (g < ncols) {
|
||||||
|
image.setAlphaBuffer(TRUE);
|
||||||
|
image.setColor(g, image.color(g) & RGB_MASK);
|
||||||
|
@@ -187,7 +187,7 @@
|
||||||
|
info_ptr->palette[i].red,
|
||||||
|
info_ptr->palette[i].green,
|
||||||
|
info_ptr->palette[i].blue,
|
||||||
|
- info_ptr->trans[i]
|
||||||
|
+ info_ptr->trans_alpha[i]
|
||||||
|
)
|
||||||
|
);
|
||||||
|
i++;
|
||||||
|
@@ -321,9 +321,9 @@
|
||||||
|
png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)
|
||||||
|
if (image.depth()==32 && png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
|
||||||
|
QRgb trans = 0xFF000000 | qRgb(
|
||||||
|
- (info_ptr->trans_values.red << 8 >> bit_depth)&0xff,
|
||||||
|
- (info_ptr->trans_values.green << 8 >> bit_depth)&0xff,
|
||||||
|
- (info_ptr->trans_values.blue << 8 >> bit_depth)&0xff);
|
||||||
|
+ (info_ptr->trans_color.red << 8 >> bit_depth)&0xff,
|
||||||
|
+ (info_ptr->trans_color.green << 8 >> bit_depth)&0xff,
|
||||||
|
+ (info_ptr->trans_color.blue << 8 >> bit_depth)&0xff);
|
||||||
|
for (uint y=0; y<height; y++) {
|
||||||
|
for (uint x=0; x<info_ptr->width; x++) {
|
||||||
|
if (((uint**)jt)[y][x] == trans) {
|
101
extra/qt3/utf8-bug-qt3.diff
Normal file
101
extra/qt3/utf8-bug-qt3.diff
Normal file
|
@ -0,0 +1,101 @@
|
||||||
|
--- src/codecs/qutfcodec.cpp
|
||||||
|
+++ src/codecs/qutfcodec.cpp
|
||||||
|
@@ -154,6 +154,7 @@
|
||||||
|
|
||||||
|
class QUtf8Decoder : public QTextDecoder {
|
||||||
|
uint uc;
|
||||||
|
+ uint min_uc;
|
||||||
|
int need;
|
||||||
|
bool headerDone;
|
||||||
|
public:
|
||||||
|
@@ -167,8 +168,9 @@
|
||||||
|
result.setLength( len ); // worst case
|
||||||
|
QChar *qch = (QChar *)result.unicode();
|
||||||
|
uchar ch;
|
||||||
|
+ int error = -1;
|
||||||
|
for (int i=0; i<len; i++) {
|
||||||
|
- ch = *chars++;
|
||||||
|
+ ch = chars[i];
|
||||||
|
if (need) {
|
||||||
|
if ( (ch&0xc0) == 0x80 ) {
|
||||||
|
uc = (uc << 6) | (ch & 0x3f);
|
||||||
|
@@ -182,6 +184,8 @@
|
||||||
|
*qch++ = QChar(high);
|
||||||
|
*qch++ = QChar(low);
|
||||||
|
headerDone = TRUE;
|
||||||
|
+ } else if ((uc < min_uc) || (uc >= 0xd800 && uc <= 0xdfff) || (uc >= 0xfffe)) {
|
||||||
|
+ *qch++ = QChar::replacement;
|
||||||
|
} else {
|
||||||
|
if (headerDone || QChar(uc) != QChar::byteOrderMark)
|
||||||
|
*qch++ = uc;
|
||||||
|
@@ -190,6 +194,7 @@
|
||||||
|
}
|
||||||
|
} else {
|
||||||
|
// error
|
||||||
|
+ i = error;
|
||||||
|
*qch++ = QChar::replacement;
|
||||||
|
need = 0;
|
||||||
|
}
|
||||||
|
@@ -200,12 +205,21 @@
|
||||||
|
} else if ((ch & 0xe0) == 0xc0) {
|
||||||
|
uc = ch & 0x1f;
|
||||||
|
need = 1;
|
||||||
|
+ error = i;
|
||||||
|
+ min_uc = 0x80;
|
||||||
|
} else if ((ch & 0xf0) == 0xe0) {
|
||||||
|
uc = ch & 0x0f;
|
||||||
|
need = 2;
|
||||||
|
+ error = i;
|
||||||
|
+ min_uc = 0x800;
|
||||||
|
} else if ((ch&0xf8) == 0xf0) {
|
||||||
|
uc = ch & 0x07;
|
||||||
|
need = 3;
|
||||||
|
+ error = i;
|
||||||
|
+ min_uc = 0x10000;
|
||||||
|
+ } else {
|
||||||
|
+ // error
|
||||||
|
+ *qch++ = QChar::replacement;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--- src/tools/qstring.cpp
|
||||||
|
+++ src/tools/qstring.cpp
|
||||||
|
@@ -5805,6 +5805,7 @@
|
||||||
|
result.setLength( len ); // worst case
|
||||||
|
QChar *qch = (QChar *)result.unicode();
|
||||||
|
uint uc = 0;
|
||||||
|
+ uint min_uc = 0;
|
||||||
|
int need = 0;
|
||||||
|
int error = -1;
|
||||||
|
uchar ch;
|
||||||
|
@@ -5822,6 +5823,12 @@
|
||||||
|
unsigned short low = uc%0x400 + 0xdc00;
|
||||||
|
*qch++ = QChar(high);
|
||||||
|
*qch++ = QChar(low);
|
||||||
|
+ } else if (uc < min_uc || (uc >= 0xd800 && uc <= 0xdfff) || (uc >= 0xfffe)) {
|
||||||
|
+ // overlong seqence, UTF16 surrogate or BOM
|
||||||
|
+ i = error;
|
||||||
|
+ qch = addOne(qch, result);
|
||||||
|
+ *qch++ = QChar(0xdbff);
|
||||||
|
+ *qch++ = QChar(0xde00+((uchar)utf8[i]));
|
||||||
|
} else {
|
||||||
|
*qch++ = uc;
|
||||||
|
}
|
||||||
|
@@ -5844,14 +5851,17 @@
|
||||||
|
uc = ch & 0x1f;
|
||||||
|
need = 1;
|
||||||
|
error = i;
|
||||||
|
+ min_uc = 0x80;
|
||||||
|
} else if ((ch & 0xf0) == 0xe0) {
|
||||||
|
uc = ch & 0x0f;
|
||||||
|
need = 2;
|
||||||
|
error = i;
|
||||||
|
+ min_uc = 0x800;
|
||||||
|
} else if ((ch&0xf8) == 0xf0) {
|
||||||
|
uc = ch & 0x07;
|
||||||
|
need = 3;
|
||||||
|
error = i;
|
||||||
|
+ min_uc = 0x10000;
|
||||||
|
} else {
|
||||||
|
// Error
|
||||||
|
qch = addOne(qch, result);
|
Loading…
Reference in a new issue