From 65acbea45a1d962edc8e62c96f090fc1afd78a15 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Jan 2018 13:45:47 +0000
Subject: [PATCH] community/neko to 2.2.0-1

---
 community/neko/PKGBUILD | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/community/neko/PKGBUILD b/community/neko/PKGBUILD
index ac6e04378..7af7bce69 100644
--- a/community/neko/PKGBUILD
+++ b/community/neko/PKGBUILD
@@ -11,21 +11,21 @@
 #  - remove unsupported gcc flag on !aarch64
 
 pkgname=neko
-pkgver=2.1.0
-pkgrel=3
+pkgver=2.2.0
+pkgrel=1
 pkgdesc='High-level and dynamically typed programming language'
 url='http://nekovm.org/' # no https
 license=('LGPL')
-arch=('x86_64' 'i686')
+arch=('x86_64')
 depends=('gc' 'gtk2' 'libmariadbclient' 'mbedtls' 'sqlite')
-makedepends=('apache' 'apr' 'cmake' 'git' 'mbedtls' 'ninja' 'pkgconfig')
+makedepends=('apache' 'apr' 'cmake' 'git' 'mbedtls' 'ninja')
 optdepends=('apache: for extending Apache with mod_neko')
 options=('!strip')
 source=("git+https://github.com/HaxeFoundation/neko#tag=v${pkgver//./-}")
 sha256sums=('SKIP')
 
 prepare() {
-  sed -i '/xlocale.h/d' "$srcdir/$pkgname/libs/std/sys.c"
+  sed -i '/xlocale.h/d' "$pkgname/libs/std/sys.c"
   if [[ $CARCH != "aarch64" ]]; then sed -i '/mincoming-stack-boundary/d' $pkgname/CMakeLists.txt; fi
 }