core/linux-armv7 to 3.18.3-1

This commit is contained in:
Kevin Mihelich 2015-01-24 22:11:05 +00:00
parent f962f5ed42
commit 65b67974eb
8 changed files with 129 additions and 31 deletions

View file

@ -1,7 +1,7 @@
From 890518b12674120f5978fc4d147f89377c778643 Mon Sep 17 00:00:00 2001
From 771ae3d1b217bc1ba0d749be1f067b5a49384a1b Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/5] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/6] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
};
--
2.1.3
2.2.2

View file

@ -1,7 +1,7 @@
From f6724eeed1f0d666a42dc5eab84801159180ed95 Mon Sep 17 00:00:00 2001
From abdf77b0eed2ce6dcdd3afc76cdfbceb2493e662 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/5] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/6] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
}
--
2.1.3
2.2.2

View file

@ -1,7 +1,7 @@
From 0bd610833e1b9ace289a46ff70b46ac9fa7003a8 Mon Sep 17 00:00:00 2001
From 4f0e1c29c503ed3c9c25eb16d0e11d169e99374c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/5] SMILE Plug device tree file
Subject: [PATCH 3/6] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -199,5 +199,5 @@ index 0000000..6b30e82
+ };
+};
--
2.1.3
2.2.2

View file

@ -1,7 +1,7 @@
From 8363a1be0d3c12ed4d07fff0036700cd0419162e Mon Sep 17 00:00:00 2001
From 58868972118abc6766471cc20ddc431267e8ded4 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/5] fix mvsdio eMMC timing
Subject: [PATCH 4/6] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index 6b4c5ad..9f50234 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.1.3
2.2.2

View file

@ -1,7 +1,7 @@
From 7b4540118f9d125ed8cf51f80aa429d1a7f5bc94 Mon Sep 17 00:00:00 2001
From 2bfc92e7ef0bc8b5acb8f5caf83984ba4ec62d6a Mon Sep 17 00:00:00 2001
From: Andrew Lunn <andrew@lunn.ch>
Date: Wed, 12 Nov 2014 23:10:08 +0100
Subject: [PATCH 5/5] mmc: mvsdio: Work around broken TX DMA
Subject: [PATCH 5/6] mmc: mvsdio: Work around broken TX DMA
In order to use the mvsdio driver for sdio, it has been necessary to
use a module parameter to disable DMA so to force PIO is used. It is
@ -53,5 +53,5 @@ index 9f50234..ab95bb7 100644
host->pio_size = data->blocks * data->blksz;
host->pio_ptr = sg_virt(data->sg);
--
2.1.3
2.2.2

View file

@ -0,0 +1,95 @@
From 845153f87f2b984be0d793087334813ff77625bf Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 6/6] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index d07bf4c..5ae60ab 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -59,6 +59,7 @@
#define SUSPEND_SUSPEND3 (0x08)
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
+#define MAC_ADDR_LEN (6)
struct smsc95xx_priv {
u32 mac_cr;
@@ -74,6 +75,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
+static char *macaddr = ":";
+module_param(macaddr, charp, 0);
+MODULE_PARM_DESC(macaddr, "MAC address");
+
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm)
{
@@ -763,8 +768,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
}
+/* Check the macaddr module parameter for a MAC address */
+static int smsc95xx_is_macaddr_param(struct usbnet *dev, u8 *dev_mac)
+{
+ int i, j, got_num, num;
+ u8 mtbl[MAC_ADDR_LEN];
+
+ if (macaddr[0] == ':')
+ return 0;
+
+ i = 0;
+ j = 0;
+ num = 0;
+ got_num = 0;
+ while (j < MAC_ADDR_LEN) {
+ if (macaddr[i] && macaddr[i] != ':') {
+ got_num++;
+ if ('0' <= macaddr[i] && macaddr[i] <= '9')
+ num = num * 16 + macaddr[i] - '0';
+ else if ('A' <= macaddr[i] && macaddr[i] <= 'F')
+ num = num * 16 + 10 + macaddr[i] - 'A';
+ else if ('a' <= macaddr[i] && macaddr[i] <= 'f')
+ num = num * 16 + 10 + macaddr[i] - 'a';
+ else
+ break;
+ i++;
+ } else if (got_num == 2) {
+ mtbl[j++] = (u8) num;
+ num = 0;
+ got_num = 0;
+ i++;
+ } else {
+ break;
+ }
+ }
+
+ if (j == MAC_ADDR_LEN) {
+ netif_dbg(dev, ifup, dev->net, "Overriding MAC address with: "
+ "%02x:%02x:%02x:%02x:%02x:%02x\n", mtbl[0], mtbl[1], mtbl[2],
+ mtbl[3], mtbl[4], mtbl[5]);
+ for (i = 0; i < MAC_ADDR_LEN; i++)
+ dev_mac[i] = mtbl[i];
+ return 1;
+ } else {
+ return 0;
+ }
+}
+
static void smsc95xx_init_mac_address(struct usbnet *dev)
{
+ /* Check module parameters */
+ if (smsc95xx_is_macaddr_param(dev, dev->net->dev_addr))
+ return;
+
/* try reading mac address from EEPROM */
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
dev->net->dev_addr) == 0) {
--
2.2.2

View file

@ -7,7 +7,7 @@ pkgbase=linux-armv7
_srcname=linux-3.18
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=3.18.2
pkgver=3.18.3
pkgrel=1
rcnrel=armv7-x2
arch=('armv7h')
@ -24,18 +24,20 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
'0004-fix-mvsdio-eMMC-timing.patch'
'0005-mmc-mvsdio-Work-around-broken-TX-DMA.patch'
'0005-mmc-mvsdio-Work-around-broken-TX-DMA.patch'
'0006-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'config')
md5sums=('9e854df51ca3fef8bfe566dbd7b89241'
'f99d6d8f844a3fe1ab7f59dd85aaa050'
'3dede0a299b25df9d0ce77df302a30b8'
'0d4f5406f6fbe34a53e1c5e1d2037e8b'
'a519781aaa041f96e4670770ba400e46'
'SKIP'
'71c2bfdde7cdefb5788aac9d3dc3e35d'
'9ba8dec6e78de09a0b0ac50d386a9c46'
'0586896c14824b5e988597617f923f5e'
'fc1cd549e20f3cf49d7b0af8b01cc900'
'1c45963a5bfcb535864a86139346217d'
'fe77781fcc6a50e59745b31098a84c1f')
'877449857f711e8f880fb023a9285641'
'201c4c6ba7d459c4617c7bd30ea2c5b4'
'65cddba7c44de41e59c68ccb13f93cbc'
'e2ea54e5ab30266a15beba5222792a18'
'246bd40b4b57fd490465e70f6ea711b9'
'8a37d76eee241f62f99415a7e14b5c2f'
'7edd5c951ff921a77e5c5e120044ee50')
prepare() {
cd "${srcdir}/${_srcname}"
@ -52,6 +54,7 @@ prepare() {
git apply ../0003-SMILE-Plug-device-tree-file.patch
git apply ../0004-fix-mvsdio-eMMC-timing.patch
git apply ../0005-mmc-mvsdio-Work-around-broken-TX-DMA.patch
git apply ../0006-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
# AUFS patches
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
@ -59,10 +62,10 @@ prepare() {
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/linux
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/uapi/linux
git apply ../aufs3-standalone/aufs3-kbuild.patch
git apply ../aufs3-standalone/aufs3-base.patch
git apply ../aufs3-standalone/aufs3-mmap.patch
git apply ../aufs3-standalone/aufs3-standalone.patch
patch -p1 -i ../aufs3-standalone/aufs3-kbuild.patch
patch -p1 -i ../aufs3-standalone/aufs3-base.patch
patch -p1 -i ../aufs3-standalone/aufs3-mmap.patch
patch -p1 -i ../aufs3-standalone/aufs3-standalone.patch
cat "${srcdir}/config" > ./.config

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 3.18.1-1 Kernel Configuration
# Linux/arm 3.18.2-1 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -5127,7 +5127,7 @@ CONFIG_USB_EHSET_TEST_FIXTURE=m
CONFIG_USB_ISIGHTFW=m
CONFIG_USB_YUREX=m
CONFIG_USB_EZUSB_FX2=m
CONFIG_USB_HSIC_USB3503=m
CONFIG_USB_HSIC_USB3503=y
# CONFIG_USB_LINK_LAYER_TEST is not set
CONFIG_USB_ATM=m
CONFIG_USB_SPEEDTOUCH=m