mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/webkit2gtk fix
This commit is contained in:
parent
62901ba7cd
commit
65bc7cba98
2 changed files with 19 additions and 2 deletions
|
@ -4,6 +4,7 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - do not use LLINT assembly for v5/v6
|
||||
# - strip -O3 from cmake generated makefiles, solves ICE
|
||||
# - remove Atomics.cpp from build for v5/v6 - https://bugs.webkit.org/show_bug.cgi?id=161900
|
||||
|
||||
highmem=1
|
||||
|
||||
|
@ -24,8 +25,10 @@ optdepends=('gtk2: Netscape plugin support'
|
|||
options=('!emptydirs')
|
||||
|
||||
# webkitgtk's signature scheme (sha1-file-as-pgp-message) is bananas and not supported
|
||||
source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz)
|
||||
sha1sums=('46f1af500b01f8dead80d349e422f7184022d363')
|
||||
source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz
|
||||
remove_atomics.patch)
|
||||
sha1sums=('46f1af500b01f8dead80d349e422f7184022d363'
|
||||
'aaac158ebcdd51d46d1c4c03839a0c6bbc40225f')
|
||||
|
||||
prepare() {
|
||||
mkdir build
|
||||
|
@ -34,6 +37,10 @@ prepare() {
|
|||
sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
|
||||
rm -r Source/ThirdParty/gtest/
|
||||
rm -r Source/ThirdParty/qunit/
|
||||
|
||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||
patch -p0 -i ../remove_atomics.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
10
extra/webkit2gtk/remove_atomics.patch
Normal file
10
extra/webkit2gtk/remove_atomics.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Source/WTF/wtf/CMakeLists.txt.orig 2016-10-12 22:36:08.235410277 -0600
|
||||
+++ Source/WTF/wtf/CMakeLists.txt 2016-10-12 22:36:23.300372381 -0600
|
||||
@@ -171,7 +171,6 @@
|
||||
|
||||
set(WTF_SOURCES
|
||||
Assertions.cpp
|
||||
- Atomics.cpp
|
||||
BitVector.cpp
|
||||
CompilationThread.cpp
|
||||
CrossThreadCopier.cpp
|
Loading…
Reference in a new issue