mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
removed extra/sbc
This commit is contained in:
parent
086061b019
commit
65c6ee98e3
3 changed files with 0 additions and 113 deletions
|
@ -1,33 +0,0 @@
|
|||
From fc950fbd3e4a1bb53825576678e0e3828ac2e08e Mon Sep 17 00:00:00 2001
|
||||
From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
|
||||
Date: Mon, 3 Apr 2017 01:42:26 +0900
|
||||
Subject: [PATCH 1/2] Add config.h in sbc/sbc_primitives.h
|
||||
|
||||
When we use "--enable-high-precision" option of configure, this does not work
|
||||
effectively. Because SBC_HIGH_PRECISION enabled by this option is not available
|
||||
in "sbc/sbc_primitives.h".
|
||||
This adds config.h to "sbc/sbc_primitives.h" to use SBC_HIGH_PRECISION.
|
||||
|
||||
Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
|
||||
---
|
||||
sbc/sbc_primitives.h | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/sbc/sbc_primitives.h b/sbc/sbc_primitives.h
|
||||
index e01c957..b060484 100644
|
||||
--- a/sbc/sbc_primitives.h
|
||||
+++ b/sbc/sbc_primitives.h
|
||||
@@ -27,6 +27,10 @@
|
||||
#ifndef __SBC_PRIMITIVES_H
|
||||
#define __SBC_PRIMITIVES_H
|
||||
|
||||
+#ifdef HAVE_CONFIG_H
|
||||
+#include <config.h>
|
||||
+#endif
|
||||
+
|
||||
#define SCALE_OUT_BITS 15
|
||||
#define SBC_X_BUFFER_SIZE 328
|
||||
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1,27 +0,0 @@
|
|||
From 10e4085d20a15d82f2a72c179e240b102041a531 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 8 Dec 2020 15:16:27 -0700
|
||||
Subject: [PATCH 2/2] Fix build on ARM
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
sbc/sbc_primitives.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/sbc/sbc_primitives.c b/sbc/sbc_primitives.c
|
||||
index 97a75be..653ad3f 100644
|
||||
--- a/sbc/sbc_primitives.c
|
||||
+++ b/sbc/sbc_primitives.c
|
||||
@@ -630,7 +630,9 @@ void sbc_init_primitives(struct sbc_encoder_state *state)
|
||||
state->implementation_info = "Generic C";
|
||||
|
||||
/* X86/AMD64 optimizations */
|
||||
+#if (SBC_BUILD_WITH_MMX_SUPPORT || SBC_BUILD_WITH_SSE_SUPPORT)
|
||||
sbc_init_primitives_x86(state);
|
||||
+#endif
|
||||
|
||||
/* ARM optimizations */
|
||||
#ifdef SBC_BUILD_WITH_ARMV6_SUPPORT
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1,53 +0,0 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - configure with --enable-high-precision for v6/v7 to fix stack corruption
|
||||
# - patch to fix enabling high precision
|
||||
# - patch to fix FTBFS on ARM
|
||||
|
||||
pkgname=sbc
|
||||
pkgver=1.5
|
||||
pkgrel=2
|
||||
pkgdesc="Bluetooth Subband Codec (SBC) library"
|
||||
url="https://git.kernel.org/pub/scm/bluetooth/sbc.git"
|
||||
arch=(x86_64)
|
||||
license=(GPL LGPL)
|
||||
depends=(glibc)
|
||||
makedepends=(git)
|
||||
provides=(libsbc.so)
|
||||
_commit=b2c20a3ecf5ed00f63c94077a9762b505935ede9 # tags/1.5^0
|
||||
source=("git+$url#commit=$_commit"
|
||||
0001-Add-config.h-in-sbc-sbc_primitives.h.patch
|
||||
0002-Fix-build-on-ARM.patch)
|
||||
sha512sums=('SKIP'
|
||||
'5daaffdf735b6fa8d3526b02cccbb378aa91c72a6f093824164d335f80a72448285835666226ef5fcecc2fc802b1bf44cb34356bfe4e90b944a5b128373a9f52'
|
||||
'ffe8736c3efb51833eddd983a23ca924c2bf6071f59ff391e253c184469995a399d762ee05e826fb8a83f697c5698e8551e779c3d86a23238647df304a0d43f1')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -p1 -i ../0001-Add-config.h-in-sbc-sbc_primitives.h.patch
|
||||
patch -p1 -i ../0002-Fix-build-on-ARM.patch
|
||||
autoreconf -fvi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && CONFIG="--enable-high-precision"
|
||||
./configure --prefix=/usr --disable-static --disable-tester $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname
|
||||
make check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
Loading…
Reference in a new issue