Removed linux-api-headers and updated recursive-builder

This commit is contained in:
Mike Staszel 2010-05-17 17:27:17 -05:00
parent 007cbcbd7f
commit 6620d139cd
8 changed files with 54 additions and 266 deletions

View file

@ -1,41 +0,0 @@
# Maintainer: Mike Staszel <mikestaszel@plugbox.org>
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
pkgname=linux-api-headers
pkgver=2.6.33.3
_basever=2.6.33
pkgrel=1
pkgdesc="Kernel headers sanitized for use in userspace"
arch=('arm')
url="http://www.gnu.org/software/libc"
license=('GPL')
provides=("kernel-headers=${pkgver}")
conflicts=("glibc<=2.10.1-4" 'kernel-headers')
replaces=('kernel-headers')
source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${_basever}.tar.bz2
http://www.kernel.org/pub/linux/kernel/v2.6/patch-${pkgver}.bz2
scsi.patch)
md5sums=('c3883760b18d50e8d78819c54d579b00'
'dd6cd6a3aea70a2d90d1e8fd6abc3b45'
'b6d05566fcfe07770d9386f0588f8758')
build() {
cd ${srcdir}/linux-${_basever}
patch -Np1 -i ${srcdir}/patch-${pkgver} || return 1
# fix issues with transition of scsi.h from glibc
patch -Np1 -i ${srcdir}/scsi.patch || return 1
make mrproper
make headers_check || return 1
}
package() {
cd ${srcdir}/linux-${_basever}
make INSTALL_HDR_PATH=${pkgdir}/usr headers_install
rm -rf ${pkgdir}/usr/include/drm
rm -f $(find ${pkgdir} -name .install -or -name ..install.cmd)
}

View file

@ -1,4 +0,0 @@
These, if they help make udev, will replace the With-Linux ones.
They are exactly the same as the vanilla Arch Linux ones, with
no changes made.

View file

@ -1,42 +0,0 @@
diff -Naur linux-2.6.32-old/include/scsi/scsi.h linux-2.6.32/include/scsi/scsi.h
--- linux-2.6.32-old/include/scsi/scsi.h 2009-12-03 13:51:21.000000000 +1000
+++ linux-2.6.32/include/scsi/scsi.h 2009-12-12 10:43:11.000000000 +1000
@@ -145,14 +145,15 @@
/* defined in T10 SCSI Primary Commands-2 (SPC2) */
struct scsi_varlen_cdb_hdr {
- u8 opcode; /* opcode always == VARIABLE_LENGTH_CMD */
- u8 control;
- u8 misc[5];
- u8 additional_cdb_length; /* total cdb length - 8 */
+ __u8 opcode; /* opcode always == VARIABLE_LENGTH_CMD */
+ __u8 control;
+ __u8 misc[5];
+ __u8 additional_cdb_length; /* total cdb length - 8 */
__be16 service_action;
/* service specific data follows */
};
+#ifdef __KERNEL__
static inline unsigned
scsi_varlen_cdb_length(const void *hdr)
{
@@ -168,6 +169,7 @@
return (cmnd[0] == VARIABLE_LENGTH_CMD) ?
scsi_varlen_cdb_length(cmnd) : COMMAND_SIZE(cmnd[0]);
}
+#endif
/*
* SCSI Architecture Model (SAM) Status codes. Taken from SAM-3 draft
@@ -284,8 +286,10 @@
SCSI_PROTOCOL_UNSPEC = 0xf, /* No specific protocol */
};
+#ifdef __KERNEL__
/* Returns a human-readable name for the device */
extern const char * scsi_device_type(unsigned type);
+#endif
/*
* standard mode-select header prepended to all mode-select commands

View file

@ -1,9 +0,0 @@
This is the Plugbox Linux Core repository rebuilder.
Included are our makepkg.conf and abs.conf.
It's assumed (for now) that /media/usb/builder/ is the working directory,
and that /media/usb/builder/abs contains the ABS tree and
/media/usb/builder/plugapps is a copy of the PlugApps Git repo.
-- Mike Staszel

View file

@ -1,31 +0,0 @@
#
# /etc/abs.conf
#
# the top-level directory of all your PKGBUILDs
[ "$ABSROOT" = "" ] && ABSROOT="/media/usb/builder/abs/"
#
# Server to sync from
#
SYNCSERVER="rsync.archlinux.org"
#
# The architecture to fetch abs for
# Either i686 or x86_64
#
ARCH="i686"
#
# Pacman mirror list used for syncing via tarball
#
MIRRORLIST="/etc/pacman.d/mirrorlist"
#
# REPOS to be parsed by abs (in this order)
# (prefix a repo with a ! to disable it)
#
# Note: If a repo is removed, it is still fetched!
# Repos must be preceded with a ! to prevent fetching
#
REPOS=(core extra community !core/bin86 !core/isdn4k-utils !core/kernel26 !core/kernel26-lts !core/lilo !community-testing !testing !gnome-unstable !xorg18)

View file

@ -1,6 +0,0 @@
#! /bin/bash
#
# Plugbox Linux custom Core repository builder
# Version 0.0.1
#
# I don't do anything yet.

View file

@ -1,105 +0,0 @@
#
# /etc/makepkg.conf
#
#########################################################################
# SOURCE ACQUISITION
#########################################################################
#
#-- The download utilities that makepkg should use to acquire sources
# Format: 'protocol::agent'
DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
'http::/usr/bin/wget -c -t 3 --waitretry=3 -O %o %u'
'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
'rsync::/usr/bin/rsync -z %u %o'
'scp::/usr/bin/scp -C %u %o')
# Other common tools:
# /usr/bin/snarf
# /usr/bin/lftpget -c
# /usr/bin/curl
#########################################################################
# ARCHITECTURE, COMPILE FLAGS
#########################################################################
#
CARCH="arm"
CHOST="arm-none-linux-gnueabi"
#-- Exclusive: will only run on arm
# -march (or -mcpu) builds exclusively for an architecture
# -mtune optimizes for an architecture, but builds for whole processor family
CFLAGS="-march=armv5te -O2 -pipe"
CXXFLAGS="-march=armv5te -O2 -pipe"
LDFLAGS="-Wl,--hash-style=gnu -Wl,--as-needed"
#-- Make Flags: change this for DistCC/SMP systems
MAKEFLAGS="-j2"
#########################################################################
# BUILD ENVIRONMENT
#########################################################################
#
# Defaults: BUILDENV=(fakeroot !distcc color !ccache)
# A negated environment option will do the opposite of the comments below.
#
#-- fakeroot: Allow building packages as a non-root user
#-- distcc: Use the Distributed C/C++/ObjC compiler
#-- color: Colorize output messages
#-- ccache: Use ccache to cache compilation
#
BUILDENV=(fakeroot !distcc color !ccache)
#
#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
#-- specify a space-delimited list of hosts running in the DistCC cluster.
#DISTCC_HOSTS=""
#########################################################################
# GLOBAL PACKAGE OPTIONS
# These are default values for the options=() settings
#########################################################################
#
# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
# A negated option will do the opposite of the comments below.
#
#-- strip: Strip symbols from binaries/libraries in STRIP_DIRS
#-- docs: Save doc directories specified by DOC_DIRS
#-- libtool: Leave libtool (.la) files in packages
#-- emptydirs: Leave empty directories in packages
#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
#-- purge: Remove files specified by PURGE_TARGETS
#
OPTIONS=(strip docs libtool emptydirs zipman purge)
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
INTEGRITY_CHECK=(md5)
#-- Manual (man and info) directories to compress (if zipman is specified)
MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
#-- Doc directories to remove (if !docs is specified)
DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
#-- Directories to be searched for the strip option (if strip is specified)
STRIP_DIRS=(bin lib sbin usr/{bin,lib,sbin,local/{bin,lib,sbin}} opt/*/{bin,lib,sbin})
#-- Files to be removed from all packages (if purge is specified)
PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
#########################################################################
# PACKAGE OUTPUT
#########################################################################
#
# Default: put built package and cached source in build directory
#
#-- Destination: specify a fixed directory where all packages will be placed
PKGDEST=/media/usb/builder/packages
#-- Source cache: specify a fixed directory where source files will be cached
SRCDEST=/media/usb/builder/sources
#-- Packager: name/email of the person or organization building packages
PACKAGER="John Doe <jdoe@example.com>"
#########################################################################
# EXTENSION DEFAULTS
#########################################################################
#
# WARNING: Do NOT modify these variables unless you know what you are
# doing.
#
PKGEXT='.pkg.tar.xz'
SRCEXT='.src.tar.gz'

View file

@ -1,29 +1,55 @@
#!/bin/sh
# Set me to where you want packages
cd /media/usb/builder/pkg/core
echo $1
pacman -Ssq $1
if [ $? = 0 ]
then
{
echo $1 "already exists."
}
else
{
if [ ! -d ./$1 ]
then
{
cp -r /media/usb/builder/abs/core/$1 .
# You might want to change me too
}
fi
cd $1
f=`find . -name *.pkg.tar*`
echo $f
if [ -z $f ]
then
echo $1
makepkg --ignorearch --asroot --clean --syncdeps --noconfirm --rmdeps 2> $1-`date +%s`.log
fi
}
fi
#
# Plugbox Linux Repository Builder
# By IanJB and mikestaszel, with hopefully easy-to-read comments
# Licensed under the GPLv2
#
# ==== README ====
# Put the name of the repository after the command, eg.
# ./recursive-builder extra
#
# For reference, $1 is the name of the repository you want built
# Packages built will be placed whereever you set makepkg.conf to put them.
# Make sure to set the settings below before running this script!
# ==== SETTINGS ====
# Set me to the root of your ABS repository, by default /var/abs
ABSDIR=/media/usb/builder/abs
# Set me to your PlugApps Github clone
GITDIR=/media/usb/builder/plugapps
# Set me to the directory you want to work in
WORKDIR=/media/usb/builder/tmper
# Set me to the makepkg command - The default below should work fine
MAKEPKGCMD="makepkg --ignorearch --asroot --clean --syncdeps --noconfirm --rmdeps"
# ==== THE PROCESS ====
# Sync ABS to get latest PKGBUILDs
abs
mkdir -p $WORKDIR
# Copy vanilla ABS PKGBUILDs first...
echo "Copying PKGBUILDs to the working directory..."
cp -r $ABSDIR/$1 $WORKDIR
# Now overwrite them with modified Git PKGBUILDs (Testing)
cp -r $GITDIR/$1 $WORKDIR
# Here's the actual building
cd $WORKDIR/$1
# In the workdir, go to the repository, find the names of folders,
# go into each folder, run makepkg, and go to the next folder...
for i in `find . -type d -maxdepth 1 -mindepth 1`; do
cd $i > /dev/null 2>&1
$MAKEPKGCMD
done
echo "Deleting PKGBUILDs from the working directory..."
rm -rf $WORKDIR/$1
echo "All done!"