core/linux-aarch64 to 4.8.13-2

This commit is contained in:
Kevin Mihelich 2016-12-09 02:06:14 +00:00
parent 0e13667941
commit 66ef4394d6
4 changed files with 104 additions and 9 deletions

View file

@ -1,7 +1,7 @@
From db07c943b91eb4afcb52643ae867eba29dd7334c Mon Sep 17 00:00:00 2001
From 7820f9e243beb0c0953fbdc6057b4b42e97dbb1e Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 1/3] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index dc989a8..912be75 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.10.0
2.10.2

View file

@ -1,7 +1,7 @@
From a4338d28dfd8228fdcd8da798ca08ff66e53afe9 Mon Sep 17 00:00:00 2001
From f89dbad26eb8e0d1d188f8ae0dbb41c9049eef62 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Thu, 11 Aug 2016 18:50:50 +0100
Subject: [PATCH 2/2] arm64: dts: qcom: Fix broken interrupt trigger settings
Subject: [PATCH 2/3] arm64: dts: qcom: Fix broken interrupt trigger settings
When a device uses the GIC as its interrupt controller and generates
SPIs, only the values 1 (edge rising) and 4 (level high) are legal.
@ -73,5 +73,5 @@ index 55ec3e8..69ed6e1 100644
qcom,channel = <0>;
#address-cells = <2>;
--
2.10.0
2.10.2

View file

@ -0,0 +1,92 @@
From 8861d81cb05203c56be540bbb7a570f89d4f2cbd Mon Sep 17 00:00:00 2001
From: Philip Pettersson <philip.pettersson@gmail.com>
Date: Wed, 30 Nov 2016 14:55:36 -0800
Subject: [PATCH 3/3] packet: fix race condition in packet_set_ring
When packet_set_ring creates a ring buffer it will initialize a
struct timer_list if the packet version is TPACKET_V3. This value
can then be raced by a different thread calling setsockopt to
set the version to TPACKET_V1 before packet_set_ring has finished.
This leads to a use-after-free on a function pointer in the
struct timer_list when the socket is closed as the previously
initialized timer will not be deleted.
The bug is fixed by taking lock_sock(sk) in packet_setsockopt when
changing the packet version while also taking the lock at the start
of packet_set_ring.
Fixes: f6fb8f100b80 ("af-packet: TPACKET_V3 flexible buffer implementation.")
Signed-off-by: Philip Pettersson <philip.pettersson@gmail.com>
Signed-off-by: Eric Dumazet <edumazet@google.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/packet/af_packet.c | 18 ++++++++++++------
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
index d2238b2..dd23323 100644
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
@@ -3648,19 +3648,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
if (optlen != sizeof(val))
return -EINVAL;
- if (po->rx_ring.pg_vec || po->tx_ring.pg_vec)
- return -EBUSY;
if (copy_from_user(&val, optval, sizeof(val)))
return -EFAULT;
switch (val) {
case TPACKET_V1:
case TPACKET_V2:
case TPACKET_V3:
- po->tp_version = val;
- return 0;
+ break;
default:
return -EINVAL;
}
+ lock_sock(sk);
+ if (po->rx_ring.pg_vec || po->tx_ring.pg_vec) {
+ ret = -EBUSY;
+ } else {
+ po->tp_version = val;
+ ret = 0;
+ }
+ release_sock(sk);
+ return ret;
}
case PACKET_RESERVE:
{
@@ -4164,6 +4170,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
/* Added to avoid minimal code churn */
struct tpacket_req *req = &req_u->req;
+ lock_sock(sk);
/* Opening a Tx-ring is NOT supported in TPACKET_V3 */
if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
net_warn_ratelimited("Tx-ring is not supported.\n");
@@ -4245,7 +4252,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
goto out;
}
- lock_sock(sk);
/* Detach socket from network */
spin_lock(&po->bind_lock);
@@ -4294,11 +4300,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
if (!tx_ring)
prb_shutdown_retire_blk_timer(po, rb_queue);
}
- release_sock(sk);
if (pg_vec)
free_pg_vec(pg_vec, order, req->tp_block_nr);
out:
+ release_sock(sk);
return err;
}
--
2.10.2

View file

@ -8,7 +8,7 @@ _srcname=linux-4.8
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform"
pkgver=4.8.13
pkgrel=1
pkgrel=2
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@ -18,12 +18,14 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch'
'0003-packet-fix-race-condition-in-packet_set_ring.patch'
'config'
'linux.preset')
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
'bc208ac66340464839ee61a4621d9384'
'af972d95438c4b9e306ad24029d6acaf'
'e6fca8e5ddf634762d9ff7daa5e37a76'
'b74480b4d76cec9c0f20c12f04869f68'
'a9501be48aa1836e2b35d57137dd3a17'
'633cf4ffefc852c8d1e6011055f21742'
'10196df62fc9b36d53bc5e58bd95a4a3'
'b5ef67d6086e20de7b82265f562f88b1')
@ -36,6 +38,7 @@ prepare() {
# ALARM patches
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch
git apply ../0003-packet-fix-race-condition-in-packet_set_ring.patch
cat "${srcdir}/config" > ./.config