mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added community/gmic
This commit is contained in:
parent
1c6259c4be
commit
670514a434
2 changed files with 87 additions and 0 deletions
67
community/gmic/PKGBUILD
Normal file
67
community/gmic/PKGBUILD
Normal file
|
@ -0,0 +1,67 @@
|
|||
# $Id$
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Maintainer: Jan "heftig" Steffens <jan.steffens@gmail.com>
|
||||
# Contributor: farid <farid at archlinuc-br.org>
|
||||
# Contributor: Archie <Mymaud@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove -mtune=generic from makefile, replace with our CFLAGS
|
||||
|
||||
pkgbase=gmic
|
||||
pkgname=("gmic" "gimp-plugin-gmic" "zart")
|
||||
pkgver=1.5.7.0
|
||||
pkgrel=1
|
||||
arch=("i686" "x86_64")
|
||||
url="http://gmic.sourceforge.net"
|
||||
license=("custom:CeCILL")
|
||||
makedepends=('gimp' 'qt4' 'fftw' 'openexr' 'opencv' 'mesa' 'gtk2')
|
||||
#options=('!emptydirs')
|
||||
source=("http://downloads.sourceforge.net/sourceforge/gmic/gmic_${pkgver}.tar.gz"
|
||||
"opencv-buildfix.patch")
|
||||
md5sums=('76e4cc4847afb7fe8afa4d7f8690d4dc'
|
||||
'120319b0d6c81c5af186abe2281b79ca')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/gmic-${pkgver}"
|
||||
patch -p1 -i "${srcdir}/opencv-buildfix.patch"
|
||||
find "${srcdir}/gmic-${pkgver}/zart" -type f -execdir chmod 644 '{}' \;
|
||||
find "${srcdir}/gmic-${pkgver}/zart" -type d -execdir chmod 755 '{}' \;
|
||||
sed -i 's|qmake zart.pro|qmake-qt4 zart.pro|' src/Makefile
|
||||
sed -i "s|-mtune=generic|${CFLAGS}|" src/Makefile
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/gmic-${pkgver}"
|
||||
make -C src all
|
||||
}
|
||||
|
||||
package_gmic() {
|
||||
pkgdesc="GREYC's Magic Image Converter: image processing framework"
|
||||
depends=("fftw" "libtiff" "libjpeg" "libpng" "openexr" "libx11")
|
||||
replaces=("greycstoration")
|
||||
|
||||
cd "${srcdir}/gmic-${pkgver}"
|
||||
make -C src install DESTDIR="$pkgdir" USR="/usr"
|
||||
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
rm -rf "${pkgdir}/usr/"{bin/zart,lib/gimp,share/zart}
|
||||
}
|
||||
|
||||
package_zart() {
|
||||
pkgdesc="A GUI for G'MIC real-time manipulations on the output of a webcam"
|
||||
depends=("opencv" "fftw" "qt4")
|
||||
|
||||
cd "${srcdir}/gmic-${pkgver}"
|
||||
make -C src install DESTDIR="$pkgdir" USR="/usr"
|
||||
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
rm -rf "${pkgdir}/usr/"{bin/gmic,include,lib,share/{man,bash-completion}}
|
||||
}
|
||||
|
||||
package_gimp-plugin-gmic() {
|
||||
pkgdesc="Gimp plugin for the G'MIC image processing framework"
|
||||
depends=("gimp" "fftw")
|
||||
replaces=("gimp-plugin-greycstoration" "gimp-plugin-gmic4gimp")
|
||||
|
||||
cd "${srcdir}/gmic-${pkgver}"
|
||||
install -Dm755 src/gmic_gimp "${pkgdir}/usr/lib/gimp/2.0/plug-ins/gmic_gimp"
|
||||
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
}
|
20
community/gmic/opencv-buildfix.patch
Normal file
20
community/gmic/opencv-buildfix.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
diff -wbBur gmic-1.5.1.7/src/Makefile gmic-1.5.1.7.q/src/Makefile
|
||||
--- gmic-1.5.1.7/src/Makefile 2012-07-26 12:59:34.000000000 +0400
|
||||
+++ gmic-1.5.1.7.q/src/Makefile 2012-08-03 14:03:10.000000000 +0400
|
||||
@@ -296,7 +296,7 @@
|
||||
|
||||
zart: lib
|
||||
ifneq ($(OS),Darwin)
|
||||
- cd ../zart && qmake-qt4 zart.pro && $(MAKE) && strip zart
|
||||
+ cd ../zart && qmake zart.pro && $(MAKE) && strip zart
|
||||
else
|
||||
cd ../zart && qmake zart.pro && $(MAKE) "CFLAGS=$(STD_MACOSX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(STD_MACOSX_LDFLAGS) $(OPT_LDFLAGS)"
|
||||
endif
|
||||
@@ -403,6 +403,7 @@
|
||||
mkdir -p $(DESTDIR)$(USR)/share/man/fr/man1/
|
||||
cp -f ../man/gmic.1.gz $(DESTDIR)$(USR)/share/man/man1/gmic.1.gz
|
||||
cp -f ../man/gmic.1.gz $(DESTDIR)$(USR)/share/man/fr/man1/gmic.1.gz
|
||||
+ if test -d /usr/share/bash-completion/completions; then mkdir -p $(DESTDIR)/usr/share/bash-completion/completions/; cp -f gmic_bashcompletion.sh $(DESTDIR)/usr/share/bash-completion/completions/gmic; fi
|
||||
if test -d /etc/bash_completion.d/; then mkdir -p $(DESTDIR)/etc/bash_completion.d/; cp -f gmic_bashcompletion.sh $(DESTDIR)/etc/bash_completion.d/gmic; fi
|
||||
if test -d /opt/local/etc/bash_completion.d/; then mkdir -p $(DESTDIR)/opt/local/etc/bash_completion.d/; cp -f gmic_bashcompletion.sh $(DESTDIR)/opt/local/etc/bash_completion.d/gmic; fi
|
||||
|
Loading…
Reference in a new issue