mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/pyqt5 to 5.8-1
This commit is contained in:
parent
ce9d4b9e0a
commit
671cbccb72
2 changed files with 9 additions and 24 deletions
|
@ -11,9 +11,9 @@
|
|||
|
||||
pkgbase=pyqt5
|
||||
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
||||
pkgver=5.7.1
|
||||
pkgver=5.8
|
||||
_pkgver=$pkgver
|
||||
pkgrel=3
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
|
||||
license=('GPL')
|
||||
|
@ -21,20 +21,16 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
|
|||
'python2-dbus' 'python-dbus' 'qt5-connectivity'
|
||||
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
|
||||
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
|
||||
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-qt5.8.patch pyqt5-fix-check-license.patch opengles-hack.patch)
|
||||
md5sums=('b3171b67c74aa63a3cd2f386660c898b'
|
||||
'524f184f0e63aea952ba77702dff1356'
|
||||
'1f57fb76747c5723dc4747fbbb376145'
|
||||
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz"
|
||||
'opengles-hack.patch')
|
||||
md5sums=('ac04c0bfc1f05f5a1c2a1edd2640235c'
|
||||
'ad09b1c84c26d5e92de192477cb3a2d1')
|
||||
|
||||
prepare() {
|
||||
pushd PyQt5_gpl-${_pkgver}
|
||||
# Support Qt 5.8
|
||||
patch -p1 -i ../pyqt-qt5.8.patch
|
||||
# Hack to make the license check pass with Qt 5.8
|
||||
patch -p1 -i ../pyqt5-fix-check-license.patch
|
||||
# Hack for OpenGLES
|
||||
patch -p1 -i ../opengles-hack.patch
|
||||
# patch -p1 -i ../pyqt-qt5.8.patch
|
||||
patch -p1 -i ../opengles-hack.patch
|
||||
popd
|
||||
|
||||
# The additional include path was removed due to this line, I don't really know why they are doing this...
|
||||
|
@ -82,7 +78,7 @@ package_pyqt5-common(){
|
|||
|
||||
package_python-pyqt5(){
|
||||
pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit"
|
||||
depends=('python-sip' 'pyqt5-common' 'python' 'python')
|
||||
depends=('python-sip' 'pyqt5-common')
|
||||
optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'python-dbus: for python-dbus mainloop support'
|
||||
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
|
||||
|
@ -103,7 +99,7 @@ package_python-pyqt5(){
|
|||
|
||||
package_python2-pyqt5(){
|
||||
pkgdesc="A set of Python 2.x bindings for the Qt5 toolkit"
|
||||
depends=('python2-sip' 'pyqt5-common' 'python2')
|
||||
depends=('python2-sip' 'pyqt5-common')
|
||||
optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'python-dbus: for python-dbus mainloop support'
|
||||
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- PyQt5_gpl-5.7.1/configure.py.orig 2017-01-23 20:42:47.791266791 +0100
|
||||
+++ PyQt5_gpl-5.7.1/configure.py 2017-01-23 20:43:02.754828184 +0100
|
||||
@@ -723,7 +723,7 @@
|
||||
lines = f.read().split('\n')
|
||||
f.close()
|
||||
|
||||
- self.qt_licensee = lines[0]
|
||||
+ self.qt_licensee = 'Open Source'
|
||||
self.qt_shared = (lines[1] == 'shared')
|
||||
self.pyqt_disabled_features = lines[2:-1]
|
||||
|
Loading…
Reference in a new issue