mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/vtk to 9.2.5-2
This commit is contained in:
parent
c3d118ae7a
commit
6735d7e806
2 changed files with 11 additions and 60 deletions
|
@ -13,20 +13,20 @@
|
|||
# - removed -ffat-lto-objects from CFLAGS
|
||||
|
||||
pkgname=vtk
|
||||
pkgver=9.1.0
|
||||
pkgrel=26
|
||||
pkgver=9.2.5
|
||||
pkgrel=2
|
||||
pkgdesc="Software system for 3D computer graphics, image processing, and visualization"
|
||||
arch=(x86_64)
|
||||
url="https://www.vtk.org/"
|
||||
license=(BSD)
|
||||
depends=(gcc-libs double-conversion pugixml tbb)
|
||||
depends=(gcc-libs double-conversion pugixml tbb libtiff)
|
||||
makedepends=(cmake boost doxygen ffmpeg gdal git gnuplot java-environment=11
|
||||
liblas libxt mariadb-libs openmp openmpi openvdb
|
||||
openvr pdal postgresql-libs python-matplotlib qt5-base
|
||||
qt5-tools qt5-declarative tk unixodbc wget
|
||||
cgns cli11 eigen expat fmt freetype2 gl2ps glew hdf5 libjpeg
|
||||
jsoncpp libjsoncpp.so libharu proj libxml2 lz4 xz python-mpi4py
|
||||
netcdf libogg libpng rapidjson sqlite libtheora libtiff utf8cpp zfp zlib)
|
||||
netcdf libogg libpng rapidjson sqlite libtheora utf8cpp zfp zlib openxr verdict)
|
||||
# pegtl: https://gitlab.kitware.com/vtk/vtk/-/issues/18151
|
||||
# exprtk, ioss: not packaged
|
||||
optdepends=('gnuplot: plotting tools'
|
||||
|
@ -54,40 +54,22 @@ optdepends=('gnuplot: plotting tools'
|
|||
netcdf
|
||||
openvdb
|
||||
openvr
|
||||
openxr
|
||||
pdal
|
||||
postgresql-libs
|
||||
proj
|
||||
sqlite
|
||||
unixodbc)
|
||||
unixodbc
|
||||
verdict)
|
||||
source=(${url}/files/release/${pkgver%.*}/VTK-${pkgver}.tar.gz
|
||||
vtkm-tbb-2021.patch::https://gitlab.kitware.com/vtk/vtk-m/-/merge_requests/2509.patch
|
||||
vtk-ffmpeg5.patch::https://gitlab.kitware.com/vtk/vtk/-/merge_requests/8863.patch
|
||||
vtk-python3.10.patch::https://gitlab.kitware.com/vtk/vtk/-/merge_requests/8738.patch
|
||||
vtk-exodus-netcdf4.9-compat.patch::https://github.com/sandialabs/seacas/commit/5e1b19181110c52b76d13e3f60da2c8cf678c941.patch
|
||||
vtk-libharu-2.4.0.patch)
|
||||
)
|
||||
options=(staticlibs)
|
||||
sha256sums=('8fed42f4f8f1eb8083107b68eaa9ad71da07110161a3116ad807f43e5ca5ce96'
|
||||
'37cff664c4eaacf44ecb995e62e9e54e54880bae0857d598c74660a2159ccb2e'
|
||||
'955ef22d2541beb9935557ef09a802b6504855a350f27ff056734679da8f0281'
|
||||
'dbc9a67caf548cf5afd571018d91aadcfcf78ddf8c66ac75b0772935e26ad29f'
|
||||
'1272fafccd3d9677f3fd9cc0a70e47a21f6ec86379765e25c6bccd9053875259'
|
||||
'675707ec492182d1f0c8f4682775613dd9b5d315596af8df99ad4d758196e9c3')
|
||||
sha256sums=('128d601baa980e98ee034207974b33fb38d2c98ab9cf4a5756efdb09ed6c0949')
|
||||
|
||||
prepare() {
|
||||
cd VTK-${pkgver}
|
||||
# Fix build with libharu 2.4.0
|
||||
patch -p1 < ../vtk-libharu-2.4.0.patch
|
||||
# We have a patched fmt
|
||||
sed -i "s|8.1.0|9.0.0|" ThirdParty/fmt/CMakeLists.txt
|
||||
# Fix build with TBB 2021
|
||||
patch -p1 -d ThirdParty/vtkm/vtkvtkm/vtk-m < ../vtkm-tbb-2021.patch
|
||||
# Fix build with FFmpeg 5
|
||||
patch -p1 < ../vtk-ffmpeg5.patch
|
||||
# Fix Python 3.10 compatibility https://gitlab.kitware.com/vtk/vtk/-/issues/18518
|
||||
patch -p1 < ../vtk-python3.10.patch || true
|
||||
# Fix build with netCDF 4.9
|
||||
sed -i 's|1999-2020|1999-2021|' ThirdParty/exodusII/vtkexodusII/src/ex_utils.c
|
||||
patch -p5 -d ThirdParty/exodusII/vtkexodusII/ < ../vtk-exodus-netcdf4.9-compat.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -101,6 +83,7 @@ build() {
|
|||
-DCMAKE_INSTALL_LICENSEDIR=share/licenses/vtk \
|
||||
-DCMAKE_SKIP_RPATH=OFF \
|
||||
-DCMAKE_SKIP_INSTALL_RPATH=ON \
|
||||
-DCMAKE_JAVA_COMPILE_FLAGS="-Xlint:-options" \
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
-DVTK_BUILD_ALL_MODULES=ON \
|
||||
-DVTK_MODULE_ENABLE_VTK_IOADIOS2:STRING=NO \
|
||||
|
@ -146,7 +129,7 @@ package() {
|
|||
python -m compileall -o 0 -o 1 -o 2 --hardlink-dupes -s "${pkgdir}" "${pkgdir}"${site_packages}
|
||||
|
||||
# Remove third party CMake patching for older versions than ours
|
||||
rm -rv "${pkgdir}"/usr/lib/cmake/vtk/patches/3.{1{3,6,8,9},20}
|
||||
rm -rv "${pkgdir}"/usr/lib/cmake/vtk/patches/3.{1{3,6,9},20}
|
||||
# … as well as duplicate copies
|
||||
rm -rv "${pkgdir}"/usr/lib/cmake/vtk/vtkm/{Find*.cmake,cmake/{Find*.cmake,3.15}}
|
||||
}
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
diff --git a/IO/ExportPDF/vtkPDFContextDevice2D.cxx b/IO/ExportPDF/vtkPDFContextDevice2D.cxx
|
||||
index 2df979c303..541a73e882 100644
|
||||
--- a/IO/ExportPDF/vtkPDFContextDevice2D.cxx
|
||||
+++ b/IO/ExportPDF/vtkPDFContextDevice2D.cxx
|
||||
@@ -1617,21 +1617,21 @@ void vtkPDFContextDevice2D::ApplyLineWidth(float width)
|
||||
void vtkPDFContextDevice2D::ApplyLineType(int type)
|
||||
{
|
||||
// These match the OpenGL2 implementation:
|
||||
- static const HPDF_UINT16 noPen[] = { 0, 10 };
|
||||
+ static const HPDF_REAL noPen[] = { 0.0f, 10.0f };
|
||||
static const HPDF_UINT noPenLen = 2;
|
||||
|
||||
- static const HPDF_UINT16 dash[] = { 8 };
|
||||
+ static const HPDF_REAL dash[] = { 8.0f };
|
||||
static const HPDF_UINT dashLen = 1;
|
||||
|
||||
- static const HPDF_UINT16 dot[] = { 1, 7 };
|
||||
- static const HPDF_UINT16 denseDot[] = { 1, 3 };
|
||||
+ static const HPDF_REAL dot[] = { 1.0f, 7.0f };
|
||||
+ static const HPDF_REAL denseDot[] = { 1.0f, 3.0f };
|
||||
static const HPDF_UINT dotLen = 2;
|
||||
|
||||
- static const HPDF_UINT16 dashDot[] = { 4, 6, 2, 4 };
|
||||
+ static const HPDF_REAL dashDot[] = { 4.0f, 6.0f, 2.0f, 4.0f };
|
||||
static const HPDF_UINT dashDotLen = 4;
|
||||
|
||||
// This is dash-dot-dash, but eh. It matches the OpenGL2 0x1C47 pattern.
|
||||
- static const HPDF_UINT16 dashDotDot[] = { 3, 3, 1, 3, 3, 3 };
|
||||
+ static const HPDF_REAL dashDotDot[] = { 3.0f, 3.0f, 1.0f, 3.0f, 3.0f, 3.0f };
|
||||
static const HPDF_UINT dashDotDotLen = 6;
|
||||
|
||||
switch (type)
|
Loading…
Reference in a new issue