mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/rust to 1.33.0-2
This commit is contained in:
parent
bd66dd93d1
commit
67679fcf9f
2 changed files with 63 additions and 3 deletions
|
@ -0,0 +1,57 @@
|
|||
From 55030c7543d8e877ec7a6b577a51422c38f01259 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 1 Mar 2019 09:27:45 -0800
|
||||
Subject: [PATCH] Backport deprecation fixes from commit b7f030e
|
||||
|
||||
---
|
||||
src/tools/linkchecker/main.rs | 6 +++---
|
||||
src/tools/tidy/src/features.rs | 2 +-
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/tools/linkchecker/main.rs b/src/tools/linkchecker/main.rs
|
||||
index 59662be349dc..2cf0fcfd34cd 100644
|
||||
--- a/src/tools/linkchecker/main.rs
|
||||
+++ b/src/tools/linkchecker/main.rs
|
||||
@@ -78,7 +78,7 @@ impl FileEntry {
|
||||
fn parse_ids(&mut self, file: &Path, contents: &str, errors: &mut bool) {
|
||||
if self.ids.is_empty() {
|
||||
with_attrs_in_source(contents, " id", |fragment, i, _| {
|
||||
- let frag = fragment.trim_left_matches("#").to_owned();
|
||||
+ let frag = fragment.trim_start_matches("#").to_owned();
|
||||
let encoded = small_url_encode(&frag);
|
||||
if !self.ids.insert(frag) {
|
||||
*errors = true;
|
||||
@@ -343,7 +343,7 @@ fn with_attrs_in_source<F: FnMut(&str, usize, &str)>(contents: &str, attr: &str,
|
||||
Some(i) => i,
|
||||
None => continue,
|
||||
};
|
||||
- if rest[..pos_equals].trim_left_matches(" ") != "" {
|
||||
+ if rest[..pos_equals].trim_start_matches(" ") != "" {
|
||||
continue;
|
||||
}
|
||||
|
||||
@@ -355,7 +355,7 @@ fn with_attrs_in_source<F: FnMut(&str, usize, &str)>(contents: &str, attr: &str,
|
||||
};
|
||||
let quote_delim = rest.as_bytes()[pos_quote] as char;
|
||||
|
||||
- if rest[..pos_quote].trim_left_matches(" ") != "" {
|
||||
+ if rest[..pos_quote].trim_start_matches(" ") != "" {
|
||||
continue;
|
||||
}
|
||||
let rest = &rest[pos_quote + 1..];
|
||||
diff --git a/src/tools/tidy/src/features.rs b/src/tools/tidy/src/features.rs
|
||||
index 2435a0cfd4e3..bf2cfbf32fc7 100644
|
||||
--- a/src/tools/tidy/src/features.rs
|
||||
+++ b/src/tools/tidy/src/features.rs
|
||||
@@ -188,7 +188,7 @@ pub fn collect_lang_features(base_src_path: &Path, bad: &mut bool) -> Features {
|
||||
}
|
||||
|
||||
let mut parts = line.split(',');
|
||||
- let level = match parts.next().map(|l| l.trim().trim_left_matches('(')) {
|
||||
+ let level = match parts.next().map(|l| l.trim().trim_start_matches('(')) {
|
||||
Some("active") => Status::Unstable,
|
||||
Some("removed") => Status::Removed,
|
||||
Some("accepted") => Status::Stable,
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -16,25 +16,27 @@ highmem=1
|
|||
pkgname=('rust' 'rust-docs')
|
||||
epoch=1
|
||||
pkgver=1.33.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
|
||||
pkgdesc='Systems programming language focused on safety, speed and concurrency'
|
||||
url='https://www.rust-lang.org/'
|
||||
arch=('x86_64')
|
||||
license=('MIT' 'Apache')
|
||||
|
||||
makedepends=('rust' 'llvm' 'libffi' 'perl' 'python2' 'curl' 'cmake')
|
||||
makedepends=('rust' 'llvm7' 'libffi' 'perl' 'python2' 'curl' 'cmake')
|
||||
checkdepends=('procps-ng' 'gdb')
|
||||
|
||||
options=('!emptydirs')
|
||||
|
||||
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
|
||||
config.toml
|
||||
0001-Backport-deprecation-fixes-from-commit-b7f030e.patch
|
||||
0001-Revert-1c95f5a34c14f08d65cdd198827e3a2fcb63cf39-9452.patch)
|
||||
|
||||
sha256sums=('4c594c7712a0e7e8eae6526c464bf6ea1d82f77b4f61717c3fc28fb27ba2224a'
|
||||
'SKIP'
|
||||
'6a28c9768d0953d2774c7704d2bb293246c4733f2d4720e1ea441a0cd1763fb4'
|
||||
'd2fdd8ec0196e87b930f49a9ffa9fe7fe4995af54cfa8ee5638c7dc2170f5f8c'
|
||||
'cf04a3c8ac0b4f5d786532e6e07a2f52cea2216d899be8d7c0b087aab78a2b68')
|
||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
|
||||
|
@ -42,6 +44,7 @@ prepare() {
|
|||
cd "rustc-$pkgver-src"
|
||||
|
||||
cp "$srcdir"/config.toml config.toml
|
||||
patch -p1 <"$srcdir"/0001-Backport-deprecation-fixes-from-commit-b7f030e.patch
|
||||
patch -p1 <"$srcdir"/0001-Revert-1c95f5a34c14f08d65cdd198827e3a2fcb63cf39-9452.patch
|
||||
|
||||
if [[ $CARCH == armv7h ]]; then
|
||||
|
@ -61,7 +64,7 @@ build() {
|
|||
}
|
||||
|
||||
package_rust() {
|
||||
depends=('gcc-libs' 'llvm-libs' 'curl' 'libssh2')
|
||||
depends=('gcc-libs' 'llvm7-libs' 'curl' 'libssh2')
|
||||
provides=('cargo' 'rustfmt')
|
||||
conflicts=('cargo' 'rustfmt')
|
||||
replaces=('cargo' 'rustfmt')
|
||||
|
|
Loading…
Reference in a new issue