mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/linux-armv7 to 3.17.0-1
This commit is contained in:
parent
a7209f8a6f
commit
6773cf27db
7 changed files with 394 additions and 235 deletions
|
@ -1,6 +1,7 @@
|
||||||
|
From 285f6acfbbada8767df3afef1e9ca0c520b521e3 Mon Sep 17 00:00:00 2001
|
||||||
From: Willy Tarreau <w@xxxxxx>
|
From: Willy Tarreau <w@xxxxxx>
|
||||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||||
Subject: ARM: atags: add support for Marvell's u-boot
|
Subject: [PATCH 1/4] ARM: atags: add support for Marvell's u-boot
|
||||||
|
|
||||||
Marvell uses a specific atag in its u-boot which includes among other
|
Marvell uses a specific atag in its u-boot which includes among other
|
||||||
information the MAC addresses for up to 4 network interfaces.
|
information the MAC addresses for up to 4 network interfaces.
|
||||||
|
@ -46,4 +47,5 @@ index 979ff40..d1d0c19 100644
|
||||||
};
|
};
|
||||||
|
|
||||||
--
|
--
|
||||||
1.7.12.2.21.g234cd45.dirty
|
1.9.0
|
||||||
|
|
|
@ -1,6 +1,8 @@
|
||||||
|
From 97ab956f6b7398968dc3c2531cca009dc8506d9e Mon Sep 17 00:00:00 2001
|
||||||
From: Willy Tarreau <w@xxxxxx>
|
From: Willy Tarreau <w@xxxxxx>
|
||||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||||
Subject: ARM: atags/fdt: retrieve MAC addresses from Marvell boot loader
|
Subject: [PATCH 2/4] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||||
|
loader
|
||||||
|
|
||||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||||
addresses are extracted there and assigned to node aliases eth0..3
|
addresses are extracted there and assigned to node aliases eth0..3
|
||||||
|
@ -15,10 +17,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
|
||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
|
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
index d1153c8..24b31ae 100644
|
index 9448aa0..ac7b6ae 100644
|
||||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
@@ -16,7 +16,7 @@ static int node_offset(void *fdt, const char *node_path)
|
@@ -18,7 +18,7 @@ static int node_offset(void *fdt, const char *node_path)
|
||||||
}
|
}
|
||||||
|
|
||||||
static int setprop(void *fdt, const char *node_path, const char *property,
|
static int setprop(void *fdt, const char *node_path, const char *property,
|
||||||
|
@ -27,7 +29,7 @@ index d1153c8..24b31ae 100644
|
||||||
{
|
{
|
||||||
int offset = node_offset(fdt, node_path);
|
int offset = node_offset(fdt, node_path);
|
||||||
if (offset < 0)
|
if (offset < 0)
|
||||||
@@ -177,6 +177,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
|
@@ -179,6 +179,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
|
||||||
initrd_start);
|
initrd_start);
|
||||||
setprop_cell(fdt, "/chosen", "linux,initrd-end",
|
setprop_cell(fdt, "/chosen", "linux,initrd-end",
|
||||||
initrd_start + initrd_size);
|
initrd_start + initrd_size);
|
||||||
|
@ -41,4 +43,5 @@ index d1153c8..24b31ae 100644
|
||||||
}
|
}
|
||||||
|
|
||||||
--
|
--
|
||||||
1.7.12.2.21.g234cd45.dirty
|
1.9.0
|
||||||
|
|
|
@ -1,5 +1,35 @@
|
||||||
--- a/arch/arm/boot/dts/armada-370-smileplug.dts 1969-12-31 17:00:00.000000000 -0700
|
From 8e2d11f6ae3ca2fe7bd656f28a29404012e57e1d Mon Sep 17 00:00:00 2001
|
||||||
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts 2014-04-01 16:39:20.422308190 -0600
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||||
|
Subject: [PATCH 3/4] SMILE Plug device tree file
|
||||||
|
|
||||||
|
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||||
|
dts with the LED definitions.
|
||||||
|
|
||||||
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/Makefile | 1 +
|
||||||
|
arch/arm/boot/dts/armada-370-smileplug.dts | 167 +++++++++++++++++++++++++++++
|
||||||
|
2 files changed, 168 insertions(+)
|
||||||
|
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
||||||
|
|
||||||
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||||
|
index b8c5cd3..da19c45 100644
|
||||||
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
|
@@ -469,6 +469,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
|
||||||
|
dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||||
|
armada-370-db.dtb \
|
||||||
|
armada-370-mirabox.dtb \
|
||||||
|
+ armada-370-smileplug.dtb \
|
||||||
|
armada-370-netgear-rn102.dtb \
|
||||||
|
armada-370-netgear-rn104.dtb \
|
||||||
|
armada-370-rd.dtb
|
||||||
|
diff --git a/arch/arm/boot/dts/armada-370-smileplug.dts b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..6b30e82
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||||
@@ -0,0 +1,167 @@
|
@@ -0,0 +1,167 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Device Tree file for Marvell SMILE Plug
|
+ * Device Tree file for Marvell SMILE Plug
|
||||||
|
@ -168,13 +198,6 @@
|
||||||
+ };
|
+ };
|
||||||
+ };
|
+ };
|
||||||
+};
|
+};
|
||||||
--- a/arch/arm/boot/dts/Makefile 2014-04-01 16:42:20.851607958 -0600
|
--
|
||||||
+++ b/arch/arm/boot/dts/Makefile 2014-04-01 15:58:38.616212480 -0600
|
1.9.0
|
||||||
@@ -124,6 +124,7 @@
|
|
||||||
qcom-apq8074-dragonboard.dtb
|
|
||||||
dtb-$(CONFIG_ARCH_MVEBU) += armada-370-db.dtb \
|
|
||||||
armada-370-mirabox.dtb \
|
|
||||||
+ armada-370-smileplug.dtb \
|
|
||||||
armada-370-netgear-rn102.dtb \
|
|
||||||
armada-370-netgear-rn104.dtb \
|
|
||||||
armada-370-rd.dtb \
|
|
|
@ -1,20 +0,0 @@
|
||||||
--- a/drivers/mmc/host/mvsdio.c 2013-09-16 14:17:51.000000000 -0600
|
|
||||||
+++ b/drivers/mmc/host/mvsdio.c 2013-10-21 01:36:10.000000000 -0600
|
|
||||||
@@ -97,7 +97,7 @@
|
|
||||||
tmout_index = fls(tmout - 1) - 12;
|
|
||||||
if (tmout_index < 0)
|
|
||||||
tmout_index = 0;
|
|
||||||
- if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX)
|
|
||||||
+// if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX) //by steven, try to setup the timeout to maximum value
|
|
||||||
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
|
||||||
|
|
||||||
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
|
||||||
@@ -600,6 +600,8 @@
|
|
||||||
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
|
||||||
if (m > MVSD_BASE_DIV_MAX)
|
|
||||||
m = MVSD_BASE_DIV_MAX;
|
|
||||||
+ if(ios->clock==50000000 ) //by steven
|
|
||||||
+ m=1;
|
|
||||||
mvsd_write(MVSD_CLK_DIV, m);
|
|
||||||
host->clock = ios->clock;
|
|
||||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
|
38
core/linux-armv7/0004-fix-mvsdio-eMMC-timing.patch
Normal file
38
core/linux-armv7/0004-fix-mvsdio-eMMC-timing.patch
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
From 824d945bc3c3ec1a635ea078f6b4b19f0c780782 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||||
|
Subject: [PATCH 4/4] fix mvsdio eMMC timing
|
||||||
|
|
||||||
|
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||||
|
of the Mirabox and SMILE Plug to work.
|
||||||
|
|
||||||
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
---
|
||||||
|
drivers/mmc/host/mvsdio.c | 4 +++-
|
||||||
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||||
|
index 6b4c5ad..9f50234 100644
|
||||||
|
--- a/drivers/mmc/host/mvsdio.c
|
||||||
|
+++ b/drivers/mmc/host/mvsdio.c
|
||||||
|
@@ -97,7 +97,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||||
|
tmout_index = fls(tmout - 1) - 12;
|
||||||
|
if (tmout_index < 0)
|
||||||
|
tmout_index = 0;
|
||||||
|
- if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX)
|
||||||
|
+// if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX) //by steven, try to setup the timeout to maximum value
|
||||||
|
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
||||||
|
|
||||||
|
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
||||||
|
@@ -614,6 +614,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
|
||||||
|
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
||||||
|
if (m > MVSD_BASE_DIV_MAX)
|
||||||
|
m = MVSD_BASE_DIV_MAX;
|
||||||
|
+ if(ios->clock==50000000 ) //by steven
|
||||||
|
+ m=1;
|
||||||
|
mvsd_write(MVSD_CLK_DIV, m);
|
||||||
|
host->clock = ios->clock;
|
||||||
|
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||||
|
--
|
||||||
|
1.9.0
|
||||||
|
|
|
@ -4,51 +4,50 @@
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
pkgbase=linux-armv7
|
pkgbase=linux-armv7
|
||||||
_srcname=linux-3.16
|
_srcname=linux-3.17
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="ARMv7 multi-platform"
|
_desc="ARMv7 multi-platform"
|
||||||
pkgver=3.16.3
|
pkgver=3.17.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
rcnrel=armv7-x4
|
rcnrel=armv7-x2
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
||||||
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
#"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
||||||
"http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
|
"http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
|
||||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
||||||
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
||||||
'0001-atags-add-support-for-marvell-uboot.patch'
|
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
|
||||||
'0002-atags-retrieve-mac-addresses.patch'
|
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
|
||||||
'0003-smileplug-devicetree.patch'
|
'0003-SMILE-Plug-device-tree-file.patch'
|
||||||
'0004-emmc-timing-fix.patch'
|
'0004-fix-mvsdio-eMMC-timing.patch'
|
||||||
'config')
|
'config')
|
||||||
md5sums=('5c569ed649a0c9711879f333e90c5386'
|
md5sums=('fb30d0f29214d75cddd2faa94f73d5cf'
|
||||||
'387a93e4833df73217c6b9b92153aa7c'
|
'12ce5eb53d8c8d4d21715a6e89d98c5c'
|
||||||
'779883717469517e983442927ef45ad8'
|
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'3ad860d0d6daedc82091ea29c9730b95'
|
'b266bbfa3f3c487a87142d0c62daf544'
|
||||||
'02cce6b8f88c4392f552b14d0bf2e71c'
|
'1c1aa520091fcd25fa135582eddd0671'
|
||||||
'0a0c5691aea2503cd0c503cb50244f48'
|
'cbfb644a50651ef450f9e35570da1b3f'
|
||||||
'911bffe9c261ca5b91dd0a083d99e81f'
|
'19330f72bf29ce5271f77d8bf769706f'
|
||||||
'ccbc5f2f5b324f0490f497d175d2db31')
|
'9338f2504f33a879d8ec5edea3eb531d')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
# add upstream patch
|
# add upstream patch
|
||||||
patch -p1 -i ../patch-${pkgver}
|
#git apply --whitespace=nowarn ../patch-${pkgver}
|
||||||
|
|
||||||
# RCN patch
|
# RCN patch
|
||||||
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
|
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
|
||||||
|
|
||||||
# ALARM patches
|
# ALARM patches
|
||||||
patch -p1 -i ../0001-atags-add-support-for-marvell-uboot.patch
|
git apply ../0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
|
||||||
patch -p1 -i ../0002-atags-retrieve-mac-addresses.patch
|
git apply ../0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
|
||||||
patch -p1 -i ../0003-smileplug-devicetree.patch
|
git apply ../0003-SMILE-Plug-device-tree-file.patch
|
||||||
patch -p1 -i ../0004-emmc-timing-fix.patch
|
git apply ../0004-fix-mvsdio-eMMC-timing.patch
|
||||||
|
|
||||||
# AUFS patches
|
# AUFS patches
|
||||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||||
|
@ -56,10 +55,10 @@ prepare() {
|
||||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/linux
|
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/linux
|
||||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/uapi/linux
|
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/uapi/linux
|
||||||
|
|
||||||
patch -Np1 -i ../aufs3-standalone/aufs3-kbuild.patch
|
git apply ../aufs3-standalone/aufs3-kbuild.patch
|
||||||
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
|
git apply ../aufs3-standalone/aufs3-base.patch
|
||||||
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
|
git apply ../aufs3-standalone/aufs3-mmap.patch
|
||||||
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
|
git apply ../aufs3-standalone/aufs3-standalone.patch
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
@ -243,7 +242,6 @@ _package-headers() {
|
||||||
# add xfs and shmem for aufs building
|
# add xfs and shmem for aufs building
|
||||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs"
|
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs"
|
||||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/mm"
|
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/mm"
|
||||||
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs/xfs_sb.h"
|
|
||||||
|
|
||||||
# copy in Kconfig files
|
# copy in Kconfig files
|
||||||
for i in $(find . -name "Kconfig*"); do
|
for i in $(find . -name "Kconfig*"); do
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue