mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/kdeedu-kalgebra
This commit is contained in:
parent
7b913a6cea
commit
677645093f
3 changed files with 70 additions and 0 deletions
41
extra/kdeedu-kalgebra/PKGBUILD
Normal file
41
extra/kdeedu-kalgebra/PKGBUILD
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $Id: PKGBUILD 184890 2013-05-09 09:43:04Z andrea $
|
||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch and cmake define to disable opengl for ARM
|
||||
|
||||
pkgname=kdeedu-kalgebra
|
||||
pkgver=4.10.3
|
||||
pkgrel=1
|
||||
pkgdesc="Graph Calculator"
|
||||
url="http://kde.org/applications/education/kalgebra/"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'FDL')
|
||||
groups=('kde' 'kdeedu')
|
||||
depends=('kdebase-runtime' 'libkdeedu' 'kdeedu-analitza')
|
||||
makedepends=('cmake' 'automoc4')
|
||||
install=${pkgname}.install
|
||||
source=("http://download.kde.org/stable/${pkgver}/src/kalgebra-${pkgver}.tar.xz"
|
||||
"kalgebra-opengl_optional.patch")
|
||||
sha1sums=('c3c237cdf891259b2bef399d2b5c75a420e21d55'
|
||||
'ae1b75e5192f8519517134447b481421112a6dd7')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/kalgebra-${pkgver}"
|
||||
patch -p1 -i ../kalgebra-opengl_optional.patch
|
||||
|
||||
cd "${srcdir}"
|
||||
mkdir build
|
||||
cd build
|
||||
cmake ../kalgebra-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DKDE4_BUILD_TESTS=OFF \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DSHOULD_BUILD_OPENGL=OFF
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}"/build
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
17
extra/kdeedu-kalgebra/kalgebra-opengl_optional.patch
Normal file
17
extra/kdeedu-kalgebra/kalgebra-opengl_optional.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2013-05-02 23:37:45.511551937 -0500
|
||||
+++ b/CMakeLists.txt 2013-05-21 19:51:54.124577735 -0500
|
||||
@@ -11,8 +11,11 @@
|
||||
include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${KDE4_INCLUDES} ${LIBKDEEDU_INCLUDE_DIR}/qtmml ${ANALITZA_INCLUDE_DIR})
|
||||
|
||||
macro_optional_find_package(OpenGL)
|
||||
-macro_bool_to_01(OPENGL_FOUND HAVE_OPENGL)
|
||||
-macro_log_feature(OPENGL_FOUND "OpenGL" "Support for 3D graphs in KAlgebra" "http://mesa3d.sourceforge.net" FALSE "" "")
|
||||
+option(SHOULD_BUILD_OPENGL "Build OpenGL support" ON)
|
||||
+if(SHOULD_BUILD_OPENGL)
|
||||
+ macro_bool_to_01(OPENGL_FOUND HAVE_OPENGL)
|
||||
+endif(SHOULD_BUILD_OPENGL)
|
||||
+macro_log_feature(HAVE_OPENGL "OpenGL" "Support for 3D graphs in KAlgebra" "http://mesa3d.sourceforge.net" FALSE "" "")
|
||||
|
||||
macro_log_feature(QTMML_LIBRARY "QtMathML Widget" "Supports displaying some formulas in a mathematic form" "http://doc.qt.nokia.com/solutions/4/qtmmlwidget/qtmmlwidget.html" FALSE "" "")
|
||||
|
12
extra/kdeedu-kalgebra/kdeedu-kalgebra.install
Normal file
12
extra/kdeedu-kalgebra/kdeedu-kalgebra.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
Loading…
Reference in a new issue