mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/qt5-base to 5.9.1-5
This commit is contained in:
parent
c5dc8ddf03
commit
679fb9fa4b
3 changed files with 87 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
||||||
# $Id: PKGBUILD 240297 2015-06-03 10:22:03Z fyan $
|
# $Id$
|
||||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@ pkgbase=qt5-base
|
||||||
pkgname=(qt5-base qt5-xcb-private-headers)
|
pkgname=(qt5-base qt5-xcb-private-headers)
|
||||||
_qtver=5.9.1
|
_qtver=5.9.1
|
||||||
pkgver=${_qtver/-/}
|
pkgver=${_qtver/-/}
|
||||||
pkgrel=3.1
|
pkgrel=5
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://qt-project.org/'
|
url='http://qt-project.org/'
|
||||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||||
|
@ -32,10 +32,12 @@ groups=('qt' 'qt5')
|
||||||
_pkgfqn="${pkgbase/5-/}-opensource-src-${_qtver}"
|
_pkgfqn="${pkgbase/5-/}-opensource-src-${_qtver}"
|
||||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||||
qtbug-61731.patch::"https://github.com/qt/qtbase/commit/386af91c.patch"
|
qtbug-61731.patch::"https://github.com/qt/qtbase/commit/386af91c.patch"
|
||||||
qtcreatorbug-18448.patch::"https://github.com/qt/qtbase/commit/2a9f678f.patch")
|
qtcreatorbug-18448.patch::"https://github.com/qt/qtbase/commit/2a9f678f.patch"
|
||||||
|
harmony-fix.diff)
|
||||||
sha256sums=('bc9a21e9f6fff9629019fdf9f989f064751d5073c3a28dc596def92f4d4275c6'
|
sha256sums=('bc9a21e9f6fff9629019fdf9f989f064751d5073c3a28dc596def92f4d4275c6'
|
||||||
'b164a873894cfc783980e883082d2b22b5aab00166c6751f66e78d4c41c3e2e3'
|
'b164a873894cfc783980e883082d2b22b5aab00166c6751f66e78d4c41c3e2e3'
|
||||||
'5f878d144ac18097376dce154a411449cde181ddce2d93501114f890c9cdb1c3')
|
'5f878d144ac18097376dce154a411449cde181ddce2d93501114f890c9cdb1c3'
|
||||||
|
'8451c0a86e887492b706950ce533c616e687b790c54e86fb1f405dc2074737a3')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ${_pkgfqn}
|
cd ${_pkgfqn}
|
||||||
|
@ -58,6 +60,8 @@ prepare() {
|
||||||
patch -p1 -i ../qtbug-61731.patch
|
patch -p1 -i ../qtbug-61731.patch
|
||||||
# Fix doc navigation
|
# Fix doc navigation
|
||||||
patch -p1 -i ../qtcreatorbug-18448.patch
|
patch -p1 -i ../qtcreatorbug-18448.patch
|
||||||
|
# Freetype 2.8.1
|
||||||
|
patch -p1 -i ../harmony-fix.diff
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
76
extra/qt5-base/harmony-fix.diff
Normal file
76
extra/qt5-base/harmony-fix.diff
Normal file
|
@ -0,0 +1,76 @@
|
||||||
|
diff -u -r qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp
|
||||||
|
--- qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp 2017-06-28 11:54:29.000000000 +0200
|
||||||
|
+++ qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp 2017-09-19 21:31:27.803755180 +0200
|
||||||
|
@@ -786,6 +786,7 @@
|
||||||
|
m_subPixelPositionCount = 4;
|
||||||
|
forceAutoHint = false;
|
||||||
|
stemDarkeningDriver = false;
|
||||||
|
+ hasLcdRendering = false;
|
||||||
|
}
|
||||||
|
|
||||||
|
QFontEngineFT::~QFontEngineFT()
|
||||||
|
@@ -909,6 +910,15 @@
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+ FT_Int amajor = 0, aminor = 0, apatch = 0;
|
||||||
|
+ FT_Library_Version(qt_getFreetype(), &amajor, &aminor, &apatch);
|
||||||
|
+ if (amajor > 2 || amajor == 2 && (aminor > 8 || aminor == 8 && apatch >= 1))
|
||||||
|
+ hasLcdRendering = true;
|
||||||
|
+#if defined(QT_USE_FREETYPE_LCDFILTER)
|
||||||
|
+ else if (FT_Library_SetLcdFilter(qt_getFreetype(), FT_LCD_FILTER_NONE) == FT_Err_Ok)
|
||||||
|
+ hasLcdRendering = true;
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
fontDef.styleName = QString::fromUtf8(face->style_name);
|
||||||
|
|
||||||
|
if (!freetype->hbFace) {
|
||||||
|
@@ -1165,21 +1175,19 @@
|
||||||
|
|
||||||
|
int glyph_buffer_size = 0;
|
||||||
|
QScopedArrayPointer<uchar> glyph_buffer;
|
||||||
|
+ if (hasLcdRendering && slot->format == FT_GLYPH_FORMAT_OUTLINE && (hsubpixel || vfactor != 1)) {
|
||||||
|
#if defined(QT_USE_FREETYPE_LCDFILTER)
|
||||||
|
- bool useFreetypeRenderGlyph = false;
|
||||||
|
- if (slot->format == FT_GLYPH_FORMAT_OUTLINE && (hsubpixel || vfactor != 1)) {
|
||||||
|
- err = FT_Library_SetLcdFilter(slot->library, (FT_LcdFilter)lcdFilterType);
|
||||||
|
- if (err == FT_Err_Ok)
|
||||||
|
- useFreetypeRenderGlyph = true;
|
||||||
|
- }
|
||||||
|
+ FT_Library_SetLcdFilter(slot->library, (FT_LcdFilter)lcdFilterType);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
- if (useFreetypeRenderGlyph) {
|
||||||
|
err = FT_Render_Glyph(slot, hsubpixel ? FT_RENDER_MODE_LCD : FT_RENDER_MODE_LCD_V);
|
||||||
|
|
||||||
|
if (err != FT_Err_Ok)
|
||||||
|
qWarning("render glyph failed err=%x face=%p, glyph=%d", err, face, glyph);
|
||||||
|
|
||||||
|
+#if defined(QT_USE_FREETYPE_LCDFILTER)
|
||||||
|
FT_Library_SetLcdFilter(slot->library, FT_LCD_FILTER_NONE);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
info.height = slot->bitmap.rows / vfactor;
|
||||||
|
info.width = hsubpixel ? slot->bitmap.width / 3 : slot->bitmap.width;
|
||||||
|
@@ -1193,9 +1201,7 @@
|
||||||
|
convertRGBToARGB(slot->bitmap.buffer, (uint *)glyph_buffer.data(), info.width, info.height, slot->bitmap.pitch, subpixelType != Subpixel_RGB, false);
|
||||||
|
else if (vfactor != 1)
|
||||||
|
convertRGBToARGB_V(slot->bitmap.buffer, (uint *)glyph_buffer.data(), info.width, info.height, slot->bitmap.pitch, subpixelType != Subpixel_VRGB, false);
|
||||||
|
- } else
|
||||||
|
-#endif
|
||||||
|
- {
|
||||||
|
+ } else {
|
||||||
|
int left = slot->metrics.horiBearingX;
|
||||||
|
int right = slot->metrics.horiBearingX + slot->metrics.width;
|
||||||
|
int top = slot->metrics.horiBearingY;
|
||||||
|
diff -u -r qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h
|
||||||
|
--- qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h 2017-06-28 11:54:29.000000000 +0200
|
||||||
|
+++ qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h 2017-09-19 21:27:52.433263233 +0200
|
||||||
|
@@ -311,6 +311,7 @@
|
||||||
|
bool cacheEnabled;
|
||||||
|
bool forceAutoHint;
|
||||||
|
bool stemDarkeningDriver;
|
||||||
|
+ bool hasLcdRendering;
|
||||||
|
|
||||||
|
private:
|
||||||
|
friend class QFontEngineFTRawFont;
|
|
@ -7,9 +7,12 @@ skrooge *
|
||||||
kwin
|
kwin
|
||||||
lxqt-qtplugin
|
lxqt-qtplugin
|
||||||
pyqt5 *
|
pyqt5 *
|
||||||
|
qt5-styleplugins
|
||||||
deepin-qt5integration *
|
deepin-qt5integration *
|
||||||
deepin-tool-kit *
|
deepin-tool-kit *
|
||||||
deepin-file-manager *
|
deepin-file-manager *
|
||||||
|
dtkwidget *
|
||||||
|
dtkwm *
|
||||||
qt5ct
|
qt5ct
|
||||||
|
|
||||||
libqtxdg *
|
libqtxdg *
|
||||||
|
|
Loading…
Reference in a new issue