mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
parent
ee9a6cbc2a
commit
67b9b42820
4 changed files with 48 additions and 9 deletions
|
@ -1,7 +1,7 @@
|
|||
From a0840cc2f621e04af5751224e64b89ea0d39bf00 Mon Sep 17 00:00:00 2001
|
||||
From 9a0284605ceb91dbf1dfa49100f378dc6cb656a0 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Tue, 19 Jul 2016 10:21:03 -0400
|
||||
Subject: [PATCH 1/2] Adapt Block/WakeupHandler signature for ABI 23
|
||||
Subject: [PATCH 1/3] Adapt Block/WakeupHandler signature for ABI 23
|
||||
|
||||
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
||||
---
|
||||
|
@ -29,5 +29,5 @@ index fefbc59..78d3c91 100644
|
|||
#define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
|
||||
#define CLOSE_SCREEN_ARGS pScreen
|
||||
--
|
||||
2.11.0
|
||||
2.16.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From d724dc5671b4b47f4913105ffa158318b7731440 Mon Sep 17 00:00:00 2001
|
||||
From 9550c82bbef1b8943ed8067c2be6a7da04cd3b42 Mon Sep 17 00:00:00 2001
|
||||
From: Keith Packard <keithp@keithp.com>
|
||||
Date: Tue, 19 Jul 2016 08:51:12 -0700
|
||||
Subject: [PATCH 2/2] Use NotifyFd for drm fd
|
||||
Subject: [PATCH 2/3] Use NotifyFd for drm fd
|
||||
|
||||
NotifyFd is available after API 22, and must be used after API 23.
|
||||
|
||||
|
@ -109,5 +109,5 @@ index 8e45b5f..70fbc7c 100644
|
|||
+ drmmode_uevent_fini(pScrn);
|
||||
}
|
||||
--
|
||||
2.11.0
|
||||
2.16.2
|
||||
|
||||
|
|
|
@ -0,0 +1,36 @@
|
|||
From b3a2e9d5109d7e020a47f109938409272196d23f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 14 Jun 2018 11:59:02 -0600
|
||||
Subject: [PATCH 3/3] Initialize XRandR before EnterVT
|
||||
|
||||
---
|
||||
src/armsoc_driver.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
|
||||
index d8d82a1..7914d1c 100644
|
||||
--- a/src/armsoc_driver.c
|
||||
+++ b/src/armsoc_driver.c
|
||||
@@ -1125,6 +1125,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||
*/
|
||||
pScrn->vtSema = TRUE;
|
||||
|
||||
+ /* Do some XRandR initialization. Return value is not useful */
|
||||
+ (void)xf86CrtcScreenInit(pScreen);
|
||||
+
|
||||
/* Take over the virtual terminal from the console, set the
|
||||
* desired mode, etc.:
|
||||
*/
|
||||
@@ -1133,9 +1136,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||
goto fail6;
|
||||
}
|
||||
|
||||
- /* Do some XRandR initialization. Return value is not useful */
|
||||
- (void)xf86CrtcScreenInit(pScreen);
|
||||
-
|
||||
if (!miCreateDefColormap(pScreen)) {
|
||||
ERROR_MSG("Cannot create colormap!");
|
||||
goto fail7;
|
||||
--
|
||||
2.16.2
|
||||
|
|
@ -4,7 +4,7 @@ buildarch=4
|
|||
|
||||
pkgname=xf86-video-armsoc-rockchip
|
||||
pkgver=261.67d4cff
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
pkgdesc='X.org graphics driver for ARM graphics - Rockchip'
|
||||
arch=('armv7h')
|
||||
url="https://github.com/mmind/xf86-video-armsoc"
|
||||
|
@ -16,10 +16,12 @@ options=('!libtool')
|
|||
source=("$pkgname::git+https://github.com/mmind/xf86-video-armsoc.git#branch=devel/rockchip"
|
||||
'0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch'
|
||||
'0002-Use-NotifyFd-for-drm-fd.patch'
|
||||
'0003-Initialize-XRandR-before-EnterVT.patch'
|
||||
'20-armsoc.conf')
|
||||
md5sums=('SKIP'
|
||||
'c9ec23461d651841b128b68f07e25c7f'
|
||||
'e7a0f28ac376f0c97a05b1bb758d36e4'
|
||||
'5d4f9626343030e6fb2583601c89335f'
|
||||
'cf88a8f072f6505e8feb0418d1d66f81'
|
||||
'7f42ada17f6ca9bd045d2dfef399692e'
|
||||
'ca34299695813b200f0d6054c45d1f94')
|
||||
|
||||
pkgver() {
|
||||
|
@ -31,6 +33,7 @@ prepare() {
|
|||
cd $pkgname
|
||||
git apply ../0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch
|
||||
git apply ../0002-Use-NotifyFd-for-drm-fd.patch
|
||||
git apply ../0003-Initialize-XRandR-before-EnterVT.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue