extra/mesa to 19.3.4-2

This commit is contained in:
Kevin Mihelich 2020-02-15 19:23:48 +00:00
parent d442d69e48
commit 6864ee7a11
2 changed files with 76 additions and 7 deletions

View file

@ -0,0 +1,66 @@
From 689817c9dfde9a0852f2b2489cb0fa93ffbcb215 Mon Sep 17 00:00:00 2001
From: Krzysztof Raszkowski <krzysztof.raszkowski@intel.com>
Date: Mon, 10 Feb 2020 16:24:10 +0100
Subject: [PATCH] gallium/swr: simplify environmental variabled expansion code
There were 2 versions of code doing the same thing.
Since std::regexp are locale-sensitive better is to leave old
good way to do this.
Reviewed-by: Jan Zielinski <jan.zielinski@intel.com>
Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3761>
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3761>
---
.../codegen/templates/gen_knobs.cpp | 29 -------------------
1 file changed, 29 deletions(-)
diff --git a/src/gallium/drivers/swr/rasterizer/codegen/templates/gen_knobs.cpp b/src/gallium/drivers/swr/rasterizer/codegen/templates/gen_knobs.cpp
index b073f73e3a0..194499aa1e0 100644
--- a/src/gallium/drivers/swr/rasterizer/codegen/templates/gen_knobs.cpp
+++ b/src/gallium/drivers/swr/rasterizer/codegen/templates/gen_knobs.cpp
@@ -43,9 +43,6 @@
//========================================================
void KnobBase::autoExpandEnvironmentVariables(std::string& text)
{
-#if (__GNUC__) && (GCC_VERSION < 40900)
- // <regex> isn't implemented prior to gcc-4.9.0
- // unix style variable replacement
size_t start;
while ((start = text.find("${'${'}")) != std::string::npos)
{
@@ -64,32 +61,6 @@ void KnobBase::autoExpandEnvironmentVariables(std::string& text)
const std::string var = GetEnv(text.substr(start + 1, end - start - 1));
text.replace(start, end - start + 1, var);
}
-#else
- {
- // unix style variable replacement
- static std::regex env("\\$\\{([^}]+?)\\}");
- std::smatch match;
- while (std::regex_search(text, match, env))
- {
- const std::string var = GetEnv(match[1].str());
- // certain combinations of gcc/libstd++ have problems with this
- // text.replace(match[0].first, match[0].second, var);
- text.replace(match.prefix().length(), match[0].length(), var);
- }
- }
- {
- // win32 style variable replacement
- static std::regex env("%([^%]+?)%");
- std::smatch match;
- while (std::regex_search(text, match, env))
- {
- const std::string var = GetEnv(match[1].str());
- // certain combinations of gcc/libstd++ have problems with this
- // text.replace(match[0].first, match[0].second, var);
- text.replace(match.prefix().length(), match[0].length(), var);
- }
- }
-#endif
}
//========================================================
--
2.24.1

View file

@ -10,7 +10,7 @@ pkgbase=mesa
pkgname=('vulkan-mesa-layer' 'opencl-mesa' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
pkgdesc="An open-source implementation of the OpenGL specification"
pkgver=19.3.4
pkgrel=1
pkgrel=2
arch=('x86_64')
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols'
@ -19,10 +19,12 @@ makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence
url="https://www.mesa3d.org/"
license=('custom')
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
0001-gallium-swr-simplify-environmental-variabled-expansion-code.patch
0001-Rip-out-VC4-forced-NEON.patch
LICENSE)
sha512sums=('2bbb3dc8f1d839f11fe12cc959393cd69607fa6714b2166b80299e0559d2d3b0ac38ed4e15ac3e5f472264eb24536d1901d350f7409f3a7e00d6f4ccbb2312fb'
'SKIP'
'10c62cef7b9cd2617453397a7585fcc36bbe3dbb817f44fd59aee2ba11df67e5943cd919838f51e37ee523757210c3a3685c4676f561801cc9e47378b1c5fa09'
'ba55fd9816ebd9147be120da1fd4fa0364d19967a11570e6d5dd9d8b4f7971df46ced8b151ee07afaaa98043e131eed14918ec25f8c9b0f7e5c53f452674ee5c'
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
@ -34,6 +36,7 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
prepare() {
cd mesa-$pkgver
patch -Np1 < ../0001-gallium-swr-simplify-environmental-variabled-expansion-code.patch
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
}