mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
added extra/libsignon-glib
This commit is contained in:
parent
727ccc2a93
commit
687000c86b
2 changed files with 63 additions and 0 deletions
22
extra/libsignon-glib/0001-remove-meson-debug-option.patch
Normal file
22
extra/libsignon-glib/0001-remove-meson-debug-option.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
From fcea80a88608cb1b9e551c2b73fb84617397ee2b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 11 Oct 2018 18:34:18 -0600
|
||||
Subject: [PATCH] remove meson debug option
|
||||
|
||||
---
|
||||
meson_options.txt | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index eb48f98..4df8038 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -1,5 +1,4 @@
|
||||
option('tests', type : 'boolean', description : 'Build with test support')
|
||||
-option('debug', type : 'boolean', value: false, description : 'Printing of debug messages')
|
||||
option('python', type : 'boolean', description : 'Build with python support')
|
||||
option('documentation', type : 'boolean', description : 'Generate the documentation of the library')
|
||||
option('introspection', type : 'boolean', description : 'Build with the GObject introspection support')
|
||||
--
|
||||
2.18.0
|
||||
|
41
extra/libsignon-glib/PKGBUILD
Normal file
41
extra/libsignon-glib/PKGBUILD
Normal file
|
@ -0,0 +1,41 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Balló György <ballogyor+arch@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to remove 'debug' meson option for compatibility with meson 0.48
|
||||
|
||||
pkgname=libsignon-glib
|
||||
pkgver=2.0
|
||||
pkgrel=1
|
||||
pkgdesc='GLib-based client library for applications handling account authentication through the Online Accounts Single Sign-On service'
|
||||
arch=(x86_64)
|
||||
url='https://gitlab.com/accounts-sso/libsignon-glib'
|
||||
license=(LGPL2.1)
|
||||
depends=(signond)
|
||||
makedepends=(python-gobject gtk-doc gobject-introspection vala meson git)
|
||||
source=("git+https://gitlab.com/accounts-sso/${pkgname}#tag=VERSION_$pkgver"
|
||||
'0001-remove-meson-debug-option.patch')
|
||||
sha256sums=('SKIP'
|
||||
'ff25c4d082bbc28af1dc33094867affc6d900390d528e53a584a4aa6b6c01b66')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd $pkgname
|
||||
git submodule init
|
||||
git submodule update
|
||||
|
||||
git apply ../0001-remove-meson-debug-option.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
arch-meson ../$pkgname -Dtests=false
|
||||
ninja -j1
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
DESTDIR="$pkgdir" ninja install
|
||||
}
|
Loading…
Reference in a new issue