diff --git a/core/systemd/.SRCINFO b/core/systemd/.SRCINFO
index 0b7911471..c8710fc4d 100644
--- a/core/systemd/.SRCINFO
+++ b/core/systemd/.SRCINFO
@@ -1,5 +1,5 @@
 pkgbase = systemd
-	pkgver = 254.5
+	pkgver = 254.6
 	pkgrel = 1
 	url = https://www.github.com/systemd/systemd
 	arch = x86_64
@@ -49,7 +49,7 @@ pkgbase = systemd
 	makedepends = python-pyelftools
 	makedepends = lib32-gcc-libs
 	options = strip
-	source = git+https://github.com/systemd/systemd-stable#tag=42f5ba1e56ddb81c244e0d85f13109acdb14cbee?signed
+	source = git+https://github.com/systemd/systemd-stable#tag=5afac6471beec5401efb51f88990eaf92f3f9507?signed
 	source = git+https://github.com/systemd/systemd#tag=v254?signed
 	source = 0001-Use-Arch-Linux-device-access-groups.patch
 	source = initcpio-hook-udev
@@ -145,8 +145,8 @@ pkgname = systemd
 	optdepends = libp11-kit: support PKCS#11
 	optdepends = tpm2-tss: unlocking LUKS2 volumes with TPM2
 	provides = nss-myhostname
-	provides = systemd-tools=254.5
-	provides = udev=254.5
+	provides = systemd-tools=254.6
+	provides = udev=254.6
 	conflicts = nss-myhostname
 	conflicts = systemd-tools
 	conflicts = udev
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 857d19254..2668749f2 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -13,8 +13,8 @@ pkgname=('systemd'
          'systemd-resolvconf'
          'systemd-sysvcompat'
          'systemd-ukify')
-_tag='42f5ba1e56ddb81c244e0d85f13109acdb14cbee' # git rev-parse v${_tag_name}
-_tag_name=254.5
+_tag='5afac6471beec5401efb51f88990eaf92f3f9507' # git rev-parse v${_tag_name}
+_tag_name=254.6
 pkgver="${_tag_name/-/}"
 pkgrel=1
 arch=('x86_64')
@@ -233,7 +233,8 @@ package_systemd() {
   mv "$pkgdir"/usr/share/man/man3 systemd-libs/man3
 
   # ukify shipped in separate package
-  install -d -m0755 systemd-ukify/{systemd,man1}
+  install -d -m0755 systemd-ukify/{install.d,systemd,man1}
+  mv "$pkgdir"/usr/lib/kernel/install.d/{60-ukify,90-uki-copy}.install systemd-ukify/install.d/
   if [[ $CARCH != "armv7h" ]]; then
     mv "$pkgdir"/usr/lib/systemd/ukify systemd-ukify/systemd/
     mv "$pkgdir"/usr/share/man/man1/ukify.1 systemd-ukify/man1/
@@ -334,7 +335,8 @@ package_systemd-ukify() {
   optdepends=('python-pillow: Show the size of splash image'
               'sbsigntools: Sign the embedded kernel')
 
-  install -d -m0755 "$pkgdir"/usr/{lib,share/man}
+  install -d -m0755 "$pkgdir"/usr/{lib/kernel,share/man}
+  mv systemd-ukify/install.d "$pkgdir"/usr/lib/kernel/install.d
   mv systemd-ukify/systemd "$pkgdir"/usr/lib/systemd
   mv systemd-ukify/man1 "$pkgdir"/usr/share/man/man1
 }