alarm/uboot-raspberrypi to 2017.03-1

This commit is contained in:
Kevin Mihelich 2017-03-22 01:56:50 +00:00
parent b136535893
commit 68f0a91278
3 changed files with 13 additions and 32 deletions

View file

@ -1,37 +1,17 @@
From 2c1bea4109c351862aa1ebb425adababd630454c Mon Sep 17 00:00:00 2001
From a77f11cb0120a0e176fe09c06f37d6d46dfe1caa Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 19 Feb 2016 21:40:56 -0700
Subject: [PATCH] arch linux arm modifications
---
configs/rpi_2_defconfig | 1 +
configs/rpi_3_defconfig | 1 +
include/configs/rpi.h | 2 +-
3 files changed, 3 insertions(+), 1 deletion(-)
include/configs/rpi.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
index bddee43..1f6fb91 100644
--- a/configs/rpi_2_defconfig
+++ b/configs/rpi_2_defconfig
@@ -27,3 +27,4 @@ CONFIG_USB_KEYBOARD=y
CONFIG_LCD=y
CONFIG_PHYS_TO_BUS=y
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
index 9b6a72f..a0118f7 100644
--- a/configs/rpi_3_defconfig
+++ b/configs/rpi_3_defconfig
@@ -28,3 +28,4 @@ CONFIG_USB_KEYBOARD=y
CONFIG_LCD=y
CONFIG_PHYS_TO_BUS=y
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/include/configs/rpi.h b/include/configs/rpi.h
index 45c8234..12d6473 100644
index e293f2ed31..27c68b151e 100644
--- a/include/configs/rpi.h
+++ b/include/configs/rpi.h
@@ -187,7 +187,7 @@
@@ -172,7 +172,7 @@
"pxefile_addr_r=0x00100000\0" \
"kernel_addr_r=0x01000000\0" \
"scriptaddr=0x02000000\0" \
@ -41,5 +21,5 @@ index 45c8234..12d6473 100644
#define BOOT_TARGET_DEVICES(func) \
func(MMC, mmc, 0) \
--
2.10.2
2.12.0

View file

@ -4,7 +4,7 @@
buildarch=12
pkgname=uboot-raspberrypi
pkgver=2016.11
pkgver=2017.03
pkgrel=1
pkgdesc="U-Boot for Raspberry Pi"
arch=('armv7h' 'aarch64')
@ -18,10 +18,10 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
'boot.txt.v2'
'boot.txt.v3'
'mkscr')
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
'7410bad5df89ae981e8c4b680d40e40e'
'c42b8a22509ca7d1580ce3916c28ae74'
'b628c01f99130b5869596326d57634a8'
md5sums=('52fed6ce16e0c4a50e2cd4defdf9097a'
'f8ae1ac4c0bd70712a7cb36967ad35fb'
'69e883f0b8d1686b32bdf79684623f06'
'f59affa04863de0ffe3211ee6f17248d'
'021623a04afd29ac3f368977140cfbfd')
prepare() {
@ -40,6 +40,7 @@ build() {
make distclean
[[ $CARCH == "armv7h" ]] && make rpi_2_config
[[ $CARCH == "aarch64" ]] && make rpi_3_config
echo 'CONFIG_IDENT_STRING=" Arch Linux ARM"' >> .config
make EXTRAVERSION=-${pkgrel}
}

View file

@ -6,7 +6,7 @@ part uuid ${devtype} ${devnum}:2 uuid
setenv bootargs console=ttyS0,115200 console=tty0 root=PARTUUID=${uuid} rw rootwait smsc95xx.macaddr="${usbethaddr}"
if load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /Image; then
if load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /dtbs/broadcom/${fdtfile}; then
if load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /dtbs/${fdtfile}; then
if load ${devtype} ${devnum}:${bootpart} ${ramdisk_addr_r} /initramfs-linux.img; then
booti ${kernel_addr_r} ${ramdisk_addr_r}:${filesize} ${fdt_addr_r};
else