core/linux-aarch64 to 5.10.8-1

closes #1835
This commit is contained in:
Kevin Mihelich 2021-01-18 19:23:15 +00:00
parent 2e1d808141
commit 693a785f97
7 changed files with 498 additions and 272 deletions

View file

@ -1,25 +1,25 @@
From 9d1a3ff2e25ec610c427040734f2a7897770a8a8 Mon Sep 17 00:00:00 2001
From 4c4a7f5be455b62eab03af8d664b790a6453c999 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/5] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index bb4ccbda031a..84e40f5aea9f 100644
index ea0d5f04dc3a..88ebceb84193 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -48,6 +48,7 @@
@@ -50,6 +50,7 @@
#define SUSPEND_SUSPEND3 (0x08)
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
+#define MAC_ADDR_LEN (6)
#define CARRIER_CHECK_DELAY (2 * HZ)
@@ -70,6 +71,10 @@ static bool turbo_mode = true;
struct smsc95xx_priv {
u32 mac_cr;
@@ -67,6 +68,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -30,8 +30,8 @@ index bb4ccbda031a..84e40f5aea9f 100644
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm)
{
@@ -899,8 +904,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
@@ -753,8 +758,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return phy_mii_ioctl(netdev->phydev, rq, cmd);
}
+/* Check the macaddr module parameter for a MAC address */
@ -87,9 +87,9 @@ index bb4ccbda031a..84e40f5aea9f 100644
+ if (smsc95xx_is_macaddr_param(dev, dev->net->dev_addr))
+ return;
+
const u8 *mac_addr;
/* maybe the boot loader passed the MAC address in devicetree */
if (!eth_platform_get_mac_address(&dev->udev->dev,
dev->net->dev_addr)) {
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 289f465c446a084344ddf83c3c3e64a638a71e8f Mon Sep 17 00:00:00 2001
From fda1e1c741e44548eb6ef93f34d8e35487302c2e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 7 Aug 2017 19:34:57 -0600
Subject: [PATCH 2/5] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Subject: [PATCH 2/4] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
---
@ -9,7 +9,7 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
index 20b5599f5e78..458805cc5ce6 100644
index 6db18808b9c5..c7c49ace4b5b 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -640,7 +640,7 @@ diy_led_pin: diy-led-pin {
@ -22,5 +22,5 @@ index 20b5599f5e78..458805cc5ce6 100644
&pwm2 {
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 28ff08901badad204458e0da9d8d48df25fec49b Mon Sep 17 00:00:00 2001
From 049261c33ab0f5cb4156f5b9a894f30dcc50e2ab Mon Sep 17 00:00:00 2001
From: William Wu <william.wu@rock-chips.com>
Date: Mon, 4 Dec 2017 10:40:39 +0100
Subject: [PATCH 3/5] arm64: dts: rockchip: add usb3 controller node for RK3328
Subject: [PATCH 3/4] arm64: dts: rockchip: add usb3 controller node for RK3328
SoCs
RK3328 has one USB 3.0 OTG controller which uses DWC_USB3
@ -16,10 +16,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 27 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
index d399883d4b75..bad0bf49716e 100644
index db0d5c8e5f96..980dce4830d2 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi
+++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
@@ -982,6 +982,33 @@ usb_host0_ohci: usb@ff5d0000 {
@@ -983,6 +983,33 @@ usb_host0_ohci: usb@ff5d0000 {
status = "disabled";
};
@ -54,5 +54,5 @@ index d399883d4b75..bad0bf49716e 100644
compatible = "arm,gic-400";
#interrupt-cells = <3>;
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 177ff33895fbe4a5ec49eab834a10a7c4da55bd6 Mon Sep 17 00:00:00 2001
From 10446b4ecaee72bb5cdc437fcd73f1aea012e7cc Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Mon, 4 Dec 2017 10:40:41 +0100
Subject: [PATCH 4/5] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
Subject: [PATCH 4/4] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
Enable the nodes to make the usb3 port usable on that board.
@ -11,7 +11,7 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 9 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
index 6e09c223ed57..1dc8ae9fb0a2 100644
index 86cfb5c50a94..ae27f449f4a3 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
@@ -392,6 +392,15 @@ &usb_host0_ohci {
@ -31,5 +31,5 @@ index 6e09c223ed57..1dc8ae9fb0a2 100644
status = "okay";
};
--
2.27.0
2.30.0

View file

@ -1,51 +0,0 @@
From 783e9350713f9c62e52834e738cd85bafe4622cc Mon Sep 17 00:00:00 2001
From: Jessica Yu <jeyu@kernel.org>
Date: Tue, 1 Sep 2020 18:00:16 +0200
Subject: [PATCH 5/5] arm64/module: set trampoline section flags regardless of
CONFIG_DYNAMIC_FTRACE
In the arm64 module linker script, the section .text.ftrace_trampoline
is specified unconditionally regardless of whether CONFIG_DYNAMIC_FTRACE
is enabled (this is simply due to the limitation that module linker
scripts are not preprocessed like the vmlinux one).
Normally, for .plt and .text.ftrace_trampoline, the section flags
present in the module binary wouldn't matter since module_frob_arch_sections()
would assign them manually anyway. However, the arm64 module loader only
sets the section flags for .text.ftrace_trampoline when CONFIG_DYNAMIC_FTRACE=y.
That's only become problematic recently due to a recent change in
binutils-2.35, where the .text.ftrace_trampoline section (along with the
.plt section) is now marked writable and executable (WAX).
We no longer allow writable and executable sections to be loaded due to
commit 5c3a7db0c7ec ("module: Harden STRICT_MODULE_RWX"), so this is
causing all modules linked with binutils-2.35 to be rejected under arm64.
Drop the IS_ENABLED(CONFIG_DYNAMIC_FTRACE) check in module_frob_arch_sections()
so that the section flags for .text.ftrace_trampoline get properly set to
SHF_EXECINSTR|SHF_ALLOC, without SHF_WRITE.
Link: http://lore.kernel.org/r/20200831094651.GA16385@linux-8ccs
Acked-by: Will Deacon <will@kernel.org>
Signed-off-by: Jessica Yu <jeyu@kernel.org>
Acked-by: Ard Biesheuvel <ardb@kernel.org>
---
arch/arm64/kernel/module-plts.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/arch/arm64/kernel/module-plts.c b/arch/arm64/kernel/module-plts.c
index 65b08a74aec6..37c0b51a7b7b 100644
--- a/arch/arm64/kernel/module-plts.c
+++ b/arch/arm64/kernel/module-plts.c
@@ -271,8 +271,7 @@ int module_frob_arch_sections(Elf_Ehdr *ehdr, Elf_Shdr *sechdrs,
mod->arch.core.plt_shndx = i;
else if (!strcmp(secstrings + sechdrs[i].sh_name, ".init.plt"))
mod->arch.init.plt_shndx = i;
- else if (IS_ENABLED(CONFIG_DYNAMIC_FTRACE) &&
- !strcmp(secstrings + sechdrs[i].sh_name,
+ else if (!strcmp(secstrings + sechdrs[i].sh_name,
".text.ftrace_trampoline"))
tramp = sechdrs + i;
else if (sechdrs[i].sh_type == SHT_SYMTAB)
--
2.27.0

View file

@ -4,11 +4,11 @@
buildarch=8
pkgbase=linux-aarch64
_srcname=linux-5.8
_srcname=linux-5.10
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform"
pkgver=5.8.9
pkgrel=2
pkgver=5.10.8
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@ -20,7 +20,6 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
'0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch'
'0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch'
'0005-arm64-module-set-trampoline-section-flags-regardless.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -28,14 +27,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'linux.preset'
'60-linux.hook'
'90-linux.hook')
md5sums=('0e5c4c15266218ef26c50fac0016095b'
'76f0d7bc98014e70f9d3dd56dca08bd4'
'1e0168bbeced4491a247023f57aa0987'
'31faa2ff07683c7b1c4a0e66c80310ca'
'7cd6703350cd6ce2c08444b04c965811'
'cbc84352982eeeaa29e1d1d66d650e62'
'99d9b63a262b7baf0a9df8f7a28f1428'
'c1bb693df1d895abc6868d715a1f7e3b'
md5sums=('753adc474bf799d569dec4f165ed92c3'
'a552b8228212ab7810294bb6ee1ed148'
'f9b6f367eef351eaa89b23a9b1ffc5a2'
'369fb1dd626c4e0a4a7e068d27dd51c8'
'1553fe4abbe675ed8abd4644561d8e8c'
'9844db3484f4d4fa3e63c7e083f656f7'
'3be2795e55df51290bfc2f2decb814bd'
'7f1a96e24f5150f790df94398e9525a3'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -54,7 +52,6 @@ prepare() {
git apply ../0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch
git apply ../0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch
git apply ../0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch
git apply ../0005-arm64-module-set-trampoline-section-flags-regardless.patch
cat "${srcdir}/config" > ./.config
@ -173,7 +170,7 @@ _package-headers() {
cp -t "${_builddir}" -a include scripts
install -Dt "${_builddir}/arch/${KARCH}" -m644 arch/${KARCH}/Makefile
install -Dt "${_builddir}/arch/${KARCH}/kernel" -m644 arch/${KARCH}/kernel/asm-offsets.s arch/$KARCH/kernel/module.lds
install -Dt "${_builddir}/arch/${KARCH}/kernel" -m644 arch/${KARCH}/kernel/asm-offsets.s
cp -t "${_builddir}/arch/${KARCH}" -a arch/${KARCH}/include
mkdir -p "${_builddir}/arch/arm"

File diff suppressed because it is too large Load diff