diff --git a/extra/qt5/PKGBUILD b/extra/qt5/PKGBUILD
index 38da2c086..ea76858f3 100644
--- a/extra/qt5/PKGBUILD
+++ b/extra/qt5/PKGBUILD
@@ -32,7 +32,7 @@ pkgname=('qt5-base'
          'qt5-x11extras'
          'qt5-xmlpatterns')
 pkgver=5.2.0
-pkgrel=2
+pkgrel=3
 arch=('i686' 'x86_64')
 url='http://qt-project.org/'
 license=('GPL3' 'LGPL' 'FDL' 'custom')
@@ -41,7 +41,7 @@ makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb
             'libjpeg-turbo' 'cups' 'libpulse' 'hicolor-icon-theme' 'desktop-file-utils'
             'postgresql-libs' 'libmariadbclient' 'sqlite' 'unixodbc'
             'python2' 'ruby' 'gperf' 'libxslt' 'libxcomposite' 'fontconfig'
-            'openal' 'gtk2' 'libxkbcommon' 'icu' 'python')
+            'openal' 'gtk2' 'libxkbcommon' 'icu' 'python' 'harfbuzz')
 groups=('qt' 'qt5')
 _pkgfqn="qt-everywhere-opensource-src-${pkgver}"
 source=("http://download.qt-project.org/official_releases/qt/5.2/${pkgver}/single/${_pkgfqn}.tar.xz"
@@ -107,6 +107,7 @@ build() {
     -sysconfdir /etc/xdg \
     -examplesdir /usr/share/doc/qt/examples \
     -plugin-sql-{psql,mysql,sqlite,odbc} \
+    -system-harfbuzz \
     -system-sqlite \
     -openssl-linked \
     -nomake examples \
@@ -142,7 +143,7 @@ package_qt5-base() {
   pkgdesc='A cross-platform application and UI framework'
   depends=('libjpeg-turbo' 'xcb-util-keysyms' 'libgl' 'dbus' 'fontconfig' 'systemd'
            'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu'
-           'qtchooser' 'libxkbcommon')
+           'qtchooser' 'libxkbcommon' 'harfbuzz')
   optdepends=('postgresql-libs: PostgreSQL driver'
               'libmariadbclient: MariaDB driver'
               'unixodbc: ODBC driver')