core/linux-kirkwood-dt to 5.10.14-1

This commit is contained in:
Kevin Mihelich 2021-02-07 20:27:49 +00:00
parent 5878072036
commit 699166521e
9 changed files with 69 additions and 135 deletions

View file

@ -1,4 +1,4 @@
From 2c85df8a81c1b8a9ff7170f195e569718bb80e10 Mon Sep 17 00:00:00 2001
From 27316c3bd9c9aa2058edda79b2d8b9663b0bb7a0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:32:06 -0700
Subject: [PATCH 1/7] leds: trigger: Introduce a SATA trigger

View file

@ -1,4 +1,4 @@
From 46cabc7ba646ec301e238f7fb8ccd7ed9d9dd88b Mon Sep 17 00:00:00 2001
From 8cadc8ea5d5576c2b8b96b499937b7096c0b34e2 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:34:33 -0700
Subject: [PATCH 2/7] ata: sata_mv: Add SATA activity LED trigger support

View file

@ -1,4 +1,4 @@
From 8f43348b6b0e28bca91c8913a5623b1bee4ffbbc Mon Sep 17 00:00:00 2001
From 1fa882e4c70e69eeefbc8d288275f9d6fee92d8d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:37:08 -0700
Subject: [PATCH 3/7] ARM: dts: kirkwood-pogo_e02: Set health LED to default-on

View file

@ -1,4 +1,4 @@
From c8d7638cbef83d8a38957b7663412546d71b8608 Mon Sep 17 00:00:00 2001
From a56c64e1b36e0cbc4736489667611d538ba033a5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:38:04 -0700
Subject: [PATCH 4/7] Fix mvsdio SD card detection

View file

@ -1,4 +1,4 @@
From ed7ec1236840b4c8f5cc61535e2c3b91b1f70718 Mon Sep 17 00:00:00 2001
From 9f07c9b93aa7ae53fc1ad026eff47662f2f49560 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:42:40 -0700
Subject: [PATCH 5/7] ARM: dts: kirkwood: Initial support for GoFlex Home

View file

@ -1,4 +1,4 @@
From a2545842afc893d09e4fa125b93329bc8636d5c1 Mon Sep 17 00:00:00 2001
From 4517a0f64d12498830f16b61bf6e871c8ba636ff Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:45:51 -0700
Subject: [PATCH 6/7] Revert "vfs,mm: fix a dead loop in

View file

@ -1,118 +0,0 @@
From 46e3b871f8aaca8be4dfd17fe942b1d40ba5ccfc Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 1 Feb 2021 17:19:21 -0700
Subject: [PATCH 7/7] Revert "SUNRPC: Handle TCP socket sends with
kernel_sendpage() again"
This reverts commit 00ee972739fb2526d3936f1e7ccfc8c91d250c60.
---
net/sunrpc/svcsock.c | 86 +-------------------------------------------
1 file changed, 1 insertion(+), 85 deletions(-)
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
index 4404c491eb38..c2752e2b9ce3 100644
--- a/net/sunrpc/svcsock.c
+++ b/net/sunrpc/svcsock.c
@@ -1062,90 +1062,6 @@ static int svc_tcp_recvfrom(struct svc_rqst *rqstp)
return 0; /* record not complete */
}
-static int svc_tcp_send_kvec(struct socket *sock, const struct kvec *vec,
- int flags)
-{
- return kernel_sendpage(sock, virt_to_page(vec->iov_base),
- offset_in_page(vec->iov_base),
- vec->iov_len, flags);
-}
-
-/*
- * kernel_sendpage() is used exclusively to reduce the number of
- * copy operations in this path. Therefore the caller must ensure
- * that the pages backing @xdr are unchanging.
- *
- * In addition, the logic assumes that * .bv_len is never larger
- * than PAGE_SIZE.
- */
-static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
- struct xdr_buf *xdr, rpc_fraghdr marker,
- unsigned int *sentp)
-{
- const struct kvec *head = xdr->head;
- const struct kvec *tail = xdr->tail;
- struct kvec rm = {
- .iov_base = &marker,
- .iov_len = sizeof(marker),
- };
- int flags, ret;
-
- *sentp = 0;
- xdr_alloc_bvec(xdr, GFP_KERNEL);
-
- msg->msg_flags = MSG_MORE;
- ret = kernel_sendmsg(sock, msg, &rm, 1, rm.iov_len);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != rm.iov_len)
- return -EAGAIN;
-
- flags = head->iov_len < xdr->len ? MSG_MORE | MSG_SENDPAGE_NOTLAST : 0;
- ret = svc_tcp_send_kvec(sock, head, flags);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != head->iov_len)
- goto out;
-
- if (xdr->page_len) {
- unsigned int offset, len, remaining;
- struct bio_vec *bvec;
-
- bvec = xdr->bvec;
- offset = xdr->page_base;
- remaining = xdr->page_len;
- flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
- while (remaining > 0) {
- if (remaining <= PAGE_SIZE && tail->iov_len == 0)
- flags = 0;
- len = min(remaining, bvec->bv_len);
- ret = kernel_sendpage(sock, bvec->bv_page,
- bvec->bv_offset + offset,
- len, flags);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != len)
- goto out;
- remaining -= len;
- offset = 0;
- bvec++;
- }
- }
-
- if (tail->iov_len) {
- ret = svc_tcp_send_kvec(sock, tail, 0);
- if (ret < 0)
- return ret;
- *sentp += ret;
- }
-
-out:
- return 0;
-}
-
/**
* svc_tcp_sendto - Send out a reply on a TCP socket
* @rqstp: completed svc_rqst
@@ -1173,7 +1089,7 @@ static int svc_tcp_sendto(struct svc_rqst *rqstp)
mutex_lock(&xprt->xpt_mutex);
if (svc_xprt_is_dead(xprt))
goto out_notconn;
- err = svc_tcp_sendmsg(svsk->sk_sock, &msg, xdr, marker, &sent);
+ err = xprt_sock_sendmsg(svsk->sk_sock, &msg, xdr, 0, marker, &sent);
xdr_free_bvec(xdr);
trace_svcsock_tcp_send(xprt, err < 0 ? err : sent);
if (err < 0 || sent != (xdr->len + sizeof(marker)))
--
2.30.0

View file

@ -0,0 +1,52 @@
From 6a6dfc24ba04d438864d4726646506b82eeb7ef3 Mon Sep 17 00:00:00 2001
From: Chuck Lever <chuck.lever@oracle.com>
Date: Sun, 31 Jan 2021 16:16:23 -0500
Subject: [PATCH 7/7] SUNRPC: Fix NFS READs that start at non-page-aligned
offsets
Anj Duvnjak reports that the Kodi.tv NFS client is not able to read
video files from a v5.10.11 Linux NFS server.
The new sendpage-based TCP sendto logic was not attentive to non-
zero page_base values. nfsd_splice_read() sets that field when a
READ payload starts in the middle of a page.
The Linux NFS client rarely emits an NFS READ that is not page-
aligned. All of my testing so far has been with Linux clients, so I
missed this one.
Reported-by: A. Duvnjak <avian@extremenerds.net>
BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=211471
Fixes: 4a85a6a3320b ("SUNRPC: Handle TCP socket sends with kernel_sendpage() again")
Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
Tested-by: A. Duvnjak <avian@extremenerds.net>
---
net/sunrpc/svcsock.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
index 4404c491eb38..fa7b7ae2c2c5 100644
--- a/net/sunrpc/svcsock.c
+++ b/net/sunrpc/svcsock.c
@@ -1113,14 +1113,15 @@ static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
unsigned int offset, len, remaining;
struct bio_vec *bvec;
- bvec = xdr->bvec;
- offset = xdr->page_base;
+ bvec = xdr->bvec + (xdr->page_base >> PAGE_SHIFT);
+ offset = offset_in_page(xdr->page_base);
remaining = xdr->page_len;
flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
while (remaining > 0) {
if (remaining <= PAGE_SIZE && tail->iov_len == 0)
flags = 0;
- len = min(remaining, bvec->bv_len);
+
+ len = min(remaining, bvec->bv_len - offset);
ret = kernel_sendpage(sock, bvec->bv_page,
bvec->bv_offset + offset,
len, flags);
--
2.30.0

View file

@ -7,7 +7,7 @@ pkgbase=linux-kirkwood-dt
_srcname=linux-5.10
_kernelname=${pkgbase#linux}
_desc="Marvell Kirkwood DT"
pkgver=5.10.13
pkgver=5.10.14
pkgrel=1
arch=('arm')
url="http://www.kernel.org/"
@ -22,20 +22,20 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'0004-Fix-mvsdio-SD-card-detection.patch'
'0005-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch'
'0006-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch'
'0007-Revert-SUNRPC-Handle-TCP-socket-sends-with-kernel_se.patch'
'0007-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch'
'config'
'linux.preset'
'99-linux.hook')
md5sums=('753adc474bf799d569dec4f165ed92c3'
'4a34221501c7ee90ba275743bc552488'
'0c40a7e045a7538bf3c8d755e51012e5'
'2aedfdadfb808e3636289a64197ff916'
'171cb19a6ef34ba1e668d6c150276b3d'
'7dd30493a4c00a71a93f7d4f90fa2c11'
'1f1b1c2d26748d38b709bd6df6804910'
'c538017c7d0a0fd98ab269934267c195'
'a38ffa8241b0df8d05e34014b0526685'
'd928049c6149ed507afbb72c90cb2dc2'
'a6b4d912185d05ce8da3c197a8819c67'
'6fd639f9b8c27a517493aaf6648f6b96'
'2127d09de35cb87b4704d62e2d2affdc'
'43f8997ea02d1a5143c02c7a47536129'
'4d188618504694ca6cc8db3eb0a6aee9'
'238a66247da0f9a57d179027e94f8cfa'
'70e6dad899f235ce620eddac81165cbf'
'bcee56942897ee4f0253619843859b7f'
'959e49540dac4c5e689ad9037150a360'
'79fa396e3f9a09a85156d6d7c2d34b58')
@ -52,7 +52,7 @@ prepare() {
git apply ../0004-Fix-mvsdio-SD-card-detection.patch
git apply ../0005-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch
git apply ../0006-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch
git apply ../0007-Revert-SUNRPC-Handle-TCP-socket-sends-with-kernel_se.patch
git apply ../0007-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch
cat "${srcdir}/config" > ./.config