mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/nodejs: v5 fix
This commit is contained in:
parent
85b44238b9
commit
69d934a2cd
3 changed files with 58 additions and 26 deletions
54
community/nodejs/0001-arm-fixes.patch
Normal file
54
community/nodejs/0001-arm-fixes.patch
Normal file
|
@ -0,0 +1,54 @@
|
|||
From 3ea8b43a40ae4c31c684d75a18d27961efa3aab1 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 16 Sep 2015 17:51:00 -0600
|
||||
Subject: [PATCH] arm fixes
|
||||
|
||||
---
|
||||
configure | 7 +++++--
|
||||
deps/v8/build/toolchain.gypi | 4 ++--
|
||||
2 files changed, 7 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 6c8dfde..cc7dbfa 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -603,9 +603,12 @@ def configure_arm(o):
|
||||
if is_arch_armv7():
|
||||
o['variables']['arm_fpu'] = 'vfpv3'
|
||||
o['variables']['arm_version'] = '7'
|
||||
- else:
|
||||
+ elif is_arch_armv6():
|
||||
o['variables']['arm_fpu'] = 'vfpv2'
|
||||
- o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
|
||||
+ o['variables']['arm_version'] = '6'
|
||||
+ else:
|
||||
+ o['variables']['arm_fpu'] = ''
|
||||
+ o['variables']['arm_version'] = '5'
|
||||
|
||||
o['variables']['arm_thumb'] = 0 # -marm
|
||||
o['variables']['arm_float_abi'] = arm_float_abi
|
||||
diff --git a/deps/v8/build/toolchain.gypi b/deps/v8/build/toolchain.gypi
|
||||
index 4dbf42b..8d3e968 100644
|
||||
--- a/deps/v8/build/toolchain.gypi
|
||||
+++ b/deps/v8/build/toolchain.gypi
|
||||
@@ -203,7 +203,7 @@
|
||||
}],
|
||||
[ 'arm_version==7 or arm_version=="default"', {
|
||||
'conditions': [
|
||||
- [ 'arm_fpu!="default"', {
|
||||
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
||||
'cflags': ['-mfpu=<(arm_fpu)',],
|
||||
}],
|
||||
],
|
||||
@@ -246,7 +246,7 @@
|
||||
}],
|
||||
[ 'arm_version==7 or arm_version=="default"', {
|
||||
'conditions': [
|
||||
- [ 'arm_fpu!="default"', {
|
||||
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
||||
'cflags': ['-mfpu=<(arm_fpu)',],
|
||||
}],
|
||||
],
|
||||
--
|
||||
2.5.2
|
||||
|
|
@ -12,7 +12,7 @@ pkgname=nodejs
|
|||
pkgver=4.0.0
|
||||
pkgrel=1
|
||||
pkgdesc='Evented I/O for V8 javascript'
|
||||
arch=('i686' 'x86_64' 'arm')
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://nodejs.org/'
|
||||
license=('MIT')
|
||||
provides=('nodejs-node-gyp')
|
||||
|
@ -20,9 +20,9 @@ depends=('openssl' 'zlib' 'icu') # 'libuv' 'v8' 'c-ares')
|
|||
makedepends=('python2' 'procps-ng')
|
||||
optdepends=('npm: nodejs package manager')
|
||||
source=("http://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz"
|
||||
'arm.patch')
|
||||
'0001-arm-fixes.patch')
|
||||
sha256sums=('e110e5a066f3a6fe565ede7dd66f3727384b9b5c5fbf46f8db723d726e2f5900'
|
||||
'218c1e89b50819dfe91f25fc3a1ea4143e8af2a3927d99dcae58eba1b14b4c86')
|
||||
'13f14499c0a83d282ac07d1116a2d9196b4ae37dbd6914865f0b6549158789c4')
|
||||
|
||||
set_flags_for_arm() {
|
||||
if [ "$CARCH" == "arm" ]; then
|
||||
|
@ -46,7 +46,7 @@ set_flags_for_arm() {
|
|||
prepare() {
|
||||
cd node-v$pkgver
|
||||
|
||||
patch -p1 -i ../arm.patch
|
||||
patch -p1 -i ../0001-arm-fixes.patch
|
||||
|
||||
msg 'Fixing for python2 name'
|
||||
find -type f -exec sed \
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
diff --git a/deps/v8/build/toolchain.gypi b/deps/v8/build/toolchain.gypi
|
||||
index 1d47360..9c2e376 100644
|
||||
--- a/deps/v8/build/toolchain.gypi
|
||||
+++ b/deps/v8/build/toolchain.gypi
|
||||
@@ -159,7 +159,7 @@
|
||||
}],
|
||||
[ 'arm_version==7 or arm_version=="default"', {
|
||||
'conditions': [
|
||||
- [ 'arm_fpu!="default"', {
|
||||
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
||||
'cflags': ['-mfpu=<(arm_fpu)',],
|
||||
}],
|
||||
],
|
||||
@@ -202,7 +202,7 @@
|
||||
}],
|
||||
[ 'arm_version==7 or arm_version=="default"', {
|
||||
'conditions': [
|
||||
- [ 'arm_fpu!="default"', {
|
||||
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
||||
'cflags': ['-mfpu=<(arm_fpu)',],
|
||||
}],
|
||||
],
|
Loading…
Reference in a new issue