mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
removed extra/kalgebra
This commit is contained in:
parent
7fd9aa6947
commit
6a35a305e6
2 changed files with 0 additions and 60 deletions
|
@ -1,47 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch and cmake define to disable opengl for ARM
|
||||
|
||||
pkgname=kalgebra
|
||||
pkgver=16.12.3
|
||||
pkgrel=1
|
||||
pkgdesc="Graph Calculator"
|
||||
url="https://kde.org/applications/education/kalgebra/"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'FDL')
|
||||
groups=('kde-applications' 'kdeedu')
|
||||
depends=('analitza' 'kio' 'qt5-webkit' 'hicolor-icon-theme')
|
||||
makedepends=('extra-cmake-modules' 'kdoctools' 'python' 'glu')
|
||||
optdepends=('kirigami: for KAlgebra Mobile')
|
||||
replaces=('kdeedu-kalgebra')
|
||||
conflicts=('kdeedu-kalgebra' 'kdeedu-analitza')
|
||||
source=("https://download.kde.org/stable/applications/${pkgver}/src/kalgebra-${pkgver}.tar.xz"{,.sig}
|
||||
'kalgebra-disable-opengl.patch')
|
||||
sha256sums=('0b6781917d2b5cbe7b400b5ece5d163a846cfec3ff93aaa0a72d90fa4ab41162'
|
||||
'SKIP'
|
||||
'281bd6ace1614d9982d6a3bf37c42b711e49618c64a4632eab6fac47da360dc7')
|
||||
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7) # Albert Astals Cid <aacid@kde.org>
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
cd kalgebra-${pkgver}
|
||||
patch -p1 -i ../kalgebra-disable-opengl.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
cmake ../kalgebra-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DKDE4_BUILD_TESTS=OFF \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DSHOULD_BUILD_OPENGL=OFF
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2014-11-12 18:59:40.000000000 -0700
|
||||
+++ b/CMakeLists.txt 2015-01-24 11:04:26.558025684 -0700
|
||||
@@ -17,8 +17,7 @@
|
||||
|
||||
include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR})
|
||||
|
||||
-find_package(OpenGL)
|
||||
-set(HAVE_OPENGL ${OPENGL_FOUND})
|
||||
+set(HAVE_OPENGL FALSE)
|
||||
set_package_properties(OpenGL PROPERTIES TYPE OPTIONAL
|
||||
PURPOSE "Support for 3D graphs in KAlgebra"
|
||||
URL "http://opengl.org")
|
Loading…
Reference in a new issue