mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-armv5 to 4.0.4-1
This commit is contained in:
parent
21ee9ba04a
commit
6a6ea54b11
5 changed files with 44 additions and 44 deletions
|
@ -1,7 +1,7 @@
|
|||
From ef05a3ce8340c7156610b173324ab793b06e0ae2 Mon Sep 17 00:00:00 2001
|
||||
From e74efbd1dd2b84c8761af9d2be2dc1294fbb8b6d Mon Sep 17 00:00:00 2001
|
||||
From: Michal Ulianko <info@itserve.cz>
|
||||
Date: Mon, 29 Jul 2013 20:14:38 +0200
|
||||
Subject: [PATCH 1/2] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
|
||||
Subject: [PATCH 1/5] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
|
||||
|
||||
---
|
||||
sound/soc/codecs/Kconfig | 4 +
|
||||
|
@ -23,10 +23,10 @@ Subject: [PATCH 1/2] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
|
|||
create mode 100644 sound/soc/mxs/mxs-builtin-pcm.h
|
||||
|
||||
diff --git a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
|
||||
index badb6fb..dc1f4ac 100644
|
||||
index 061c465..577f7fd 100644
|
||||
--- a/sound/soc/codecs/Kconfig
|
||||
+++ b/sound/soc/codecs/Kconfig
|
||||
@@ -127,6 +127,7 @@ config SND_SOC_ALL_CODECS
|
||||
@@ -170,6 +170,7 @@ config SND_SOC_ALL_CODECS
|
||||
select SND_SOC_WM9705 if SND_SOC_AC97_BUS
|
||||
select SND_SOC_WM9712 if SND_SOC_AC97_BUS
|
||||
select SND_SOC_WM9713 if SND_SOC_AC97_BUS
|
||||
|
@ -34,7 +34,7 @@ index badb6fb..dc1f4ac 100644
|
|||
help
|
||||
Normally ASoC codec drivers are only built if a machine driver which
|
||||
uses them is also built since they are only usable with a machine
|
||||
@@ -515,6 +516,9 @@ config SND_SOC_WM9712
|
||||
@@ -844,6 +845,9 @@ config SND_SOC_WM9712
|
||||
config SND_SOC_WM9713
|
||||
tristate
|
||||
|
||||
|
@ -45,10 +45,10 @@ index badb6fb..dc1f4ac 100644
|
|||
config SND_SOC_LM4857
|
||||
tristate
|
||||
diff --git a/sound/soc/codecs/Makefile b/sound/soc/codecs/Makefile
|
||||
index 70fd806..9c3b73a 100644
|
||||
index abe2d7e..9ef8c98 100644
|
||||
--- a/sound/soc/codecs/Makefile
|
||||
+++ b/sound/soc/codecs/Makefile
|
||||
@@ -120,6 +120,7 @@ snd-soc-wm9705-objs := wm9705.o
|
||||
@@ -175,6 +175,7 @@ snd-soc-wm9705-objs := wm9705.o
|
||||
snd-soc-wm9712-objs := wm9712.o
|
||||
snd-soc-wm9713-objs := wm9713.o
|
||||
snd-soc-wm-hubs-objs := wm_hubs.o
|
||||
|
@ -56,7 +56,7 @@ index 70fd806..9c3b73a 100644
|
|||
|
||||
# Amp
|
||||
snd-soc-max9877-objs := max9877.o
|
||||
@@ -246,6 +247,7 @@ obj-$(CONFIG_SND_SOC_WM9712) += snd-soc-wm9712.o
|
||||
@@ -357,6 +358,7 @@ obj-$(CONFIG_SND_SOC_WM9712) += snd-soc-wm9712.o
|
||||
obj-$(CONFIG_SND_SOC_WM9713) += snd-soc-wm9713.o
|
||||
obj-$(CONFIG_SND_SOC_WM_ADSP) += snd-soc-wm-adsp.o
|
||||
obj-$(CONFIG_SND_SOC_WM_HUBS) += snd-soc-wm-hubs.o
|
||||
|
@ -66,7 +66,7 @@ index 70fd806..9c3b73a 100644
|
|||
obj-$(CONFIG_SND_SOC_MAX9877) += snd-soc-max9877.o
|
||||
diff --git a/sound/soc/codecs/mxs-builtin-codec.c b/sound/soc/codecs/mxs-builtin-codec.c
|
||||
new file mode 100644
|
||||
index 0000000..e5dcb4e
|
||||
index 0000000..cd74a8f
|
||||
--- /dev/null
|
||||
+++ b/sound/soc/codecs/mxs-builtin-codec.c
|
||||
@@ -0,0 +1,1128 @@
|
||||
|
@ -2030,10 +2030,10 @@ index 0000000..75dee0b
|
|||
+
|
||||
+#endif /* __MXS_ADC_CODEC_H */
|
||||
diff --git a/sound/soc/mxs/Kconfig b/sound/soc/mxs/Kconfig
|
||||
index 78d321c..9b8dd7d 100644
|
||||
index 219235c..7612ef8 100644
|
||||
--- a/sound/soc/mxs/Kconfig
|
||||
+++ b/sound/soc/mxs/Kconfig
|
||||
@@ -18,3 +18,13 @@ config SND_SOC_MXS_SGTL5000
|
||||
@@ -19,3 +19,13 @@ config SND_SOC_MXS_SGTL5000
|
||||
a sgtl5000 codec.
|
||||
|
||||
endif # SND_MXS_SOC
|
||||
|
@ -2192,7 +2192,7 @@ index 0000000..7a27c63
|
|||
+MODULE_LICENSE("GPL");
|
||||
diff --git a/sound/soc/mxs/mxs-builtin-dai.c b/sound/soc/mxs/mxs-builtin-dai.c
|
||||
new file mode 100644
|
||||
index 0000000..cc81f9a
|
||||
index 0000000..de29256
|
||||
--- /dev/null
|
||||
+++ b/sound/soc/mxs/mxs-builtin-dai.c
|
||||
@@ -0,0 +1,588 @@
|
||||
|
@ -2725,7 +2725,7 @@ index 0000000..cc81f9a
|
|||
+ }
|
||||
+
|
||||
+ ret = devm_request_irq(&pdev->dev, mxs_adc->hp_short_irq, mxs_short_irq,
|
||||
+ IRQF_DISABLED | IRQF_SHARED, "MXS DAC and ADC HP SHORT", mxs_adc);
|
||||
+ IRQF_SHARED, "MXS DAC and ADC HP SHORT", mxs_adc);
|
||||
+ if (ret) {
|
||||
+ printk(KERN_ERR "%s: Unable to request ADC/DAC HP SHORT irq %d\n",
|
||||
+ __func__, mxs_adc->hp_short_irq);
|
||||
|
@ -2891,5 +2891,5 @@ index 0000000..2fba109
|
|||
+
|
||||
+#endif
|
||||
--
|
||||
1.7.10.4
|
||||
2.3.5
|
||||
|
||||
|
|
|
@ -1,18 +1,18 @@
|
|||
From a68d3fb3c79b2860a230532c178ed7685db535f7 Mon Sep 17 00:00:00 2001
|
||||
From 67cd1951bac133002ce52cd7132625ff6f1943a8 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Nelson <robertcnelson@gmail.com>
|
||||
Date: Mon, 12 Aug 2013 11:27:22 -0500
|
||||
Subject: [PATCH 2/2] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
|
||||
Subject: [PATCH 2/5] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
|
||||
|
||||
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
||||
---
|
||||
arch/arm/boot/dts/imx23-olinuxino.dts | 25 +++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/imx23-olinuxino.dts | 25 +++++++++++++++++++++++++
|
||||
1 file changed, 25 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
index fc766ae..4a96623 100644
|
||||
index 8204539..db0fd3f 100644
|
||||
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
@@ -88,6 +88,25 @@
|
||||
@@ -89,6 +89,25 @@
|
||||
usbphy0: usbphy@8007c000 {
|
||||
status = "okay";
|
||||
};
|
||||
|
@ -38,8 +38,8 @@ index fc766ae..4a96623 100644
|
|||
};
|
||||
};
|
||||
|
||||
@@ -122,4 +141,10 @@
|
||||
gpios = <&gpio2 1 1>;
|
||||
@@ -127,4 +146,10 @@
|
||||
gpios = <&gpio2 1 GPIO_ACTIVE_HIGH>;
|
||||
};
|
||||
};
|
||||
+
|
||||
|
@ -50,5 +50,5 @@ index fc766ae..4a96623 100644
|
|||
+ };
|
||||
};
|
||||
--
|
||||
1.7.10.4
|
||||
2.3.5
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 96f0b63db8df533cc619212f41e134cdf112b853 Mon Sep 17 00:00:00 2001
|
||||
From aad1b273d25d2a45aa7527913955c215eac4b86f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 18 Jun 2014 21:55:51 -0600
|
||||
Subject: [PATCH] imx23 I2C fixes
|
||||
Subject: [PATCH 3/5] imx23 I2C fixes
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/imx23-olinuxino.dts | 35 ++++++++++++++++++++++++++++++
|
||||
|
@ -9,10 +9,10 @@ Subject: [PATCH] imx23 I2C fixes
|
|||
2 files changed, 75 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
index 7e6eef2..5caef60 100644
|
||||
index db0fd3f..aca7625 100644
|
||||
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
@@ -73,6 +73,25 @@
|
||||
@@ -74,6 +74,25 @@
|
||||
status = "okay";
|
||||
};
|
||||
|
||||
|
@ -38,7 +38,7 @@ index 7e6eef2..5caef60 100644
|
|||
duart: serial@80070000 {
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&duart_pins_a>;
|
||||
@@ -113,6 +132,22 @@
|
||||
@@ -134,6 +153,22 @@
|
||||
startup-delay-us = <300>; /* LAN9215 requires a POR of 200us minimum */
|
||||
gpio = <&gpio0 17 0>;
|
||||
};
|
||||
|
@ -122,5 +122,5 @@ index bbcfb5a..54b6a83 100644
|
|||
dma-names = "rx-tx";
|
||||
status = "disabled";
|
||||
--
|
||||
1.9.0
|
||||
2.3.5
|
||||
|
|
@ -1,11 +1,11 @@
|
|||
From 2edc71fc799c4fb2661a4b69767f2e28a096954b Mon Sep 17 00:00:00 2001
|
||||
From 1d9e3650cc61660e0bed3c4696be90cff10cd21b Mon Sep 17 00:00:00 2001
|
||||
From: Michal Ulianko <info@itserve.cz>
|
||||
Date: Tue, 30 Jul 2013 14:28:17 +0200
|
||||
Subject: [PATCH 2/2] Added DTS with mxs-builtin-* entries for testing the
|
||||
Subject: [PATCH 4/5] Added DTS with mxs-builtin-* entries for testing the
|
||||
audio driver.
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/imx23-audio.dts | 153 +++++++++++++++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/imx23-audio.dts | 153 ++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 153 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx23-audio.dts
|
||||
|
||||
|
@ -169,5 +169,5 @@ index 0000000..1555896
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
1.7.10.4
|
||||
2.3.5
|
||||
|
|
@ -7,7 +7,7 @@ pkgbase=linux-armv5
|
|||
_srcname=linux-4.0
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv5 multi-platform"
|
||||
pkgver=4.0.3
|
||||
pkgver=4.0.4
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -19,17 +19,17 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
"git+https://github.com/sfjro/aufs4-standalone.git#branch=aufs${pkgver%.*}"
|
||||
#"git+https://github.com/sfjro/aufs4-standalone.git#branch=aufs4.x-rcN"
|
||||
'0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch'
|
||||
'0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
|
||||
'0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
|
||||
'0001-imx23-I2C-fixes.patch'
|
||||
'0002-ARM-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
|
||||
'0003-imx23-I2C-fixes.patch'
|
||||
'0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
|
||||
'config')
|
||||
md5sums=('a86916bd12798220da9eb4a1eec3616d'
|
||||
'0ccd3969e595402f4f6bed790d5481a6'
|
||||
'30de8c55237264deee4d4fc60eee78fd'
|
||||
'SKIP'
|
||||
'114af68d721fdc22548994b847807929'
|
||||
'3a1e689563354c2f9f2d2764e1baa334'
|
||||
'a88071c80e1c2b22637894ae148c74b8'
|
||||
'e64077ce856769fc3af2a15ae95d8310'
|
||||
'ed7991bb04554fd9ed4292ffd07bc916'
|
||||
'9225efbd445352fcfeaa83317bed0825'
|
||||
'560af5c50a5374201e3b89113cd69977'
|
||||
'8b9d27de7a5a5b73dba4dbd249b378eb'
|
||||
'1b4db68ad21f2abee8824b3b449dad65')
|
||||
|
||||
prepare() {
|
||||
|
@ -40,9 +40,9 @@ prepare() {
|
|||
|
||||
# ALARM patches
|
||||
git apply ../0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch
|
||||
git apply ../0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
|
||||
git apply ../0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
|
||||
git apply ../0001-imx23-I2C-fixes.patch
|
||||
git apply ../0002-ARM-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
|
||||
git apply ../0003-imx23-I2C-fixes.patch
|
||||
git apply ../0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs4-standalone/Documentation" .
|
||||
|
|
Loading…
Reference in a new issue