mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed community/freeradius
This commit is contained in:
parent
830fcbefc0
commit
6a7f18f966
5 changed files with 0 additions and 117 deletions
|
@ -1,77 +0,0 @@
|
|||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: Jason R Begley (jayray@digitalgoat.com>
|
||||
# Contributor: Daniel Micay <danielmicay@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=freeradius
|
||||
pkgver=3.0.25
|
||||
pkgrel=5
|
||||
pkgdesc='The premier open source RADIUS server'
|
||||
arch=('x86_64')
|
||||
url="https://freeradius.org/"
|
||||
license=('GPL')
|
||||
depends=('krb5' 'net-snmp' 'postgresql-libs' 'mariadb-libs' 'talloc'
|
||||
'libpcap' 'libxcrypt' 'libcrypt.so' 'smbclient')
|
||||
makedepends=('curl' 'freetds' 'hiredis' 'json-c' 'libmemcached' 'perl'
|
||||
'python' 'samba' 'sqlite' 'unixodbc' 'yubico-c-client')
|
||||
optdepends=('curl: for REST'
|
||||
'freetds: for Sybase and MS SQL'
|
||||
'hiredis: for redis support'
|
||||
'json-c: rlm_rest module'
|
||||
'libmemcached: for memcached'
|
||||
'perl: for Perl'
|
||||
'python: for Python'
|
||||
'sqlite: for sqlite'
|
||||
'unixodbc: for ODBC'
|
||||
'yubico-c-client: for yubicloud')
|
||||
options=('!makeflags')
|
||||
validpgpkeys=('BF2384EC6938B9744B03E2A620E37C25995B4F85') # FreeRADIUS - Package Signing [...] <packages@freeradius.org>
|
||||
source=("ftp://ftp.freeradius.org/pub/radius/freeradius-server-$pkgver.tar.bz2"{,.sig}
|
||||
'python310.patch'
|
||||
'freeradius-sysusers.conf'
|
||||
'freeradius-tmpfiles.conf'
|
||||
'freeradius.service')
|
||||
sha256sums=('fc158cdab4a705b179b1a91cd72473006ef4dfb570b0d097db6c9c34049a4509'
|
||||
'SKIP'
|
||||
'58f415a4d05f2446d2514b98f5fd5d740d7bee400745d43a82d024a3d23ab253'
|
||||
'573c05df429405d8647f5b52f68f7ad13bf7392314d30154df770ab170d793f8'
|
||||
'f536a9aa972e3e42a6b1a6d8ee17166eb721c7cba2e80f60473811497c7bd8bc'
|
||||
'c469e1a3f9edad769da01c324779babe783ee85a9b53ce4638d3d2d09c7c8d4b')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir"/freeradius-server-$pkgver
|
||||
patch -Np1 -i ../python310.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/freeradius-server-$pkgver
|
||||
|
||||
[[ $CARCH == arm || $CARCH == armv6h ]] && LIBS="-latomic"
|
||||
LIBS=$LIBS ./configure \
|
||||
--prefix=/usr \
|
||||
--sbindir=/usr/bin \
|
||||
--sysconfdir=/etc \
|
||||
--libdir=/usr/lib/freeradius \
|
||||
--localstatedir=/var \
|
||||
--enable-heimdal-krb5 \
|
||||
--enable-reproducible-builds \
|
||||
--with-system-libltdl \
|
||||
--with-system-libtool \
|
||||
--with-udpfromto
|
||||
make PACKAGE='archlinux'
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir"/freeradius-server-$pkgver
|
||||
|
||||
make install R="$pkgdir" PACKAGE='archlinux'
|
||||
chmod o+r "$pkgdir"/etc/raddb/*
|
||||
mv "$pkgdir"/etc/raddb "$pkgdir"/etc/raddb.default
|
||||
rm -rf "$pkgdir"/var/run
|
||||
|
||||
install -D -m0644 "$srcdir"/$pkgname.service "$pkgdir"/usr/lib/systemd/system/$pkgname.service
|
||||
install -D -m0644 "$srcdir"/$pkgname-sysusers.conf "$pkgdir"/usr/lib/sysusers.d/$pkgname.conf
|
||||
install -D -m0644 "$srcdir"/$pkgname-tmpfiles.conf "$pkgdir"/usr/lib/tmpfiles.d/$pkgname.conf
|
||||
}
|
|
@ -1 +0,0 @@
|
|||
u radiusd - "radius daemon" /var/lib/radiusd
|
|
@ -1,8 +0,0 @@
|
|||
# configuration directory
|
||||
C /etc/raddb 0755 radiusd radiusd - /etc/raddb.default
|
||||
|
||||
# log file
|
||||
f /var/log/radius/radius.log 0644 radiusd radiusd -
|
||||
|
||||
# run directory
|
||||
d /run/radiusd 0755 radiusd radiusd -
|
|
@ -1,19 +0,0 @@
|
|||
[Unit]
|
||||
Description=FreeRADIUS high performance RADIUS server.
|
||||
After=syslog.target network.target
|
||||
Documentation=man:radiusd(8) man:radiusd.conf(5) https://wiki.freeradius.org/Home https://networkradius.com/freeradius-documentation/
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
PIDFile=/run/radiusd/radiusd.pid
|
||||
ExecStartPre=/usr/bin/radiusd -C
|
||||
ExecStart=/usr/bin/radiusd -d /etc/raddb
|
||||
ExecReload=/usr/bin/radiusd -C
|
||||
ExecReload=/bin/kill -HUP $MAINPID
|
||||
Restart=on-failure
|
||||
RestartSec=2
|
||||
ProtectSystem=full
|
||||
ProtectHome=on
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
|
@ -1,12 +0,0 @@
|
|||
diff -upr freeradius-server-3.0.25.orig/src/modules/rlm_python/configure freeradius-server-3.0.25/src/modules/rlm_python/configure
|
||||
--- freeradius-server-3.0.25.orig/src/modules/rlm_python/configure 2021-10-07 22:46:04.000000000 +0300
|
||||
+++ freeradius-server-3.0.25/src/modules/rlm_python/configure 2021-12-10 18:13:15.196401810 +0200
|
||||
@@ -2945,7 +2945,7 @@ $as_echo "$as_me: Python sys.prefix \"${
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"" >&5
|
||||
$as_echo "$as_me: Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"" >&6;}
|
||||
|
||||
- PY_SYS_VERSION=`${PYTHON_BIN} -c 'import sys ; print(sys.version[0:3])'`
|
||||
+ PY_SYS_VERSION=`${PYTHON_BIN} -c 'import sys ; print(".".join(map(str, sys.version_info[:2])))'`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.version \"${PY_SYS_VERSION}\"" >&5
|
||||
$as_echo "$as_me: Python sys.version \"${PY_SYS_VERSION}\"" >&6;}
|
||||
|
Loading…
Reference in a new issue