added extra/tightvnc 1.3.10-5

This commit is contained in:
Kevin Mihelich 2011-11-29 18:15:12 -05:00
parent 6214eaef54
commit 6aac8a8cb3
3 changed files with 72 additions and 0 deletions

48
extra/tightvnc/PKGBUILD Normal file
View file

@ -0,0 +1,48 @@
# $Id: PKGBUILD 64786 2010-01-22 07:44:39Z eric $
# Maintainer: Paul Mattal <paul@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to enable ARM building, contributed by vahokif
plugrel=1
pkgname=tightvnc
pkgver=1.3.10
pkgrel=5
pkgdesc="VNC Unix server && viewer"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.tightvnc.com"
depends=('libjpeg>=7' 'zlib' 'libxaw' 'libxp' 'xorg-xauth')
makedepends=('imake')
conflicts=('vnc')
options=(!makeflags)
source=(http://downloads.sf.net/sourceforge/vnc-tight/$pkgname-${pkgver}_unixsrc.tar.bz2
tightvnc-fontpath-xcolors.patch
tightvnc-1.3.10-arm.patch)
md5sums=('397b35faad32d5246b6d44b142f8304f'
'21aa7f3376ec3c608ff22d199a19c601'
'0c10d9cd275d90ba5f13ffe3109443a2')
build() {
cd $srcdir/vnc_unixsrc || return 1
patch -Np1 -i ../tightvnc-fontpath-xcolors.patch || return 1
patch -Np1 -i ../tightvnc-1.3.10-arm.patch
sed -i 's|/usr/local/|/usr/share/|' vncserver || return 1
xmkmf || return 1
make World || return 1
cd Xvnc || return 1
./configure || return 1
sed 's|PROTO_DEFINES =|PROTO_DEFINES = -D_XOPEN_SOURCE=500L|' \
-i programs/Xserver/os/Makefile lib/font/fc/Makefile || return 1
make || return 1
cd .. || return 1
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/man/man1 || return 1
./vncinstall $pkgdir/usr/bin $pkgdir/usr/share/man || return 1
# install java classes
mkdir -p $pkgdir/usr/share/vnc/classes || return 1
install -Dm644 $srcdir/vnc_unixsrc/classes/* \
$pkgdir/usr/share/vnc/classes || return 1
}

View file

@ -0,0 +1,11 @@
diff -ru vnc_unixsrc.orig//Xvnc/configure vnc_unixsrc/Xvnc/configure
--- vnc_unixsrc.orig//Xvnc/configure 2010-12-01 01:24:05.000000000 +0000
+++ vnc_unixsrc/Xvnc/configure 2010-12-01 01:20:19.000000000 +0000
@@ -39,6 +39,7 @@
echo "#define OSMinorVersion $MINOR" >> config/cf/platform.def
echo "#define OSTeenyVersion $TEENY" >> config/cf/platform.def
echo "#define LinuxCLibMajorVersion 6" >> config/cf/platform.def
+echo "#define ArmArchitecture 1" >> config/cf/platform.def
if [ "$SYSNAME" = AIX ]
then

View file

@ -0,0 +1,13 @@
diff -urN vnc_unixsrc/vncserver vnc_unixsrc.fixed/vncserver
--- vnc_unixsrc/vncserver 2009-02-11 23:27:18.000000000 -0500
+++ vnc_unixsrc.fixed/vncserver 2009-04-23 21:46:46.000000000 -0400
@@ -34,7 +34,8 @@
$desktopName = "X";
$vncClasses = "/usr/local/vnc/classes";
$vncUserDir = "$ENV{HOME}/.vnc";
-$fontPath = "unix/:7100";
+$fontPath = "/usr/share/fonts/misc/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/Type1/";
+$colorPath = "/usr/share/X11/rgb";
$authType = "-rfbauth $vncUserDir/passwd";
# Read configuration from the system-wide and user files if present.