Revert "core/linux-odroid to 3.8.13.27-2" - functionality already exists

This reverts commit 38f92073ba.
This commit is contained in:
Kevin Mihelich 2014-08-25 18:15:44 +00:00
parent 38f92073ba
commit 6ab571ac37
2 changed files with 1 additions and 31 deletions

View file

@ -1,26 +0,0 @@
From dd277c9a851cc4b5b6521cc2c6d79ce407488910 Mon Sep 17 00:00:00 2001
From: "S.J.R. van Schaik" <stephan@synkhronix.com>
Date: Thu, 19 Jun 2014 17:08:06 +0100
Subject: [PATCH] exynos DRM: have exynos_drm_fbdev_update() set smem_start and
smem_len.
---
drivers/gpu/drm/exynos/exynos_drm_fbdev.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/exynos/exynos_drm_fbdev.c b/drivers/gpu/drm/exynos/exynos_drm_fbdev.c
index 5a7cd8b..6b96fd4 100644
--- a/drivers/gpu/drm/exynos/exynos_drm_fbdev.c
+++ b/drivers/gpu/drm/exynos/exynos_drm_fbdev.c
@@ -125,6 +125,8 @@ static int exynos_drm_fbdev_update(struct drm_fb_helper *helper,
fbi->screen_base = buffer->kvaddr;
fbi->screen_size = size;
+ fbi->fix.smem_start = buffer->dma_addr;
+ fbi->fix.smem_len = size;
return 0;
}
--
1.8.5.5

View file

@ -8,7 +8,7 @@ pkgname=('linux-odroid-x' 'linux-odroid-x2' 'linux-odroid-u2' 'linux-headers-odr
_kernelname=${pkgname#linux}
_basekernel=3.8
pkgver=${_basekernel}.13.27
pkgrel=2
pkgrel=1
arch=('armv7h')
url="http://github.com/hardkernel/linux/"
license=('GPL2')
@ -16,12 +16,10 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'git' 'inetutils' 'bc')
options=('!strip')
_commit=414f3757fefdd17bd6d13dd3354c19fd43429632
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
'0001-exynos-drm-smem-start-len.patch'
'config_x'
'config_x2'
'config_u2')
md5sums=('d1093954d79b015ea9d1358b6b368674'
'dc8c3ffa65edd9ee30a1f9805d2b3460'
'af8d188bd1913729fc8424ff40288362'
'fc3ccaf2b892eafea45ffc124db052a8'
'9b62bc38316a719a5283039de4a94e07')
@ -34,8 +32,6 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
patch -p1 -F3 -i ../0001-exynos-drm-smem-start-len.patch
}
package_linux-odroid-x() {