mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/netpbm to 10.73.32-1
This commit is contained in:
parent
4cfdd874ee
commit
6ada993625
2 changed files with 4 additions and 28 deletions
|
@ -4,8 +4,8 @@
|
|||
# - add armv7h and aarch64 for -fPIC flag
|
||||
|
||||
pkgname=netpbm
|
||||
pkgver=10.73.31
|
||||
pkgrel=3
|
||||
pkgver=10.73.32
|
||||
pkgrel=1
|
||||
pkgdesc="A toolkit for manipulation of graphic images"
|
||||
arch=('x86_64')
|
||||
license=('custom' 'BSD' 'GPL' 'LGPL')
|
||||
|
@ -18,11 +18,11 @@ source=(https://downloads.sourceforge.net/project/netpbm/super_stable/$pkgver/ne
|
|||
https://sources.archlinux.org/other/packages/netpbm/netpbm-doc-31Jan2014.tar.xz{,.sig}
|
||||
netpbm-CAN-2005-2471.patch netpbm-security-code.patch netpbm-security-scripts.patch
|
||||
reproducible-man-gzip.patch use-source-date-epoch.patch)
|
||||
sha256sums=('584c95f1ccdcd66d5ca68d7d5501728ae1184cba324d713f6b2a3ca86424243b'
|
||||
sha256sums=('a79b86a9ff28bac4fa46688a6cb6e537be0129d23fc74ec71a941b0791679942'
|
||||
'74bcf840ee643c6917330c382484010cb99c004a3fcf05391bebcac63815acb3'
|
||||
'SKIP'
|
||||
'991aba7897e0710687369b4e2edfba1397ecd77d62578eac496afbc47b5ca970'
|
||||
'd39951cf96db6b3f430edef6fddcab5ef082db49968f09eb1c3e891205bcdb5f'
|
||||
'83d75a80ce999d8b69572e54f04c4d220c60b0d09f9e52d3236264535c3bf216'
|
||||
'2c397588d9cba2c40dee55c07713d5e77e0e04245db939fdc1962d7de4cf4a33'
|
||||
'8e3efdb4fcbfdc8e9a5c8e9663c7d6b9ecef3a2379ce38d2acc5669c339f6814'
|
||||
'68055341833f482c6910a56c2fdfe046978a1a92fd8442a2a9209c82ce3e4d13')
|
||||
|
|
|
@ -843,30 +843,6 @@ diff --git a/converter/ppm/ximtoppm.c b/converter/ppm/ximtoppm.c
|
|||
index ce5e639..a39b689 100644
|
||||
--- a/converter/ppm/ximtoppm.c
|
||||
+++ b/converter/ppm/ximtoppm.c
|
||||
@@ -117,6 +117,7 @@ ReadXimHeader(FILE * const in_fp,
|
||||
header->bits_channel = atoi(a_head.bits_per_channel);
|
||||
header->alpha_flag = atoi(a_head.alpha_channel);
|
||||
if (strlen(a_head.author)) {
|
||||
+ overflow_add(strlen(a_head.author),1);
|
||||
if (!(header->author = calloc((unsigned int)strlen(a_head.author)+1,
|
||||
1))) {
|
||||
pm_message("ReadXimHeader: can't calloc author string" );
|
||||
@@ -126,6 +127,7 @@ ReadXimHeader(FILE * const in_fp,
|
||||
strncpy(header->author, a_head.author, strlen(a_head.author));
|
||||
}
|
||||
if (strlen(a_head.date)) {
|
||||
+ overflow_add(strlen(a_head.date),1);
|
||||
if (!(header->date =calloc((unsigned int)strlen(a_head.date)+1,1))){
|
||||
pm_message("ReadXimHeader: can't calloc date string" );
|
||||
return(0);
|
||||
@@ -134,6 +136,7 @@ ReadXimHeader(FILE * const in_fp,
|
||||
strncpy(header->date, a_head.date, strlen(a_head.date));
|
||||
}
|
||||
if (strlen(a_head.program)) {
|
||||
+ overflow_add(strlen(a_head.program),1);
|
||||
if (!(header->program = calloc(
|
||||
(unsigned int)strlen(a_head.program) + 1, 1))) {
|
||||
pm_message("ReadXimHeader: can't calloc program string" );
|
||||
@@ -160,6 +163,7 @@ ReadXimHeader(FILE * const in_fp,
|
||||
if (header->nchannels == 3 && header->bits_channel == 8)
|
||||
header->ncolors = 0;
|
||||
|
|
Loading…
Reference in a new issue