mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-armv5 to 3.13.5-2
This commit is contained in:
parent
95838428b7
commit
6bb25ec4d1
2 changed files with 36 additions and 3 deletions
|
@ -8,7 +8,7 @@ _srcname=linux-3.13
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv5 based platforms"
|
||||
pkgver=3.13.5
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -18,12 +18,14 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
|||
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${_srcname#linux-}"
|
||||
'config'
|
||||
'imx23-olinuxino.patch')
|
||||
'imx23-olinuxino.patch'
|
||||
'gpio-clamp.patch')
|
||||
md5sums=('0ecbaf65c00374eb4a826c2f9f37606f'
|
||||
'114c391a592131f1c12544e063173a45'
|
||||
'SKIP'
|
||||
'd277d406b1c488d7b26c0cf150afceb4'
|
||||
'c3abaa939372af7a07ae5c2196263110')
|
||||
'c3abaa939372af7a07ae5c2196263110'
|
||||
'eb02814c2c46d5a8cf81361bbab9abbd')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -32,6 +34,7 @@ prepare() {
|
|||
patch -Np1 -i "${srcdir}/patch-${pkgver}"
|
||||
|
||||
patch -Np1 -i "${srcdir}/imx23-olinuxino.patch"
|
||||
patch -Np1 -i "${srcdir}/gpio-clamp.patch"
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||
|
|
30
core/linux-armv5/gpio-clamp.patch
Normal file
30
core/linux-armv5/gpio-clamp.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
From 25b35da7f4cce82271859f1b6eabd9f3bd41a2bb Mon Sep 17 00:00:00 2001
|
||||
From: Linus Walleij <linus.walleij@linaro.org>
|
||||
Date: Wed, 05 Feb 2014 13:08:02 +0000
|
||||
Subject: gpio: generic: clamp retured value to [0,1]
|
||||
|
||||
The generic GPIO would return 0 for low generic GPIO, and
|
||||
something != 0 for high GPIO. Let's make this sane by clamping
|
||||
the returned value to [0,1].
|
||||
|
||||
Reported-by: Evgeny Boger <boger@contactless.ru>
|
||||
Reviewed-by: Alexandre Courbot <acourbot@nvidia.com>
|
||||
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
|
||||
---
|
||||
(limited to 'drivers/gpio/gpio-generic.c')
|
||||
|
||||
diff --git a/drivers/gpio/gpio-generic.c b/drivers/gpio/gpio-generic.c
|
||||
index 8c778af..d815dd2 100644
|
||||
--- a/drivers/gpio/gpio-generic.c
|
||||
+++ b/drivers/gpio/gpio-generic.c
|
||||
@@ -139,7 +139,7 @@ static int bgpio_get(struct gpio_chip *gc, unsigned int gpio)
|
||||
{
|
||||
struct bgpio_chip *bgc = to_bgpio_chip(gc);
|
||||
|
||||
- return bgc->read_reg(bgc->reg_dat) & bgc->pin2mask(bgc, gpio);
|
||||
+ return !!(bgc->read_reg(bgc->reg_dat) & bgc->pin2mask(bgc, gpio));
|
||||
}
|
||||
|
||||
static void bgpio_set(struct gpio_chip *gc, unsigned int gpio, int val)
|
||||
--
|
||||
cgit v0.9.2
|
Loading…
Reference in a new issue