extra/webkitgtk to 2.0.2-3

This commit is contained in:
Kevin Mihelich 2013-06-07 18:32:13 +00:00
parent 89dbd289dc
commit 6bdcb25310
2 changed files with 61 additions and 24 deletions

View file

@ -1,42 +1,49 @@
# $Id: PKGBUILD 183326 2013-04-21 22:06:45Z heftig $
# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - re-enabled --disable-silent-rules, needed for v5 and v6 to build
pkgbase=webkitgtk
pkgname=('webkitgtk3')
pkgname=webkitgtk
pkgver=2.0.2
pkgrel=1
arch=('i686' 'x86_64')
pkgrel=3
pkgdesc="GTK+ Web content engine library"
arch=(i686 x86_64)
url="http://webkitgtk.org/"
license=('custom')
makedepends=('libxt' 'libxslt' 'sqlite' 'libsoup' 'enchant' 'libgl' 'geoclue' 'gtk2' 'gtk3' 'gst-plugins-base-libs' 'gperf' 'gobject-introspection' 'python' 'mesa' 'ruby' 'gtk-doc' 'libsecret' 'libwebp')
options=('!libtool' '!emptydirs')
source=(http://webkitgtk.org/releases/$pkgbase-$pkgver.tar.xz)
sha256sums=('c3685032545eb4c23f3f56826817783a6963ad59bd7bbf806705059b3d8caeb2')
license=(custom)
depends=(libxt libxslt sqlite libsoup enchant libgl geoclue gtk3 gst-plugins-base-libs libsecret libwebp
harfbuzz-icu)
makedepends=(gtk2 gperf gobject-introspection python mesa ruby gtk-doc)
optdepends=('gtk2: Webkit2 plugin support')
conflicts=(webkitgtk3 libwebkit3)
provides=("webkitgtk3=${pkgver}" "libwebkit3=${pkgver}")
replaces=(webkitgtk3 libwebkit3)
options=(!libtool !emptydirs)
source=(http://webkitgtk.org/releases/$pkgname-${pkgver}.tar.xz
changeset_150963.diff)
sha256sums=('c3685032545eb4c23f3f56826817783a6963ad59bd7bbf806705059b3d8caeb2'
'8d2542600cba876b714cdf6be478d847b6672bff2856e6e6d0582b1566fe5764')
prepare() {
cd $pkgbase-$pkgver
mkdir build-gtk3
cd $pkgname-$pkgver
patch -Np2 -i ../changeset_150963.diff
autoreconf -fi -I Source/autotools
}
build() {
cd $pkgbase-$pkgver/build-gtk3
cd $pkgname-$pkgver
./configure --prefix=/usr \
--libexecdir=/usr/lib/$pkgname \
--enable-introspection --disable-silent-rules
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
../configure --prefix=/usr --libexecdir=/usr/lib/webkitgtk3 --enable-introspection --disable-silent-rules
make all stamp-po
}
package_webkitgtk3() {
pkgdesc="GTK+ Web content engine library for GTK+ 3.0"
depends=('libxt' 'libxslt' 'sqlite' 'libsoup' 'enchant' 'libgl' 'geoclue' 'gtk3' 'gst-plugins-base-libs' 'libsecret' 'libwebp')
conflicts=('libwebkit3')
provides=("libwebkit3=${pkgver}")
replaces=('libwebkit3')
optdepends=('gtk2: Webkit2 plugin support')
cd $pkgbase-$pkgver/build-gtk3
package() {
cd $pkgname-$pkgver
make -j1 DESTDIR="$pkgdir" install
install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

View file

@ -0,0 +1,30 @@
2013-05-30 Alberto Garcia <agarcia@igalia.com>
[GTK] Needs to check for harfbuzz-icu
https://bugs.webkit.org/show_bug.cgi?id=116978
Reviewed by Xan Lopez.
HarfBuzz 0.9.18 splits harbuzz-icu into a separate library so we
also need to check for it in order to get the necessary flags for
the compiler and the linker.
We keep this conditional for now since we still want to support
earlier versions of HarfBuzz.
Index: /trunk/Source/autotools/FindDependencies.m4
===================================================================
--- /trunk/Source/autotools/FindDependencies.m4 (revision 150962)
+++ /trunk/Source/autotools/FindDependencies.m4 (revision 150963)
@@ -376,4 +376,11 @@
[cairo-ft fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz >= harfbuzz_required_version])
fi
+# HarfBuzz 0.9.18 splits harbuzz-icu into a separate library.
+# Since we support earlier HarfBuzz versions we keep this conditional for now.
+if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ PKG_CHECK_MODULES(HARFBUZZ_ICU, harfbuzz-icu >= $harfbuzz_required_version)
+ FREETYPE_CFLAGS+=" $HARFBUZZ_ICU_CFLAGS"
+ FREETYPE_LIBS+=" $HARFBUZZ_ICU_LIBS"
+fi
AC_SUBST([FREETYPE_CFLAGS])
AC_SUBST([FREETYPE_LIBS])