mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/libinput to 1.7.2-1
This commit is contained in:
parent
872de550ec
commit
6c5af2dbb9
6 changed files with 35 additions and 293 deletions
|
@ -1,248 +0,0 @@
|
|||
From c48c84a47ae45db3591d99237b72f9ac3b84de48 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Thu, 20 Apr 2017 14:59:23 +1000
|
||||
Subject: [PATCH 1/5] touchpad: move the pressure range to a hwdb entry
|
||||
|
||||
Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
|
||||
---
|
||||
src/evdev-mt-touchpad.c | 44 +++++++++++++++++++++++++++-----------
|
||||
src/libinput-util.c | 36 +++++++++++++++++++++++++++++++
|
||||
src/libinput-util.h | 1 +
|
||||
test/test-misc.c | 43 +++++++++++++++++++++++++++++++++++++
|
||||
udev/90-libinput-model-quirks.hwdb | 2 ++
|
||||
udev/parse_hwdb.py | 8 ++++++-
|
||||
6 files changed, 121 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/src/evdev-mt-touchpad.c b/src/evdev-mt-touchpad.c
|
||||
index 4a8b618..184d37d 100644
|
||||
--- a/src/evdev-mt-touchpad.c
|
||||
+++ b/src/evdev-mt-touchpad.c
|
||||
@@ -2364,8 +2364,9 @@ tp_init_pressure(struct tp_dispatch *tp,
|
||||
struct evdev_device *device)
|
||||
{
|
||||
const struct input_absinfo *abs;
|
||||
- unsigned int range;
|
||||
unsigned int code = ABS_PRESSURE;
|
||||
+ const char *prop;
|
||||
+ int hi, lo;
|
||||
|
||||
if (tp->has_mt)
|
||||
code = ABS_MT_PRESSURE;
|
||||
@@ -2375,25 +2376,44 @@ tp_init_pressure(struct tp_dispatch *tp,
|
||||
return;
|
||||
}
|
||||
|
||||
- tp->pressure.use_pressure = true;
|
||||
-
|
||||
abs = libevdev_get_abs_info(device->evdev, code);
|
||||
assert(abs);
|
||||
|
||||
- range = abs->maximum - abs->minimum;
|
||||
+ prop = udev_device_get_property_value(device->udev_device,
|
||||
+ "LIBINPUT_ATTR_PRESSURE_RANGE");
|
||||
+ if (prop) {
|
||||
+ if (!parse_pressure_range_property(prop, &hi, &lo)) {
|
||||
+ evdev_log_bug_client(device,
|
||||
+ "discarding invalid pressure range '%s'\n",
|
||||
+ prop);
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
- if (device->model_flags & EVDEV_MODEL_ELANTECH_TOUCHPAD) {
|
||||
- tp->pressure.high = 24;
|
||||
- tp->pressure.low = 10;
|
||||
- } else if (device->model_flags & EVDEV_MODEL_CYAPA) {
|
||||
- tp->pressure.high = 10;
|
||||
- tp->pressure.low = 8;
|
||||
+ if (hi == 0 && lo == 0) {
|
||||
+ evdev_log_info(device,
|
||||
+ "pressure-based touch detection disabled\n");
|
||||
+ return;
|
||||
+ }
|
||||
} else {
|
||||
+ unsigned int range = abs->maximum - abs->minimum;
|
||||
+
|
||||
/* Approximately the synaptics defaults */
|
||||
- tp->pressure.high = abs->minimum + 0.12 * range;
|
||||
- tp->pressure.low = abs->minimum + 0.10 * range;
|
||||
+ hi = abs->minimum + 0.12 * range;
|
||||
+ lo = abs->minimum + 0.10 * range;
|
||||
+ }
|
||||
+
|
||||
+ if (hi > abs->maximum || hi < abs->minimum ||
|
||||
+ lo > abs->maximum || lo < abs->minimum) {
|
||||
+ evdev_log_bug_libinput(device,
|
||||
+ "discarding out-of-bounds pressure range %d:%d\n",
|
||||
+ hi, lo);
|
||||
+ return;
|
||||
}
|
||||
|
||||
+ tp->pressure.use_pressure = true;
|
||||
+ tp->pressure.high = hi;
|
||||
+ tp->pressure.low = lo;
|
||||
+
|
||||
evdev_log_debug(device,
|
||||
"using pressure-based touch detection\n");
|
||||
}
|
||||
diff --git a/src/libinput-util.c b/src/libinput-util.c
|
||||
index 351bbe4..38594fa 100644
|
||||
--- a/src/libinput-util.c
|
||||
+++ b/src/libinput-util.c
|
||||
@@ -360,6 +360,42 @@ parse_tpkbcombo_layout_poperty(const char *prop,
|
||||
}
|
||||
|
||||
/**
|
||||
+ * Parses a string of the format "a:b" where both a and b must be integer
|
||||
+ * numbers and a > b. Also allowed is the special string vaule "none" which
|
||||
+ * amounts to unsetting the property.
|
||||
+ *
|
||||
+ * @param prop The value of the property
|
||||
+ * @param hi Set to the first digit or 0 in case of 'none'
|
||||
+ * @param lo Set to the second digit or 0 in case of 'none'
|
||||
+ * @return true on success, false otherwise
|
||||
+ */
|
||||
+bool
|
||||
+parse_pressure_range_property(const char *prop, int *hi, int *lo)
|
||||
+{
|
||||
+ int first, second;
|
||||
+
|
||||
+ if (!prop)
|
||||
+ return false;
|
||||
+
|
||||
+ if (streq(prop, "none")) {
|
||||
+ *hi = 0;
|
||||
+ *lo = 0;
|
||||
+ return true;
|
||||
+ }
|
||||
+
|
||||
+ if (sscanf(prop, "%d:%d", &first, &second) != 2)
|
||||
+ return false;
|
||||
+
|
||||
+ if (second >= first)
|
||||
+ return false;
|
||||
+
|
||||
+ *hi = first;
|
||||
+ *lo = second;
|
||||
+
|
||||
+ return true;
|
||||
+}
|
||||
+
|
||||
+/**
|
||||
* Return the next word in a string pointed to by state before the first
|
||||
* separator character. Call repeatedly to tokenize a whole string.
|
||||
*
|
||||
diff --git a/src/libinput-util.h b/src/libinput-util.h
|
||||
index d86ff12..66fd336 100644
|
||||
--- a/src/libinput-util.h
|
||||
+++ b/src/libinput-util.h
|
||||
@@ -378,6 +378,7 @@ int parse_mouse_wheel_click_count_property(const char *prop);
|
||||
double parse_trackpoint_accel_property(const char *prop);
|
||||
bool parse_dimension_property(const char *prop, size_t *width, size_t *height);
|
||||
bool parse_calibration_property(const char *prop, float calibration[6]);
|
||||
+bool parse_pressure_range_property(const char *prop, int *hi, int *lo);
|
||||
|
||||
enum tpkbcombo_layout {
|
||||
TPKBCOMBO_LAYOUT_UNKNOWN,
|
||||
diff --git a/test/test-misc.c b/test/test-misc.c
|
||||
index 3f4b229..5101dcf 100644
|
||||
--- a/test/test-misc.c
|
||||
+++ b/test/test-misc.c
|
||||
@@ -1001,6 +1001,48 @@ START_TEST(calibration_prop_parser)
|
||||
}
|
||||
END_TEST
|
||||
|
||||
+struct parser_test_pressure_range {
|
||||
+ char *tag;
|
||||
+ bool success;
|
||||
+ int hi, lo;
|
||||
+};
|
||||
+
|
||||
+START_TEST(pressure_range_prop_parser)
|
||||
+{
|
||||
+ struct parser_test_pressure_range tests[] = {
|
||||
+ { "10:8", true, 10, 8 },
|
||||
+ { "100:-1", true, 100, -1 },
|
||||
+ { "-203813:-502023", true, -203813, -502023 },
|
||||
+ { "238492:28210", true, 238492, 28210 },
|
||||
+ { "none", true, 0, 0 },
|
||||
+ { "0:0", false, 0, 0 },
|
||||
+ { "", false, 0, 0 },
|
||||
+ { "abcd", false, 0, 0 },
|
||||
+ { "10:30:10", false, 0, 0 },
|
||||
+ { NULL, false, 0, 0 }
|
||||
+ };
|
||||
+ int i;
|
||||
+ int hi, lo;
|
||||
+ bool success;
|
||||
+
|
||||
+ for (i = 0; tests[i].tag != NULL; i++) {
|
||||
+ hi = lo = 0xad;
|
||||
+ success = parse_pressure_range_property(tests[i].tag, &hi, &lo);
|
||||
+ ck_assert(success == tests[i].success);
|
||||
+ if (success) {
|
||||
+ ck_assert_int_eq(hi, tests[i].hi);
|
||||
+ ck_assert_int_eq(lo, tests[i].lo);
|
||||
+ } else {
|
||||
+ ck_assert_int_eq(hi, 0xad);
|
||||
+ ck_assert_int_eq(lo, 0xad);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ success = parse_pressure_range_property(NULL, NULL, NULL);
|
||||
+ ck_assert(success == false);
|
||||
+}
|
||||
+END_TEST
|
||||
+
|
||||
START_TEST(time_conversion)
|
||||
{
|
||||
ck_assert_int_eq(us(10), 10);
|
||||
@@ -1275,6 +1317,7 @@ litest_setup_tests_misc(void)
|
||||
litest_add_no_device("misc:parser", dimension_prop_parser);
|
||||
litest_add_no_device("misc:parser", reliability_prop_parser);
|
||||
litest_add_no_device("misc:parser", calibration_prop_parser);
|
||||
+ litest_add_no_device("misc:parser", pressure_range_prop_parser);
|
||||
litest_add_no_device("misc:parser", safe_atoi_test);
|
||||
litest_add_no_device("misc:parser", safe_atod_test);
|
||||
litest_add_no_device("misc:parser", strsplit_test);
|
||||
diff --git a/udev/90-libinput-model-quirks.hwdb b/udev/90-libinput-model-quirks.hwdb
|
||||
index 2ff50b6..4b9b7f2 100644
|
||||
--- a/udev/90-libinput-model-quirks.hwdb
|
||||
+++ b/udev/90-libinput-model-quirks.hwdb
|
||||
@@ -85,6 +85,7 @@ libinput:name:* Touchpad:dmi:*svnDellInc.:*
|
||||
##########################################
|
||||
libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*
|
||||
LIBINPUT_ATTR_RESOLUTION_HINT=31x31
|
||||
+ LIBINPUT_ATTR_PRESSURE_RANGE=24:8
|
||||
LIBINPUT_MODEL_ELANTECH_TOUCHPAD=1
|
||||
|
||||
##########################################
|
||||
@@ -111,6 +112,7 @@ libinput:name:Atmel maXTouch Touchpad:dmi:*svn*GOOGLE*:pn*Samus*
|
||||
|
||||
libinput:name:Cypress APA Trackpad ?cyapa?:dmi:*
|
||||
LIBINPUT_MODEL_CYAPA=1
|
||||
+ LIBINPUT_ATTR_PRESSURE_RANGE=10:8
|
||||
|
||||
##########################################
|
||||
# HP
|
||||
diff --git a/udev/parse_hwdb.py b/udev/parse_hwdb.py
|
||||
index 2a342bf..97f04f4 100755
|
||||
--- a/udev/parse_hwdb.py
|
||||
+++ b/udev/parse_hwdb.py
|
||||
@@ -112,7 +112,13 @@ def property_grammar():
|
||||
Suppress('=') -
|
||||
tpkbcombo_tags('VALUE')]
|
||||
|
||||
- grammar = Or(model_props + size_props + reliability + tpkbcombo)
|
||||
+ pressure_range = INTEGER('X') + Suppress(':') + INTEGER('Y')
|
||||
+ pressure_prop = [ Literal('LIBINPUT_ATTR_PRESSURE_RANGE')('NAME') -
|
||||
+ Suppress('=') -
|
||||
+ Group(pressure_range('SETTINGS*')) ]
|
||||
+
|
||||
+ grammar = Or(model_props + size_props + reliability + tpkbcombo +
|
||||
+ pressure_prop)
|
||||
|
||||
return grammar
|
||||
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From a96753126be75ef8aee5035ad5be2df36e617877 Mon Sep 17 00:00:00 2001
|
||||
From b29b47c0c89d33306227556f7fe3aee620e0e47c Mon Sep 17 00:00:00 2001
|
||||
From: Paul Kocialkowski <contact@paulk.fr>
|
||||
Date: Fri, 21 Apr 2017 13:31:56 +0200
|
||||
Subject: [PATCH 2/5] udev: Add name-based input device detection without dmi
|
||||
Subject: [PATCH 1/4] udev: Add name-based input device detection without dmi
|
||||
|
||||
Some devices do not use dmi at all (this is the case on most non-x86
|
||||
platforms, such as arm and arm64) but should able to select specific
|
|
@ -1,7 +1,7 @@
|
|||
From 7137ea7c201c1f3d7f7c2feb749f5c311ee6ea6c Mon Sep 17 00:00:00 2001
|
||||
From bf5b10b31d23682d1fc1333e9094e902dcc7150a Mon Sep 17 00:00:00 2001
|
||||
From: Paul Kocialkowski <contact@paulk.fr>
|
||||
Date: Fri, 21 Apr 2017 13:31:57 +0200
|
||||
Subject: [PATCH 3/5] udev: Add support for I2C Elan touchpads (without dmi)
|
||||
Subject: [PATCH 2/4] udev: Add support for I2C Elan touchpads (without dmi)
|
||||
|
||||
This adds support for I2C Elan touchpads, such as the ones found in
|
||||
various ARM CrOS devices. These devices do not use dmi.
|
||||
|
@ -11,19 +11,18 @@ touchpads entry. It is not adapted to every touchpad configuration.
|
|||
|
||||
Signed-off-by: Paul Kocialkowski <contact at paulk.fr>
|
||||
---
|
||||
udev/90-libinput-model-quirks.hwdb | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
udev/90-libinput-model-quirks.hwdb | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/udev/90-libinput-model-quirks.hwdb b/udev/90-libinput-model-quirks.hwdb
|
||||
index 4b9b7f2..77d0a67 100644
|
||||
index 560e77a..8cf3304 100644
|
||||
--- a/udev/90-libinput-model-quirks.hwdb
|
||||
+++ b/udev/90-libinput-model-quirks.hwdb
|
||||
@@ -88,6 +88,10 @@ libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*
|
||||
LIBINPUT_ATTR_PRESSURE_RANGE=24:8
|
||||
LIBINPUT_MODEL_ELANTECH_TOUCHPAD=1
|
||||
@@ -90,6 +90,9 @@ libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*
|
||||
libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*svnASUSTeKComputerInc.:pnUX21E:*
|
||||
LIBINPUT_ATTR_PRESSURE_RANGE=24:10
|
||||
|
||||
+libinput:name:*Elan Touchpad*
|
||||
+ LIBINPUT_MODEL_ELANTECH_TOUCHPAD=1
|
||||
+ LIBINPUT_ATTR_PRESSURE_RANGE=24:8
|
||||
+
|
||||
##########################################
|
|
@ -1,7 +1,7 @@
|
|||
From 424058c86ef56a80fc9723e0afd1695681a145b8 Mon Sep 17 00:00:00 2001
|
||||
From 43cba4ba6cdad42faa878008036a75a5049c95d6 Mon Sep 17 00:00:00 2001
|
||||
From: Paul Kocialkowski <contact@paulk.fr>
|
||||
Date: Fri, 21 Apr 2017 13:31:58 +0200
|
||||
Subject: [PATCH 4/5] udev: Decrease high pressure value for Elantech touchpads
|
||||
Subject: [PATCH 3/4] udev: Decrease high pressure value for Elantech touchpads
|
||||
|
||||
The high pressure value for Elantech touchpads (both PS/2 and I2C) is
|
||||
not adapted to various devices, on which the touchpad is barely usable.
|
||||
|
@ -11,23 +11,17 @@ introducing any major drawback for other devices.
|
|||
|
||||
Signed-off-by: Paul Kocialkowski <contact at paulk.fr>
|
||||
---
|
||||
udev/90-libinput-model-quirks.hwdb | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
udev/90-libinput-model-quirks.hwdb | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/udev/90-libinput-model-quirks.hwdb b/udev/90-libinput-model-quirks.hwdb
|
||||
index 77d0a67..a873546 100644
|
||||
index 8cf3304..d9f0022 100644
|
||||
--- a/udev/90-libinput-model-quirks.hwdb
|
||||
+++ b/udev/90-libinput-model-quirks.hwdb
|
||||
@@ -85,12 +85,12 @@ libinput:name:* Touchpad:dmi:*svnDellInc.:*
|
||||
##########################################
|
||||
libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*
|
||||
LIBINPUT_ATTR_RESOLUTION_HINT=31x31
|
||||
- LIBINPUT_ATTR_PRESSURE_RANGE=24:8
|
||||
+ LIBINPUT_ATTR_PRESSURE_RANGE=10:8
|
||||
LIBINPUT_MODEL_ELANTECH_TOUCHPAD=1
|
||||
@@ -91,7 +91,7 @@ libinput:name:*ETPS/2 Elantech Touchpad*:dmi:*svnASUSTeKComputerInc.:pnUX21E:*
|
||||
LIBINPUT_ATTR_PRESSURE_RANGE=24:10
|
||||
|
||||
libinput:name:*Elan Touchpad*
|
||||
LIBINPUT_MODEL_ELANTECH_TOUCHPAD=1
|
||||
- LIBINPUT_ATTR_PRESSURE_RANGE=24:8
|
||||
+ LIBINPUT_ATTR_PRESSURE_RANGE=10:8
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 5811dd08f263a88613807ac3261f31c0a11ae507 Mon Sep 17 00:00:00 2001
|
||||
From 3d319e3a09dbd366d2721844cf6fb5d91adc76c0 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Apr 2017 16:56:55 -0600
|
||||
Subject: [PATCH 5/5] Don't pair touchpad and lid switch
|
||||
Subject: [PATCH 4/4] Don't pair touchpad and lid switch
|
||||
|
||||
Kills Xorg immediately upon any touchpad or keyboard entry on the Samsung Chromebook Plus.
|
||||
|
||||
|
@ -11,10 +11,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/evdev-mt-touchpad.c b/src/evdev-mt-touchpad.c
|
||||
index 184d37d..bb034c5 100644
|
||||
index a35688b..2243682 100644
|
||||
--- a/src/evdev-mt-touchpad.c
|
||||
+++ b/src/evdev-mt-touchpad.c
|
||||
@@ -1635,7 +1635,7 @@ tp_interface_device_added(struct evdev_device *device,
|
||||
@@ -1638,7 +1638,7 @@ tp_interface_device_added(struct evdev_device *device,
|
||||
|
||||
tp_pair_trackpoint(device, added_device);
|
||||
tp_dwt_pair_keyboard(device, added_device);
|
|
@ -7,7 +7,7 @@
|
|||
# - patch to not crash Xorg on the Chromebook Plus
|
||||
|
||||
pkgname=libinput
|
||||
pkgver=1.7.1
|
||||
pkgver=1.7.2
|
||||
pkgrel=1
|
||||
pkgdesc="Input device management and event handling library"
|
||||
arch=(i686 x86_64)
|
||||
|
@ -18,27 +18,24 @@ depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
|
|||
makedepends=('doxygen' 'graphviz' 'gtk3')
|
||||
#checkdepends=('check' 'libunwind')
|
||||
source=(https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
0001-touchpad-move-the-pressure-range-to-a-hwdb-entry.patch
|
||||
0002-udev-Add-name-based-input-device-detection-without-d.patch
|
||||
0003-udev-Add-support-for-I2C-Elan-touchpads-without-dmi.patch
|
||||
0004-udev-Decrease-high-pressure-value-for-Elantech-touch.patch
|
||||
0005-Don-t-pair-touchpad-and-lid-switch.patch)
|
||||
sha512sums=('ee477fbbe2042ffeff70a960caf97e914d28c916af495765071a0184f442fa503d461bc34b87dc3dd62ef1bfd3e921ddc6fc065f8089d16d81c037d53d677352'
|
||||
0001-udev-Add-name-based-input-device-detection-without-d.patch
|
||||
0002-udev-Add-support-for-I2C-Elan-touchpads-without-dmi.patch
|
||||
0003-udev-Decrease-high-pressure-value-for-Elantech-touch.patch
|
||||
0004-Don-t-pair-touchpad-and-lid-switch.patch)
|
||||
sha512sums=('cdbd2994e954aac9538fe907c275e6e23e2bed0e9c4c65f19591bdcdbf5074131c72b92e87de87c03f75a991fcdb7f568b491a12f00031c4eba11082ca44d69f'
|
||||
'SKIP'
|
||||
'12649bc2b1103bed2c2050bea43661fd4363745d997a2e07ef44c096279532aa95fbf8108ac4330e481c16d6732cbc26b00333d0e62d5e93cf6be4d8d0ac04d6'
|
||||
'f6bd66dbb7421c09ef0f58d911d6432693db901715c8e24f4faddffd03a3b3d0929c9f88e5413821da2e7efe73e8b9f391b39472fbedeb09aec416ea466a25c5'
|
||||
'dd96f2699948b055ad4491d24e98c7f62ada678a5cebc360e0242cf20383528c33d3879d0b34c20c446ccac2c3cb7daab9355aff2d12cdc674623736aa8f710c'
|
||||
'c7dcdae77e195409dae4a3a01bec4e5b6cc997fa80644d09538cfa3700977f4c2562338b45725a7ac0ef115b0b04a184de16c9105a2e11b10033d0ea86c59533'
|
||||
'29b20078c1b8b4f8f33de3c39529351d2e37d37f3f7cb10f4aef6f05e120285c2b987d2ec94ea5875bc0cc101c6d9b02353b09b8e4927c396584fc8f5fe1846f')
|
||||
'3c696a723fd1cc32fd851cb8daea47c629d7245c9190e3086813f81ad54197e2e95fc79df4e6ebb956fed539b362a058d4cfb53f364a1ecaba1cbd5cac7a4cab'
|
||||
'14a9081f6ca2741d43142251bf38fbd9af445d671472a137e97ccd3827bf01feb076b95c459bcd7947757d919254913fc8c8496976ee5f6f4a4ed5713f7b6f8c'
|
||||
'f75895141ef2f78c7ccecbc4b08437c1c4e27078ed7bc52751d3f0b3693ca2820c85aacb4435d4fe950d43ea940e90896c55423a80698762d20b740a64f12884'
|
||||
'db8d684d3370e860764b52cc4f2287630cf58dad337684a7ae485957b8cec54cd2da47e27b5c8eefa42f753d366a4cda3d957cf0514087b3013ac7562fa785f3')
|
||||
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../0001-touchpad-move-the-pressure-range-to-a-hwdb-entry.patch
|
||||
patch -p1 -i ../0002-udev-Add-name-based-input-device-detection-without-d.patch
|
||||
patch -p1 -i ../0003-udev-Add-support-for-I2C-Elan-touchpads-without-dmi.patch
|
||||
patch -p1 -i ../0004-udev-Decrease-high-pressure-value-for-Elantech-touch.patch
|
||||
patch -p1 -i ../0005-Don-t-pair-touchpad-and-lid-switch.patch
|
||||
patch -p1 -i ../0001-udev-Add-name-based-input-device-detection-without-d.patch
|
||||
patch -p1 -i ../0002-udev-Add-support-for-I2C-Elan-touchpads-without-dmi.patch
|
||||
patch -p1 -i ../0003-udev-Decrease-high-pressure-value-for-Elantech-touch.patch
|
||||
patch -p1 -i ../0004-Don-t-pair-touchpad-and-lid-switch.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue