mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/js52 to 52.7.3-2
This commit is contained in:
parent
010e8b94b6
commit
6c93aa7380
2 changed files with 17 additions and 17 deletions
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgname=js52
|
||||
pkgver=52.7.3
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_ffver=${pkgver%%.*}
|
||||
pkgdesc="JavaScript interpreter and libraries - Version $_ffver"
|
||||
arch=(x86_64)
|
||||
|
@ -25,7 +25,7 @@ source=("https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_${pkgver//./_}es
|
|||
sha256sums=('abe0022c74a666d13db1d96508c1b639d91b09ae0883ffe0c5626caa80c39b17'
|
||||
'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc'
|
||||
'5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8'
|
||||
'06389b8e30465bb8e6fab6144dadedffa30595f143a686524da175b5cf5e8a27'
|
||||
'728456fd9e66b69d6e0688c75e50091dc56735004ecf5f649212a83fe3087df1'
|
||||
'd91a89acd88bfc747a255050757a0c17139bf5c3508c2e1c3c6bb2056786a344')
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -1,18 +1,6 @@
|
|||
From: Laszlo Boszormenyi (GCS) <gcs@debian.org>
|
||||
Date: Fri, 02 May 2014 22:20:45 +0200
|
||||
Subject: fix soname
|
||||
|
||||
Add soname switch to linker, regardless of Operating System
|
||||
|
||||
Bug-Debian: http://bugs.debian.org/746705
|
||||
---
|
||||
config/rules.mk | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
Index: mozjs52-52.2.1~artful1/config/rules.mk
|
||||
===================================================================
|
||||
--- mozjs52-52.2.1~artful1.orig/config/rules.mk
|
||||
+++ mozjs52-52.2.1~artful1/config/rules.mk
|
||||
diff --git a/config/rules.mk b/config/rules.mk
|
||||
--- a/config/rules.mk
|
||||
+++ b/config/rules.mk
|
||||
@@ -418,7 +418,7 @@ endif # AIX
|
||||
#
|
||||
# Linux: add -Bsymbolic flag for components
|
||||
|
@ -32,3 +20,15 @@ Index: mozjs52-52.2.1~artful1/config/rules.mk
|
|||
|
||||
ifdef SYMBOLS_FILE
|
||||
ifeq ($(OS_TARGET),WINNT)
|
||||
diff --git a/js/src/Makefile.in b/js/src/Makefile.in
|
||||
--- a/js/src/Makefile.in
|
||||
+++ b/js/src/Makefile.in
|
||||
@@ -222,6 +222,8 @@ ifneq (,$(REAL_LIBRARY))
|
||||
endif
|
||||
ifneq (,$(SHARED_LIBRARY))
|
||||
$(SYSINSTALL) $(SHARED_LIBRARY) $(DESTDIR)$(libdir)
|
||||
+ mv -f $(DESTDIR)$(libdir)/$(SHARED_LIBRARY) $(DESTDIR)$(libdir)/$(SHARED_LIBRARY).0
|
||||
+ ln -s $(SHARED_LIBRARY).0 $(DESTDIR)$(libdir)/$(SHARED_LIBRARY)
|
||||
ifeq ($(OS_ARCH),Darwin)
|
||||
install_name_tool -id $(abspath $(libdir)/$(SHARED_LIBRARY)) $(DESTDIR)$(libdir)/$(SHARED_LIBRARY)
|
||||
endif
|
||||
|
|
Loading…
Reference in a new issue