mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-29 00:25:25 +00:00
extra/pulseaudio to 15.0-1
This commit is contained in:
parent
1dd0e116fe
commit
6d3bc90b73
2 changed files with 28 additions and 20 deletions
extra/pulseaudio
|
@ -1,4 +1,4 @@
|
|||
From bc4cdcd76159b3b2fadd3274322433a9b9e72966 Mon Sep 17 00:00:00 2001
|
||||
From 5e83594fa0f7e18747030684f4de512052f2df56 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 12 Sep 2019 05:44:39 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
@ -8,17 +8,17 @@ Subject: [PATCH] disable neon
|
|||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/src/pulsecore/meson.build b/src/pulsecore/meson.build
|
||||
index 5f78be012..4955e859e 100644
|
||||
index d7f9ef2cf..933d1de0e 100644
|
||||
--- a/src/pulsecore/meson.build
|
||||
+++ b/src/pulsecore/meson.build
|
||||
@@ -174,7 +174,6 @@ simd = import('unstable-simd')
|
||||
libpulsecore_simd = simd.check('libpulsecore_simd',
|
||||
mmx : ['remap_mmx.c', 'svolume_mmx.c'],
|
||||
sse : ['remap_sse.c', 'sconv_sse.c', 'svolume_sse.c'],
|
||||
- neon : ['remap_neon.c', 'sconv_neon.c', 'mix_neon.c'],
|
||||
c_args : [pa_c_args],
|
||||
include_directories : [configinc, topinc],
|
||||
implicit_include_directories : false,
|
||||
@@ -175,7 +175,6 @@ simd = import('unstable-simd')
|
||||
simd_variants = [
|
||||
{ 'mmx' : ['remap_mmx.c', 'svolume_mmx.c'] },
|
||||
{ 'sse' : ['remap_sse.c', 'sconv_sse.c', 'svolume_sse.c'] },
|
||||
- { 'neon' : ['remap_neon.c', 'sconv_neon.c', 'mix_neon.c'] },
|
||||
]
|
||||
|
||||
libpulsecore_simd_lib = []
|
||||
--
|
||||
2.28.0
|
||||
2.30.0
|
||||
|
||||
|
|
|
@ -2,24 +2,25 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to remove meson NEON check
|
||||
# - remove makedepend on valgrind, meson with -D valgrind=disabled
|
||||
|
||||
pkgbase=pulseaudio
|
||||
pkgname=(pulseaudio libpulse pulseaudio-{zeroconf,lirc,jack,bluetooth,equalizer,rtp})
|
||||
pkgdesc="A featureful, general-purpose sound server"
|
||||
pkgver=14.2
|
||||
pkgrel=3
|
||||
pkgver=15.0
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
|
||||
license=(GPL)
|
||||
makedepends=(libasyncns libcap attr libxtst libsm libsndfile rtkit libsoxr
|
||||
speexdsp tdb systemd dbus avahi bluez bluez-libs jack2 sbc
|
||||
lirc openssl fftw orc gtk3 webrtc-audio-processing check git meson
|
||||
xmltoman)
|
||||
_commit=6a487c5244563f49a025088de3510c80824fc99e # tags/v14.2^0
|
||||
xmltoman doxygen)
|
||||
_commit=6329a2498eb038f8a9537888280a62b00a93f68e # tags/v15.0^0
|
||||
source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git#commit=$_commit"
|
||||
'0001-disable-neon.patch')
|
||||
sha256sums=('SKIP'
|
||||
'7572bfc1a185f8b6f7757db217d35f9134128fc8cd047845f34acb17e2fe67d1')
|
||||
'a6fc3a127aa8523b9b88f53217aeae01fb1831f33e265b9e1e233c3db2a97cf2')
|
||||
|
||||
pkgver() {
|
||||
cd pulseaudio
|
||||
|
@ -38,10 +39,17 @@ prepare() {
|
|||
}
|
||||
|
||||
build() {
|
||||
arch-meson pulseaudio build \
|
||||
-D pulsedsp-location='/usr/\$LIB/pulseaudio' \
|
||||
-D stream-restore-clear-old-devices=true \
|
||||
local meson_options=(
|
||||
-D stream-restore-clear-old-devices=true
|
||||
-D pulsedsp-location='/usr/\$LIB/pulseaudio'
|
||||
-D udevrulesdir=/usr/lib/udev/rules.d
|
||||
-D bluez5-gstreamer=disabled
|
||||
-D elogind=disabled
|
||||
-D tcpwrap=disabled
|
||||
-D valgrind=disabled
|
||||
)
|
||||
|
||||
arch-meson pulseaudio build "${meson_options[@]}"
|
||||
meson compile -C build
|
||||
}
|
||||
|
||||
|
@ -80,7 +88,7 @@ package_pulseaudio() {
|
|||
done
|
||||
pulsever=${pulsever%%-*}
|
||||
|
||||
DESTDIR="$pkgdir" meson install -C build
|
||||
meson install -C build --destdir "$pkgdir"
|
||||
|
||||
cd "$pkgdir"
|
||||
|
||||
|
|
Loading…
Reference in a new issue