community/android-tools to 29.0.2-1

This commit is contained in:
Kevin Mihelich 2019-08-05 12:35:51 +00:00
parent 21a6c42644
commit 6d3e395d58
3 changed files with 25 additions and 10 deletions

View file

@ -8,7 +8,7 @@
buildarch=28
pkgname=android-tools
pkgver=29.0.1
pkgver=29.0.2
pkgrel=1
tag=platform-tools-$pkgver
pkgdesc='Android platform tools'
@ -23,6 +23,7 @@ conflicts=(fastboot adb)
_boringssl_commit=`curl https://android.googlesource.com/platform/external/boringssl/+/refs/tags/$tag/BORINGSSL_REVISION?format=TEXT | base64 -d`
source=(git+https://android.googlesource.com/platform/system/core#tag=$tag
git+https://android.googlesource.com/platform/system/extras#tag=$tag
git+https://android.googlesource.com/platform/system/tools/mkbootimg#tag=$tag
git+https://android.googlesource.com/platform/external/selinux#tag=$tag
git+https://android.googlesource.com/platform/external/f2fs-tools#tag=$tag
git+https://android.googlesource.com/platform/external/e2fsprogs#tag=$tag
@ -41,8 +42,9 @@ sha1sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'8510f5031c386c855f9be15cd8055237db290a33'
'16cf92e7ddbec79a672152a07837474ad8ad6356'
'SKIP'
'ff8613a331b9026f2f413768f88ccd10e26149bf'
'99a1618bd93af8ef3ff2cca893e950a0346021fe'
'b2ccf6dac3577d230f910e668ae70af6051fee46'
'bcebdf1e706a3c3da175234840c6ee4e13652012'
'7004dbd0c193668827174880de6f8434de8ceaee')
@ -73,7 +75,7 @@ build() {
package(){
install -m755 -d "$pkgdir"/usr/bin
install -m755 -t "$pkgdir"/usr/bin fastboot adb mke2fs.android e2fsdroid ext2simg avb/avbtool
install -Dm 755 core/mkbootimg/mkbootimg.py "$pkgdir"/usr/bin/mkbootimg
install -Dm 755 core/mkbootimg/unpack_bootimg.py "$pkgdir"/usr/bin/unpack_bootimg
install -Dm 755 mkbootimg/mkbootimg.py "$pkgdir"/usr/bin/mkbootimg
install -Dm 755 mkbootimg/unpack_bootimg.py "$pkgdir"/usr/bin/unpack_bootimg
install -Dm 644 bash_completion.fastboot "$pkgdir"/usr/share/bash-completion/completions/fastboot
}

View file

@ -72,6 +72,18 @@ index 81b8306436..b4f09caab8 100644
#include <sys/time.h>
#include <sys/sysmacros.h>
#include <sys/types.h>
diff --git a/adb/fdevent/fdevent.h b/adb/fdevent/fdevent.h
index ccb0c9221c..2424252f5d 100644
--- a/adb/fdevent/fdevent.h
+++ b/adb/fdevent/fdevent.h
@@ -20,6 +20,7 @@
#include <stddef.h>
#include <stdint.h>
+#include <atomic>
#include <chrono>
#include <deque>
#include <functional>
diff --git a/adb/sysdeps/posix/network.cpp b/adb/sysdeps/posix/network.cpp
index c5c227568f..99686f15fb 100644
--- a/adb/sysdeps/posix/network.cpp
@ -133,7 +145,7 @@ index f89168c0fc..da522019dc 100644
// For getprogname(3) or program_invocation_short_name.
#if defined(__ANDROID__) || defined(__APPLE__)
diff --git a/fastboot/fastboot.cpp b/fastboot/fastboot.cpp
index 39abc4a3b1..4bea3bc84b 100644
index 8923f409df..d245a577ff 100644
--- a/fastboot/fastboot.cpp
+++ b/fastboot/fastboot.cpp
@@ -58,9 +58,7 @@
@ -146,7 +158,7 @@ index 39abc4a3b1..4bea3bc84b 100644
#include <sparse/sparse.h>
#include <ziparchive/zip_archive.h>
@@ -1678,7 +1676,7 @@ int FastBootTool::Main(int argc, char* argv[]) {
@@ -1749,7 +1747,7 @@ int FastBootTool::Main(int argc, char* argv[]) {
setvbuf(stdout, nullptr, _IONBF, 0);
setvbuf(stderr, nullptr, _IONBF, 0);
} else if (name == "version") {
@ -193,7 +205,7 @@ index bffcb7e6e1..6b36a641a6 100644
#include <android-base/file.h>
#include <android-base/unique_fd.h>
diff --git a/libziparchive/zip_archive.cc b/libziparchive/zip_archive.cc
index f4b6c74f8c..6b3610cfe3 100644
index c95b03542e..ae8ebb93a4 100644
--- a/libziparchive/zip_archive.cc
+++ b/libziparchive/zip_archive.cc
@@ -30,6 +30,7 @@

View file

@ -77,7 +77,8 @@ adbdfiles = %w(
transport.cpp
transport_local.cpp
transport_usb.cpp
fdevent.cpp
fdevent/fdevent.cpp
fdevent/fdevent_poll.cpp
shell_service_protocol.cpp
)
libadbd = compile(expand("core/adb", adbdfiles), '-DPLATFORM_TOOLS_VERSION="\"$PLATFORM_TOOLS_VERSION\"" -DADB_HOST=1 -Icore/include -Icore/base/include -Icore/adb -Icore/libcrypto_utils/include -Iboringssl/include -Icore/diagnose_usb/include')
@ -175,7 +176,7 @@ fastbootfiles = %w(
main.cpp
fastboot_driver.cpp
)
libfastboot = compile(expand("core/fastboot", fastbootfiles), '-DPLATFORM_TOOLS_VERSION="\"$PLATFORM_TOOLS_VERSION\"" -D_GNU_SOURCE -D_XOPEN_SOURCE=700 -DUSE_F2FS -Icore/base/include -Icore/include -Icore/adb -Icore/libsparse/include -Icore/mkbootimg -Iextras/ext4_utils/include -Iextras/f2fs_utils -Icore/libziparchive/include -Icore/mkbootimg/include/bootimg -Icore/fs_mgr/liblp/include -Icore/diagnose_usb/include')
libfastboot = compile(expand("core/fastboot", fastbootfiles), '-DPLATFORM_TOOLS_VERSION="\"$PLATFORM_TOOLS_VERSION\"" -D_GNU_SOURCE -D_XOPEN_SOURCE=700 -DUSE_F2FS -Icore/base/include -Icore/include -Icore/adb -Icore/libsparse/include -Imkbootimg/include/bootimg -Iextras/ext4_utils/include -Iextras/f2fs_utils -Icore/libziparchive/include -Imkbootimg/include/bootimg/include/bootimg -Icore/fs_mgr/liblp/include -Icore/diagnose_usb/include')
fsmgrfiles = %w(
liblp/reader.cpp