mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/x265 to 2.9-1
This commit is contained in:
parent
f58a84b488
commit
6d40e8d4ad
2 changed files with 22 additions and 22 deletions
|
@ -1,4 +1,3 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
||||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||||
# Contributor: kfgz <kfgz@interia.pl>
|
# Contributor: kfgz <kfgz@interia.pl>
|
||||||
|
@ -6,31 +5,31 @@
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - patch to attempt fixing ARM hackery by bandwagoning developers
|
# - patch to attempt fixing ARM hackery by bandwagoning developers
|
||||||
# - retain 10/12 bit separation for AArch64
|
# - retain 10/12 bit separation for AArch64
|
||||||
# - upstream patch to fix ARM FTBFS
|
|
||||||
# - disable all ARM assembly - version 2.8 broke ARM support completely
|
# - disable all ARM assembly - version 2.8 broke ARM support completely
|
||||||
|
# - patch from upstream bug https://bitbucket.org/multicoreware/x265/issues/442
|
||||||
|
|
||||||
pkgname=x265
|
pkgname=x265
|
||||||
pkgver=2.8
|
pkgver=2.9
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='Open Source H265/HEVC video encoder'
|
pkgdesc='Open Source H265/HEVC video encoder'
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://bitbucket.org/multicoreware/x265'
|
url='https://bitbucket.org/multicoreware/x265'
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
depends=('gcc-libs')
|
depends=()
|
||||||
makedepends=('cmake' 'nasm')
|
makedepends=('cmake' 'mercurial' 'nasm')
|
||||||
provides=('libx265.so')
|
provides=('libx265.so')
|
||||||
source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz"
|
source=("hg+https://bitbucket.org/multicoreware/x265#tag=${pkgver}"
|
||||||
arm.patch
|
arm.patch
|
||||||
https://github.com/videolan/x265/commit/8911cbae1f7f868b213c5c0aa41cf827cdf367bb.patch)
|
enable512.diff)
|
||||||
sha256sums=('6e59f9afc0c2b87a46f98e33b5159d56ffb3558a49d8e3d79cb7fdc6b7aaa863'
|
sha256sums=('SKIP'
|
||||||
'fdd9113a015679652224f2d62c4bbbffe9a15bfef8c6a928aaf2fc57d1cd8fd8'
|
'd292976588ea1cb12f6371a2379fe7e22b93c18a16ea0a5acd1fbebab48988f2'
|
||||||
'edd298ac1be919d325e618a20231a0f84c783fbdcba30e0e2372f69f471bd1cd')
|
'bc812d10a7abbd1e5646c9bd43ab46339d1b69d1be752334120a0d12222f1e0c')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd x265_${pkgver}
|
cd x265
|
||||||
|
|
||||||
patch -p1 -i ../arm.patch
|
patch -p1 -i ../arm.patch
|
||||||
patch -p1 -i ../8911cbae1f7f868b213c5c0aa41cf827cdf367bb.patch
|
patch -p1 -i ../enable512.diff
|
||||||
[[ $CARCH == "aarch64" ]] && CFLAGS+=" -fPIC" && CXXFLAGS+=" -fPIC"
|
[[ $CARCH == "aarch64" ]] && CFLAGS+=" -fPIC" && CXXFLAGS+=" -fPIC"
|
||||||
[[ $CARCH != "aarch64" ]] && CONFIG="-DENABLE_ASSEMBLY=OFF"
|
[[ $CARCH != "aarch64" ]] && CONFIG="-DENABLE_ASSEMBLY=OFF"
|
||||||
|
|
||||||
|
@ -45,7 +44,7 @@ prepare() {
|
||||||
build() {
|
build() {
|
||||||
if [[ $CARCH == aarch64 ]]; then
|
if [[ $CARCH == aarch64 ]]; then
|
||||||
|
|
||||||
cd x265_${pkgver}/build-12
|
cd x265/build-12
|
||||||
|
|
||||||
cmake ../source \
|
cmake ../source \
|
||||||
-DCMAKE_INSTALL_PREFIX='/usr' \
|
-DCMAKE_INSTALL_PREFIX='/usr' \
|
||||||
|
@ -83,7 +82,7 @@ if [[ $CARCH == aarch64 ]]; then
|
||||||
|
|
||||||
else
|
else
|
||||||
|
|
||||||
cd x265_${pkgver}/build-8
|
cd x265/build-8
|
||||||
|
|
||||||
cmake ../source \
|
cmake ../source \
|
||||||
-DCMAKE_INSTALL_PREFIX='/usr' \
|
-DCMAKE_INSTALL_PREFIX='/usr' \
|
||||||
|
@ -94,7 +93,7 @@ fi
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd x265_${pkgver}/build-8
|
cd x265/build-8
|
||||||
|
|
||||||
make DESTDIR="${pkgdir}" install
|
make DESTDIR="${pkgdir}" install
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,7 +1,8 @@
|
||||||
|
Binary files a/.hg/dirstate and b/.hg/dirstate differ
|
||||||
diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
||||||
--- a/source/CMakeLists.txt 2016-12-22 22:57:39.000000000 -0700
|
--- a/source/CMakeLists.txt 2018-10-08 10:04:19.918015626 -0600
|
||||||
+++ b/source/CMakeLists.txt 2016-12-28 06:36:06.297232756 -0700
|
+++ b/source/CMakeLists.txt 2018-10-08 10:04:37.277342636 -0600
|
||||||
@@ -41,7 +41,7 @@
|
@@ -40,7 +40,7 @@
|
||||||
# System architecture detection
|
# System architecture detection
|
||||||
string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
|
string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
|
||||||
set(X86_ALIASES x86 i386 i686 x86_64 amd64)
|
set(X86_ALIASES x86 i386 i686 x86_64 amd64)
|
||||||
|
@ -10,7 +11,7 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
||||||
list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
|
list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
|
||||||
list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
|
list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
|
||||||
set(POWER_ALIASES ppc64 ppc64le)
|
set(POWER_ALIASES ppc64 ppc64le)
|
||||||
@@ -71,9 +71,17 @@
|
@@ -70,9 +70,17 @@
|
||||||
else()
|
else()
|
||||||
set(CROSS_COMPILE_ARM 0)
|
set(CROSS_COMPILE_ARM 0)
|
||||||
endif()
|
endif()
|
||||||
|
@ -30,7 +31,7 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
||||||
else()
|
else()
|
||||||
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
|
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
|
||||||
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
|
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
|
||||||
@@ -208,18 +216,6 @@
|
@@ -227,18 +235,6 @@
|
||||||
endif()
|
endif()
|
||||||
endif()
|
endif()
|
||||||
endif()
|
endif()
|
||||||
|
@ -50,8 +51,8 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
|
||||||
if(INTEL_CXX)
|
if(INTEL_CXX)
|
||||||
add_definitions(-prof-gen -prof-dir="${CMAKE_CURRENT_BINARY_DIR}")
|
add_definitions(-prof-gen -prof-dir="${CMAKE_CURRENT_BINARY_DIR}")
|
||||||
diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
|
diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
|
||||||
--- a/source/common/cpu.cpp 2016-12-22 22:57:39.000000000 -0700
|
--- a/source/common/cpu.cpp 2018-10-08 10:04:19.938014851 -0600
|
||||||
+++ b/source/common/cpu.cpp 2016-12-28 06:36:06.297232756 -0700
|
+++ b/source/common/cpu.cpp 2018-10-08 10:04:37.277342636 -0600
|
||||||
@@ -37,7 +37,7 @@
|
@@ -37,7 +37,7 @@
|
||||||
#include <machine/cpu.h>
|
#include <machine/cpu.h>
|
||||||
#endif
|
#endif
|
||||||
|
|
Loading…
Reference in a new issue