mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-armv7: resolve dmesg spam issue with rt2800usb on Trimslice
This commit is contained in:
parent
05b4568a74
commit
6d4145a18c
2 changed files with 48 additions and 1 deletions
44
core/linux-armv7/0003-squelch-rt2800usb-messages.patch
Normal file
44
core/linux-armv7/0003-squelch-rt2800usb-messages.patch
Normal file
|
@ -0,0 +1,44 @@
|
|||
commit 45cfc51681287482c8b9843a20d6b4d06555ff62
|
||||
Author: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||
Date: Fri Jan 31 13:18:09 2014 +0100
|
||||
|
||||
rt2x00: move frequent messages to debug level
|
||||
|
||||
On commit 28f2bce9f8bbf704c86f8c684337f82c51592c81 I make change that
|
||||
print various messages as default. This can cause flood of messages
|
||||
related to TX status timeout on some environments. I partially fixed
|
||||
problem on commit bb9c298f3193ac5b80e47b325c690700580b6bcf, but forgot
|
||||
to move two more messages to debug level.
|
||||
|
||||
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||
Acked-by: Gertjan van Wingerde <gwingerde@gmail.com>
|
||||
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
||||
|
||||
diff --git a/drivers/net/wireless/rt2x00/rt2800usb.c b/drivers/net/wireless/rt2x00/rt2800usb.c
|
||||
index caddc1b..14a90dd 100644
|
||||
--- a/drivers/net/wireless/rt2x00/rt2800usb.c
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2800usb.c
|
||||
@@ -125,9 +125,9 @@ static inline bool rt2800usb_entry_txstatus_timeout(struct queue_entry *entry)
|
||||
|
||||
tout = time_after(jiffies, entry->last_action + msecs_to_jiffies(100));
|
||||
if (unlikely(tout))
|
||||
- rt2x00_warn(entry->queue->rt2x00dev,
|
||||
- "TX status timeout for entry %d in queue %d\n",
|
||||
- entry->entry_idx, entry->queue->qid);
|
||||
+ rt2x00_dbg(entry->queue->rt2x00dev,
|
||||
+ "TX status timeout for entry %d in queue %d\n",
|
||||
+ entry->entry_idx, entry->queue->qid);
|
||||
return tout;
|
||||
|
||||
}
|
||||
@@ -566,8 +566,8 @@ static void rt2800usb_txdone(struct rt2x00_dev *rt2x00dev)
|
||||
queue = rt2x00queue_get_tx_queue(rt2x00dev, qid);
|
||||
|
||||
if (unlikely(rt2x00queue_empty(queue))) {
|
||||
- rt2x00_warn(rt2x00dev, "Got TX status for an empty queue %u, dropping\n",
|
||||
- qid);
|
||||
+ rt2x00_dbg(rt2x00dev, "Got TX status for an empty queue %u, dropping\n",
|
||||
+ qid);
|
||||
break;
|
||||
}
|
||||
|
|
@ -8,7 +8,7 @@ _srcname=linux-3.13
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=3.13.6
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
rcnrel=armv7-x11
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -21,6 +21,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
|||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${_srcname#linux-}"
|
||||
'0001-atags-add-support-for-marvell-uboot.patch'
|
||||
'0002-atags-retrieve-mac-addresses.patch'
|
||||
'0003-squelch-rt2800usb-messages.patch'
|
||||
'smile.patch'
|
||||
'mmc.patch'
|
||||
'config')
|
||||
|
@ -30,6 +31,7 @@ md5sums=('0ecbaf65c00374eb4a826c2f9f37606f'
|
|||
'SKIP'
|
||||
'3ad860d0d6daedc82091ea29c9730b95'
|
||||
'02cce6b8f88c4392f552b14d0bf2e71c'
|
||||
'8609ac79ba99320692c50481aabc6ed2'
|
||||
'15482d66eaaf0237f0cc6a61f36365b3'
|
||||
'911bffe9c261ca5b91dd0a083d99e81f'
|
||||
'4a75e2a8d76455756753841eb269e977')
|
||||
|
@ -46,6 +48,7 @@ prepare() {
|
|||
# mvebu patches
|
||||
patch -p1 -i ../0001-atags-add-support-for-marvell-uboot.patch
|
||||
patch -p1 -i ../0002-atags-retrieve-mac-addresses.patch
|
||||
patch -p1 -i ../0003-squelch-rt2800usb-messages.patch
|
||||
patch -p1 -i ../smile.patch
|
||||
patch -p1 -i ../mmc.patch
|
||||
|
||||
|
|
Loading…
Reference in a new issue