removed community/ghc

This commit is contained in:
Kevin Mihelich 2020-02-28 19:24:09 +00:00
parent 67f9740e6a
commit 6d89c93034
7 changed files with 0 additions and 333 deletions

View file

@ -1,45 +0,0 @@
From d1964b7fc347d56b595008027d44af745bfc5750 Mon Sep 17 00:00:00 2001
From: Guillaume GARDET <guillaume.gardet@opensuse.org>
Date: Fri, 18 May 2018 08:56:28 +0200
Subject: [PATCH] llvm-targets: Add armv6l-unknown-linux-gnueabihf and
armv7l-unknown-linux-gnueabihf
---
llvm-targets | 4 +++-
utils/llvm-targets/gen-data-layout.sh | 2 +-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/llvm-targets b/llvm-targets
index 3c9da1e571..b67ee6ccfa 100644
--- a/llvm-targets
+++ b/llvm-targets
@@ -3,10 +3,12 @@
,("x86_64-unknown-windows", ("e-m:w-i64:64-f80:128-n8:16:32:64-S128", "x86-64", ""))
,("arm-unknown-linux-gnueabihf", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "arm1176jzf-s", "+strict-align"))
,("armv6-unknown-linux-gnueabihf", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "arm1136jf-s", "+strict-align"))
+,("armv6l-unknown-linux-gnueabihf", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "arm1176jzf-s", "+strict-align"))
,("armv7-unknown-linux-gnueabihf", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "generic", ""))
+,("armv7a-unknown-linux-gnueabi", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "generic", ""))
+,("armv7l-unknown-linux-gnueabihf", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "generic", ""))
,("aarch64-unknown-linux-gnu", ("e-m:e-i8:8:32-i16:16:32-i64:64-i128:128-n32:64-S128", "generic", "+neon"))
,("aarch64-unknown-linux", ("e-m:e-i8:8:32-i16:16:32-i64:64-i128:128-n32:64-S128", "generic", "+neon"))
-,("armv7a-unknown-linux-gnueabi", ("e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64", "generic", ""))
,("i386-unknown-linux-gnu", ("e-m:e-p:32:32-f64:32:64-f80:32-n8:16:32-S128", "pentium4", ""))
,("i386-unknown-linux", ("e-m:e-p:32:32-f64:32:64-f80:32-n8:16:32-S128", "pentium4", ""))
,("x86_64-unknown-linux-gnu", ("e-m:e-i64:64-f80:128-n8:16:32:64-S128", "x86-64", ""))
diff --git a/utils/llvm-targets/gen-data-layout.sh b/utils/llvm-targets/gen-data-layout.sh
index 6f2aafc65d..d6e78ee41c 100755
--- a/utils/llvm-targets/gen-data-layout.sh
+++ b/utils/llvm-targets/gen-data-layout.sh
@@ -18,7 +18,7 @@
# Target sets
WINDOWS_x86="i386-unknown-windows i686-unknown-windows x86_64-unknown-windows"
-LINUX_ARM="arm-unknown-linux-gnueabihf armv6-unknown-linux-gnueabihf armv7-unknown-linux-gnueabihf aarch64-unknown-linux-gnu aarch64-unknown-linux armv7a-unknown-linux-gnueabi"
+LINUX_ARM="arm-unknown-linux-gnueabihf armv6-unknown-linux-gnueabihf armv6l-unknown-linux-gnueabihf armv7-unknown-linux-gnueabihf aarch64-unknown-linux-gnu aarch64-unknown-linux armv7a-unknown-linux-gnueabi armv7l-unknown-linux-gnueabihf"
LINUX_x86="i386-unknown-linux-gnu i386-unknown-linux x86_64-unknown-linux-gnu x86_64-unknown-linux"
ANDROID="armv7-unknown-linux-androideabi aarch64-unknown-linux-android"
QNX="arm-unknown-nto-qnx-eabi"
--
2.16.2

View file

@ -1,194 +0,0 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Vesa Kaihlavirta <vesa@archlinux.org>
# Contributor: Thomas Dziedzic <gostrc@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - depend on llvm50, make -j1
buildarch=4
# Special note for devs looking to upgrade this package:
# ghc places a unique hash for each library when it is built.
# Libraries depend on versions specified by those hashes.
# This implies that all libraries need to be rebuilt when ghc is rebuilt.
shopt -s extglob
pkgbase=ghc
pkgname=(ghc-libs ghc ghc-static)
pkgver=8.8.2
pkgrel=1
pkgdesc='The Glasgow Haskell Compiler'
arch=('x86_64')
url='https://www.haskell.org/ghc/'
license=('custom')
makedepends=('ghc-static' 'perl' 'libxslt' 'docbook-xsl' 'python-sphinx' 'haskell-hscolour'
'texlive-bin' 'texlive-latexextra' 'ttf-dejavu' 'alex' 'happy' 'time')
source=("https://downloads.haskell.org/~ghc/$pkgver/$pkgbase-${pkgver}-src.tar.xz"
ghc-rebuild-doc-index.hook ghc-register.hook ghc-unregister.hook
0001-llvm-targets-Add-armv6l-unknown-linux-gnueabihf-and-.patch)
noextract=("$pkgbase-${pkgver}-src.tar.xz")
sha512sums=('11eec0bc03254ea848a5c86bc3e2da317801a1227dd91406a157e11cb675891d77d61177b740b6df88bd823063f6cb2af5a928a7540e25392d9d0769ea121069'
'afb119e4f665770c5704b97034d2488504eaa7afcddca2fb6b554079921cd2330599bcb5c36669f0d0e7856dd99ae1deeca1b0e97e2371a783f26e5ef9776ba9'
'bd65a369b618ec9bee46c028c2b6acff8f883f60f6cad6e5be8561fbcef6118278abec11bb86f9e6f92cb2e05ad74ec54611c1788e8ed95187d0091fcbbf8767'
'd4bfdd4c8ad9ac612cf187fec150850e9f4068a4a4202503c00dba07ba26f804bc11d7181249f7e3452d7ede60dc5dedea34e73fdb584ac2953068b51c6fd5ad'
'0d46375b5d864d8e8268becf52ab66d9d51e459a1ff7ef71ca77c4d8bc65e2952b29be6acc55750aaab07c52fcb9e9bddc279d7292696fcfc578a44e5eca16a3')
prepare() {
# Need to extract this tarball with a UTF-8 locale instead of a chroot's "C"
# locale; otherwise we get:
# bsdtar: Pathname can't be converted from UTF-8 to current locale.
LANG=en_US.UTF-8 bsdtar xf $pkgbase-${pkgver}-src.tar.xz
cd ghc-$pkgver
cp mk/build.mk{.sample,}
sed -i '/defined(STAGE)/d' includes/MachDeps.h
sed -i '1iBuildFlavour = perf' mk/build.mk
patch -p1 -i ../0001-llvm-targets-Add-armv6l-unknown-linux-gnueabihf-and-.patch
}
build() {
cd ghc-$pkgver
./configure \
--prefix=/usr \
--docdir=/usr/share/doc/ghc \
--with-system-libffi \
--with-ffi-includes=$(pkg-config --variable=includedir libffi)
make -j1
}
package_ghc-static() {
pkgdesc='The Glasgow Haskell Compiler - Static Libraries and Documentation'
depends=('ghc')
cd ghc-$pkgver
make DESTDIR="$pkgdir" -j1 install
mv "$pkgdir"/usr/lib/ghc-$pkgver/package.conf.d "$srcdir"/static-package.conf.d
find "$pkgdir"/usr/lib ! \( -name "*.a" -o -name "*.o" -o -name "*.p_o" -o -name "*.p_hi" -o -name "*.hi" \) -type f -delete
find "$pkgdir"/usr/lib -type d -empty -delete
mv "$srcdir"/static-package.conf.d "$pkgdir"/usr/lib/ghc-$pkgver/
rm -r "$pkgdir"/usr/bin "$pkgdir"/usr/share/man
install -Dm644 "$srcdir"/ghc-rebuild-doc-index.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-rebuild-doc-index.hook
}
package_ghc() {
pkgdesc='The Glasgow Haskell Compiler'
provides=("haskell-ghc=$pkgver")
replaces=("haskell-ghc")
depends=('gcc' 'ghc-libs')
cd ghc-$pkgver
make DESTDIR="$pkgdir" -j1 install
# Remove static libs
find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.o" -o -name "*.p_o" -o -name "*.p_hi" -o -name "*.hi" \) -delete
# ghc-pkg is in ghc-libs
rm "$pkgdir"/usr/lib/ghc-$pkgver/bin/ghc-pkg*
rm "$pkgdir"/usr/bin/ghc-pkg*
(cd "$pkgdir"/usr/lib/ghc-$pkgver; rm -r !(bin|ghc-$pkgver))
# docs moved to ghc-static
rm -r "$pkgdir"/usr/share/doc
install -Dm644 utils/completion/ghc.bash \
"$pkgdir/usr/share/bash-completion/completions/ghc"
}
package_ghc-libs() {
pkgdesc='The Glasgow Haskell Compiler - Dynamic Libraries'
install='ghc.install'
depends=('gmp' 'libffi' 'perl' 'llvm50')
provides=('haskell-array=0.5.4.0'
'haskell-base=4.13.0.0'
'haskell-binary=0.8.7.0'
'haskell-bytestring=0.10.10.0'
'haskell-containers=0.6.2.1'
'haskell-deepseq=1.4.4.0'
'haskell-directory=1.3.4.0'
'haskell-filepath=1.4.2.1'
'haskell-ghc-boot=8.8.2'
'haskell-ghc-boot-th=8.8.2'
'haskell-ghc-compact=0.1.0.0'
'haskell-ghc-heap=8.8.2'
'haskell-ghc-prim=0.5.3'
'haskell-haskeline=0.7.5.0'
'haskell-hpc=0.6.0.3'
'haskell-integer-gmp=1.0.2.0'
'haskell-libiserv=8.8.2'
'haskell-mtl=2.2.2'
'haskell-parsec=3.1.14.0'
'haskell-pretty=1.1.3.6'
'haskell-process=1.6.7.0'
'haskell-stm=2.5.0.0'
'haskell-template-haskell=2.15.0.0'
'haskell-terminfo=0.4.1.4'
'haskell-text=1.2.4.0'
'haskell-time=1.9.3'
'haskell-transformers=0.5.6.2'
'haskell-unix=2.7.2.2'
'haskell-xhtml=3000.2.2.1'
'haskell-cabal=3.0.1.0')
replaces=('haskell-array'
'haskell-base'
'haskell-binary'
'haskell-bytestring'
'haskell-containers'
'haskell-deepseq'
'haskell-directory'
'haskell-filepath'
'haskell-ghc-boot'
'haskell-ghc-boot-th'
'haskell-ghc-compact'
'haskell-ghc-heap'
'haskell-ghc-prim'
'haskell-haskeline'
'haskell-hpc'
'haskell-integer-gmp'
'haskell-libiserv'
'haskell-mtl'
'haskell-parsec'
'haskell-pretty'
'haskell-process'
'haskell-stm'
'haskell-template-haskell'
'haskell-terminfo'
'haskell-text'
'haskell-time'
'haskell-transformers'
'haskell-unix'
'haskell-xhtml'
'haskell-cabal')
provides+=("haskell-ghci=$pkgver")
conflicts+=('haskell-ghci')
cd ghc-$pkgver
make DESTDIR="$pkgdir" -j1 install
# Remove static libs
find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.o" -o -name "*.p_o" -o -name "*.p_hi" -o -name "*.hi" \) -delete
# ghc library and other exes are in the ghc package
rm -r "$pkgdir"/usr/lib/ghc-$pkgver/ghc-$pkgver
(cd "$pkgdir"/usr/lib/ghc-$pkgver/bin; rm !(ghc-pkg*))
(cd "$pkgdir"/usr/bin; rm !(ghc-pkg*))
# docs moved to ghc-static
rm -r "$pkgdir"/usr/share/{man,doc}
install -Dm644 "$srcdir"/ghc-register.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-register.hook
install -Dm644 "$srcdir"/ghc-unregister.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-unregister.hook
install -dm755 "$pkgdir"/usr/share/haskell/{register,unregister}
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}

View file

@ -1,14 +0,0 @@
[Trigger]
Type = File
Operation = Install
Operation = Upgrade
Operation = Remove
Target = usr/share/doc/ghc/html/libraries/*
Target = !usr/share/doc/ghc/html/libraries/index.html
[Action]
Description = Rebuilding Haskell doc index...
When = PostTransaction
Exec = /bin/bash -c "cd /usr/share/doc/ghc/html/libraries && ./gen_contents_index"
Depends = ghc-static
Depends = bash

View file

@ -1,12 +0,0 @@
[Trigger]
Type = File
Operation = Install
Operation = Upgrade
Target = usr/share/haskell/register/*.sh
[Action]
Description = Registering Haskell modules...
When = PostTransaction
Exec = /bin/sh -c 'while read -r f; do /bin/sh "/$f" >>/tmp/haskell-register.log 2>&1 ; done'
Depends = ghc-libs
NeedsTargets

View file

@ -1,12 +0,0 @@
[Trigger]
Type = File
Operation = Upgrade
Operation = Remove
Target = usr/share/haskell/unregister/*.sh
[Action]
Description = Unregistering Haskell modules...
When = PreTransaction
Exec = /bin/sh -c 'while read -r f; do /bin/sh "/$f" >>/tmp/haskell-register.log 2>&1 ; done'
Depends = ghc-libs
NeedsTargets

View file

@ -1,12 +0,0 @@
pre_upgrade() {
if [[ ${1%-*} != ${2%-*} ]]; then
[[ -d /usr/share/haskell ]] && find /usr/share/haskell -maxdepth 2 -name 'unregister.sh' -exec {} \;
fi
}
post_upgrade() {
if [[ ${1%-*} != ${2%-*} ]]; then
echo '==> If you have custom packages installed, you will need to reinstall them now.'
echo "==> See /usr/lib/ghc-${2%-*}/package.conf.d/ for a tentative list of affected packages."
fi
}

View file

@ -1,44 +0,0 @@
#!/bin/bash
. PKGBUILD
if [[ ! -d src/ghc-${pkgver}/libraries ]]; then
echo "error: no directory src/ghc-${pkgver}/libraries: You must extract the source tarball under src/"
exit 1
fi
declare -A exclude
# no Win32 cause we're not building on windows
exclude['Win32']=1
# no integer-simple because we use integer-gmp
exclude['integer-simple']=1
# extract excluded libraries from ghc.mk
for exclude_pkg in $(sed 's/PKGS_THAT_ARE_INTREE_ONLY := //p' -n src/ghc-${pkgver}/ghc.mk); do
exclude[${exclude_pkg}]=1
done
cd src/ghc-${pkgver}/libraries
# $1 is the name of the variable
# $2 is the string for the test, either '=' or '<'
print_var() {
printf " $1=("
for path in $(ls ./*/*.cabal ./containers/containers/*.cabal); do
dirname=$(echo $path | awk -F '/' '{ print $2 }')
cabalfile=$(echo $path | awk -F '/' '{ print $3 }')
cabalname=$(basename $cabalfile .cabal)
[[ ${exclude[${dirname}]} ]] && continue
version=$(awk 'tolower($0) ~ /^version:/ {print $2 }' $path)
printf "'haskell-$cabalname"
[[ -n "$2" ]] && printf "$2$version"
printf "'\n "
done
# also add cabal
version=$(awk 'tolower($0) ~ /^version:/ { print $2 }' Cabal/Cabal/Cabal.cabal)
printf "'haskell-cabal"
[[ -n "$2" ]] && printf "$2$version"
printf "')\n"
}
print_var 'provides' '='
print_var 'replaces'