extra/firefox: fix

This commit is contained in:
Kevin Mihelich 2022-07-07 03:18:27 +00:00
parent a9928d5e87
commit 6da804f402
2 changed files with 0 additions and 29 deletions

View file

@ -30,14 +30,12 @@ options=(!emptydirs !makeflags !strip !lto !debug)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
cbindgen-0.24.0.diff zstandard-0.18.0.diff
build-arm-libopus.patch
bug1173070.patch
$pkgname.desktop identity-icons-brand.svg)
sha256sums=('7bba6ffd6e8e42d5c38aa2a453f5fa30dfc9ef150f2175aa0625edb68fddae70'
'SKIP'
'4628d136c3beada292e83cd8e89502cac4aa3836851b34259a665582a7713978'
'a6857ad2f2e2091c6c4fdcde21a59fbeb0138914c0e126df64b50a5af5ff63be'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'2243d3d3f57ba504e81ef1cdcc7b351086e9ba03a8e42a73ddf060523fcfda3e'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -133,7 +131,6 @@ END
export LDFLAGS+=" -Wl,--no-keep-memory"
export RUSTFLAGS="-Cdebuginfo=0"
patch -p1 -i ../build-arm-libopus.patch
patch -p0 -i ../bug1173070.patch
}
build() {

View file

@ -1,26 +0,0 @@
In file included from Unified_cpp_accessible_html0.cpp:29:
In file included from accessible/html/HTMLImageMapAccessible.cpp:14:
In file included from layout/generic/nsImageFrame.h:17:
In file included from ../.build/dist/include/nsDisplayList.h:48:
In file included from ../.build/dist/include/nsCSSRenderingBorders.h:20:
In file included from ../.build/dist/include/gfxUtils.h:23:
In file included from ../.build/dist/include/mozilla/webrender/WebRenderTypes.h:11:
In file included from ../.build/dist/include/mozilla/webrender/webrender_ffi.h:103:
../.build/dist/include/mozilla/webrender/webrender_ffi_generated.h:24:33: error: redefinition of 'ROOT_CLIP_CHAIN'
constexpr static const uint64_t ROOT_CLIP_CHAIN = ~0;
^
../.build/dist/include/mozilla/webrender/webrender_ffi.h:75:16: note: previous definition is here
const uint64_t ROOT_CLIP_CHAIN = ~0;
^
--- gfx/webrender_bindings/webrender_ffi.h.orig 2022-06-08 21:06:36 UTC
+++ gfx/webrender_bindings/webrender_ffi.h
@@ -72,8 +72,6 @@ using WrPipelineIdEpochs = nsTArray<WrPipelineIdAndEpo
struct WrPipelineIdAndEpoch;
using WrPipelineIdEpochs = nsTArray<WrPipelineIdAndEpoch>;
-const uint64_t ROOT_CLIP_CHAIN = ~0;
-
} // namespace wr
} // namespace mozilla