mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox to 98.0-1
This commit is contained in:
parent
2f79560ec6
commit
6e9069602a
2 changed files with 2 additions and 64 deletions
|
@ -1,57 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Mon, 25 Mar 2019 20:30:11 +0100
|
||||
Subject: [PATCH] Use remoting name for GDK application names
|
||||
|
||||
---
|
||||
toolkit/xre/nsAppRunner.cpp | 6 +-----
|
||||
widget/gtk/nsAppShell.cpp | 12 +++++-------
|
||||
2 files changed, 6 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||
index ce001e93821f..3be817c5cbd5 100644
|
||||
--- a/toolkit/xre/nsAppRunner.cpp
|
||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||
@@ -4348,11 +4348,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||
// consistently.
|
||||
|
||||
// Set program name to the one defined in application.ini.
|
||||
- {
|
||||
- nsAutoCString program(gAppData->name);
|
||||
- ToLowerCase(program);
|
||||
- g_set_prgname(program.get());
|
||||
- }
|
||||
+ g_set_prgname(gAppData->remotingName);
|
||||
|
||||
// Initialize GTK here for splash.
|
||||
|
||||
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
|
||||
index c8bbd9a373f5..a6a2186f20fb 100644
|
||||
--- a/widget/gtk/nsAppShell.cpp
|
||||
+++ b/widget/gtk/nsAppShell.cpp
|
||||
@@ -27,6 +27,8 @@
|
||||
# include "nsIObserverService.h"
|
||||
#endif
|
||||
#include "gfxPlatform.h"
|
||||
+#include "nsAppRunner.h"
|
||||
+#include "mozilla/XREAppData.h"
|
||||
#include "ScreenHelperGTK.h"
|
||||
#include "HeadlessScreenHelper.h"
|
||||
#include "mozilla/widget/ScreenManager.h"
|
||||
@@ -257,13 +259,9 @@ nsresult nsAppShell::Init() {
|
||||
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
|
||||
//
|
||||
// Only bother doing this for the parent process, since it's the one
|
||||
- // creating top-level windows. (At this point, a child process hasn't
|
||||
- // received the list of registered chrome packages, so the
|
||||
- // GetBrandShortName call would fail anyway.)
|
||||
- nsAutoString brandName;
|
||||
- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
|
||||
- if (!brandName.IsEmpty()) {
|
||||
- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
|
||||
+ // creating top-level windows.
|
||||
+ if (gAppData) {
|
||||
+ gdk_set_program_class(gAppData->remotingName);
|
||||
}
|
||||
}
|
||||
}
|
|
@ -10,7 +10,7 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=97.0.2
|
||||
pkgver=98.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=(x86_64)
|
||||
|
@ -29,11 +29,9 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
|
|||
options=(!emptydirs !makeflags !strip !lto !debug)
|
||||
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
|
||||
build-arm-libopus.patch
|
||||
0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
$pkgname.desktop identity-icons-brand.svg)
|
||||
sha256sums=('c9f127741beabde78b021dc95b1740259d01677d461400682cb30e072126f075'
|
||||
sha256sums=('fd0a4c11d007d9045706667eb0f99f9b7422945188424cb937bfef530cb6f4dd'
|
||||
'SKIP'
|
||||
'8de6c0ecc70d2763936be6df4b91a3d2e806765bf510f987d6f2ffa2377c3f01'
|
||||
'5ead90994f91bed3231c2661977c69fc276cfbe278a1ab904daa544c9455ff42'
|
||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
|
||||
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
|
||||
|
@ -56,9 +54,6 @@ prepare() {
|
|||
mkdir mozbuild
|
||||
cd firefox-$pkgver
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
||||
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
|
Loading…
Reference in a new issue