mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/percona-server: fix
This commit is contained in:
parent
c768e1facb
commit
6ea460fbf4
2 changed files with 31 additions and 2 deletions
|
@ -0,0 +1,25 @@
|
|||
From aa67bb2825b9c1b8e09c07b69c723c6ed5d3767e Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 31 Dec 2018 10:03:22 -0700
|
||||
Subject: [PATCH] fix LF_PINS padding calculation
|
||||
|
||||
---
|
||||
include/lf.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/lf.h b/include/lf.h
|
||||
index 973b84cf..9c893c3a 100644
|
||||
--- a/include/lf.h
|
||||
+++ b/include/lf.h
|
||||
@@ -88,7 +88,7 @@ struct LF_PINS {
|
||||
std::atomic<uint64> link;
|
||||
/* we want sizeof(LF_PINS) to be 64 to avoid false sharing */
|
||||
#if 2 * 8 + SIZEOF_CHARP * (LF_PINBOX_PINS + 2) != 64
|
||||
- char pad[64 - sizeof(uint32) * 2 - sizeof(void *) * (LF_PINBOX_PINS + 2)];
|
||||
+ char pad[64 - sizeof(uint64) * 2 - sizeof(void *) * (LF_PINBOX_PINS + 2)];
|
||||
#endif
|
||||
};
|
||||
|
||||
--
|
||||
2.19.2
|
||||
|
|
@ -3,6 +3,7 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - drop numactl makedepend, don't build with NUMA
|
||||
# - disable epoll on aarch64
|
||||
# - patch to fix padding calculation
|
||||
|
||||
pkgbase=percona-server
|
||||
pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
|
||||
|
@ -21,14 +22,16 @@ source=("https://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona
|
|||
'mysql-user.conf'
|
||||
'build-hostname.patch'
|
||||
'no-werror.patch'
|
||||
'rocksdb-systemlibs.patch')
|
||||
'rocksdb-systemlibs.patch'
|
||||
'0001-fix-LF_PINS-padding-calculation.patch')
|
||||
sha256sums=('ab00626775b85ea506c1d992d66acee50f0bfbde54b830731f61652e87ff93da'
|
||||
'8aa4e330c870ef50a896634c931adf468b21f8a69b77007e45c444151229f665'
|
||||
'b467b04d6d06152b2abc33f2a6de63fef0fc922dd5119d2ee1d07d3c1a489731'
|
||||
'e638a2657085f15b6728f43c1fd6aa551b27608fbf6b435e33afd3606a0cfb0e'
|
||||
'1537fdbb92dd1c135c1eb9f4d10c44fd02e652db66c933d731990a1196f1397c'
|
||||
'fe1cb2b079c56ff0f827c7dfb25d004b2190410406820c490dc6152cfe392b70'
|
||||
'38f1acce8d8eff8167f1defcd4ce7063e67beeb7ab67bbf15ba5630290d00b71')
|
||||
'38f1acce8d8eff8167f1defcd4ce7063e67beeb7ab67bbf15ba5630290d00b71'
|
||||
'aa5e960625843b061f47c32b4a267fab1115667b8b7d1ce7ec952efe42eb77af')
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$_pkgver
|
||||
|
@ -37,6 +40,7 @@ prepare() {
|
|||
patch -p1 -i "$srcdir"/build-hostname.patch
|
||||
patch -p1 -i "$srcdir"/no-werror.patch
|
||||
# patch -p1 -i "$srcdir"/rocksdb-systemlibs.patch
|
||||
patch -p1 -i "$srcdir"/0001-fix-LF_PINS-padding-calculation.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue